Table of Contents
Introducing *Theorist (LMM)*

What is Theorist (LMM)? 2
How to Use this Guide 3
Installing on a Macintosh 4
Installing on Windows 8
Writing Conventions 11
A First Example 14
What is MathView?

MathView is a program for doing mathematics. More formally, MathView is a Computer Algebra System, meaning it can manipulate mathematical equations and expressions in a symbolic or algebraic manner. This feature sets MathView apart from other programs or, for that matter, most calculators, which require you to use numerical values.

MathView is different from other Computer Algebra Systems because of its unique graphical interface and the way it displays both inputs and outputs. When you enter equations, MathView displays the inputs in real mathematical notation, as opposed to a command-line display. After you manipulate equations and MathView generates the answer, the answer also is displayed in real mathematical notation.

MathView allows you to manipulate equations: by using menu selections; by clicking on Palette icons; or by invoking command key equivalents. Take, for example, the following problem where the goal is to solve for \( y \), and then generate a graph.

You solve by first selecting \( y \), and then clicking on the Isolate icon (on the top row of the Palette).

\[
-2x = -\sin(x^3) - x^2 + y
\]

Select \( y \) and click on Isolate

MathView solves the equation for \( y \).

\[
\bigtriangleup y = \sin(x^3) + x^2 - 2x \quad \text{Isolate}
\]

Graphing the equation is as easy as selecting it and clicking on the linear graph icon on the Palette.

MathView generates the graph automatically.

You can save or print your MathView documents, send them via e-mail to a colleague that uses a different platform, or copy parts of them to other documents. In addition, you can annotate your workspace with words and pictures as well as produce animations.
How to Use this Guide

The objective of this guide is to show you how to use MathView through examples. The guide starts out showing how to install the program and then presents a comprehensive example (see “Starting Example #1” on page 16). This example is for everyone, even for those who do not like to read manuals. It gives you a good first look at MathView, and provides a foundation for further exploration. This example may be all that you require; if so, you can use the remainder of the guide as a reference. For some, the reading and working of the examples which remain will be the way to go.

After the first example, the chapter called Preliminaries (page 27) covers the most important and basic MathView manipulations and procedures.

After Preliminaries, the approach changes. Starting with the chapter called Functions (page 97), the guide introduces MathView manipulations by including them in familiar mathematical subjects. Each section starts with a list of MathView skills and commands that the section features along with a short introduction. The chapter then presents examples demonstrating those skills.

After you have mastered the basics of MathView, you will find the table of contents, the appendix, and the index valuable guides in directing you. If you have a question about the use of a menu or palette item, go to the index and find where in the guide an example demonstrates the skill.

Most of the examples are of an analytical nature, with little real world application. For example, you will look at slope as a subject in its own right, without discussion of its application in the areas of velocity and acceleration. The guide, for the most part, does not teach the mathematics, but how to use MathView to solve mathematical problems.

• A bullet precedes the steps you are to follow in examples. Commentary is formatted like the rest of this page.

MathView is a mathematics engine, in the same way some consider a spreadsheet program an accounting engine. Both start out with a blank document where you enter problems and use the program tools to solve those problems. MathView can help you solve all but the most advanced mathematics. You can use it for mathematics curriculums found in high schools and all the way through most undergraduate programs; if you are a scientist or an engineer you will find MathView an invaluable tool.

MathView has many powerful tools, unavailable in other programs, that can help you understand the math. Your imagination is your only limitation.

Besides this guide, many MathView resources are available to you. Several books on the use of the program are available, and if you can connect to on-line services, you will find a network of people and resources available that can enhance the usefulness of the program. To find updated information, connect to the Waterloo Maple web-site (http://www.mathview.com).

Many have said that, in this computer age, learning and using mathematics will never be the same. Once you learn how to use MathView, you will see why.
Introducing MathView

Installing on a Macintosh

The following preparation instructions apply to all Macintosh System versions. Do not follow these instructions if you are using a computer with Microsoft Windows. See page 8.

Serial Number

Please take note of the serial number on the cover of the CD and on your Registration Card. You need this number to install the program and when upgrading.

System Requirements

- MathView works on a Macintosh Plus (68030 processor), or later model Macintosh. (An older Macintosh upgraded to the equivalent of a Plus is satisfactory.)
- The minimum memory requirement for the MathView program alone is 2.0 Mb RAM, although 3.0 Mb is suggested.
- You must have a hard disk with at least 3 Mb of free space for MathView and its related files.
- MathView is supported on System 7.1.1 or later.

Symbol Font and Greek Letters

In order for you to use Greek letters and other symbols in equations, you must have the Symbol font installed in your System. The Symbol font comes with all of Apple Computer’s system versions. Follow the Macintosh documentation to learn how to install it on your System.

MathView Application Installer

All you have to do to install MathView onto your computer is to double-click on the installer icon (called MathView Installer). The installer will check for the type of CPU you are using and install the appropriate version.

Two dialogs will open in order below. When you click on the first one, the installer will start its process. The second dialog tells you how much disk space the program will take up on your disk. Click on the install button or press .

There is another installer, the MathView Internet Installer. This file is discussed in the section; “MathView and the Internet” on page 213.
Installing on a Macintosh

The installer will open the following dialog box, giving you the opportunity to choose the location on your disk of the MathView folder.

After you have chosen the location and have clicked on the Install button or pressed [Enter], the installation will proceed. The following progress box will display on your screen as the installer expands the program.

The next box that opens is the personalization dialog. Fill in your name and your organization in the appropriate boxes, along with your serial number. Enter the rest of your serial number exactly as it appears on your registration card. Click on the OK button or press [Enter].

Warning: You must have a name and organization with at least 6 characters.

The MathView installer will close down and unlock the program. If you type in the wrong serial number or do not use names with at least six letters in them, you will be alerted and the program will close down. Open the program back up, by double-clicking on the MathView program icon, and enter the information again.
Introducing MathView

Web-Browser Plugins
There is an internet browser plug-in called MathView Internet on the MathView CD. MathView™ Internet is a web-browser plug-in designed for use with browsers such as Netscape™ Navigator, Microsoft Internet Explorer, or Cyberdog. To install, follow the instructions in the ReadMe file contained in the folder labelled “MathView™ Internet”. See “MathView and the Internet” on page 213 for more information.

Notebooks Folder
The folder called Notebooks which the installer places in your MathView folder contains several special notebooks for your use. They contain examples and are configured to special topics.

New Notebook
The document called New Notebook is a MathView file which acts as a type of stationery pad. Each time you open MathView by double-clicking on the program icon, this specially configured file will open as an Untitled document. Also when you choose File ➤ New Notebook, this file will open as an Untitled document.

Using the Application
To open the MathView application from the Finder, double-click on the MathView icon.

Closing the Application
To stop using MathView, choose Quit from the File menu. MathView may ask you to save open files.

Increasing Application Memory Size
To create large notebooks and QuickTime animations, you must increase the MathView application memory size. First, close MathView. Now, select the application in the Finder and choose Get Info from the File menu to bring up the Info dialog.

This dialog looks slightly different under different System versions.
Installing on a Macintosh

The box in the lower right hand corner labelled “Preferred size” specifies the amount of memory you want available to the application. Enter the number of kilobytes you prefer and close the window.

<table>
<thead>
<tr>
<th>Memory Requirements</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Suggested size:</td>
<td>2965  K</td>
</tr>
<tr>
<td>Minimum size:</td>
<td>2465  K</td>
</tr>
<tr>
<td>Preferred size:</td>
<td>2965  K</td>
</tr>
</tbody>
</table>
Introducing MathView

Installing on Windows

The following preparation instructions apply to computer systems with Microsoft Windows. Do not follow these instructions if you are using a Macintosh computer (see page 4).

Serial Number

Please take note of the serial number on the cover of the CD and on your Registration Card. You need this number to install the program and when upgrading.

System Requirements

• To run MathView, you must have a computer with an 80386 or later CPU running Microsoft Windows (version 3.1 or later in enhanced mode), Windows 95, or Windows NT.
• You must make at least 2 Mb of RAM and 3 Mb of free hard disk space available for MathView and its related files.

Symbol Font and Greek Letters

In order for you to use Greek letters and other symbols in your equations, you must install the Symbol font for use with Windows. All Microsoft Windows versions have the Symbol font.

Follow your Windows documentation to learn how to install the font on your system.

Installing MathView on a Windows System

These instructions show screen shots of a Windows 95 installation. They also assume the hard drive is the c: volume and the CD drive is the d: drive.

Insert the CD into the drive.

With your computer currently running Windows, close any open applications. From the Windows Program Manager’s File menu (Windows 3.1 or Windows NT), or the Start menu (Windows 95), choose Run. In the Command Line box (Windows 3.1 or Windows NT), or the Open box (Windows 95), type d:\install.exe

Using the Install Program

The Install program starts up and shows the following dialog.
Installing on Windows

The installer will create a new directory named MathView at the path the dialog specifies. If you want a different name or a different directory, type a new path-name in the box.

**Exit Install**

If you do not wish to install MathView at this time, choose Exit Install to leave the install program and return to Windows. If you stop the installation process, no files will be installed on your disk.

**Continue Install**

Click Continue to install MathView.

**Copying Files**

When you continue with the installation, the install program decompresses and copies various files to the specified directory and informs you of its progress.

**Creating a Group**

After you copy the files to your hard disk, the Install program asks whether you want to create a MathView group or skip it.

You may type another name for the group.

Unless you are re-installing MathView and already have a MathView group, click Create.

**Exiting the Installer**

When the installer finishes, it returns to Windows, where the MathView group is open for you.

**Personalizing MathView**

Double-click the MathView application icon from the MathView group in Windows (or choose the MathView item from the Program section of the Start menu in Windows 95) to run MathView.

The first time you open the program, a dialog appears for personalizing your copy of MathView. Enter your name, organization, and serial number in the places provided. You can find the serial number on the cover of the CD and on your Registration Card. Enter the rest of the serial number exactly as it appears on your
Introducing MathView

Registration Card. When you have completed the information click OK or press enter.

Warning:
You must a name and organization with at least 6 characters.

After you have done this, MathView will close down and unlock the program for your use the next time, and all subsequent times you open MathView. If you type in the wrong serial number, or do not use names with at least six letters in them, you will be alerted and the program will close down. Open the program back up, by clicking on the MathView program icon, and enter the information again.

Using the Application

Double-click the MathView icon to open the MathView application.

Closing the Application

Choose Exit from the File menu to stop using MathView. MathView may ask you to save open files.
Writing Conventions

For the most part, the examples in this guide are independent of each other. This means that once you have read and understand this introductory chapter and the chapter called Preliminaries, you can just select a topic of interest from the contents and go directly to it. This guide is your introduction to MathView. It discusses the most important concepts and builds a framework of knowledge which you can then expand upon depending upon your needs.

The guide assumes you have a basic knowledge of the mathematics. Numerous areas do exist, however, where you will review the underlying mathematical concepts to help you make the link between the old methods and the new computer methods. You will find MathView useful whether you are a beginning student of mathematics, or a scientist or engineer who needs to analyze the most complicated equation.

Help

The Windows version has a separate on-line help system, that you access from the Help menu. You access help with the Macintosh version by using Apple’s Balloon Help.

Anomalies

This guide uses screen-shots of Macintosh windows and dialogs which may have a slightly different appearance than what you will see on your screen, depending on the platform and font you are using. The font you see in the screen-shots is Adobe’s New Century Schoolbook (italics on).

All versions of MathView are virtually the same except for the location and appearance of the main menu (at the top of the screen in the Mac and at the top of the Notebook window in Windows). Command key equivalents are different too, depending on the platform. All manipulations are the same, and notebooks in one platform are 100% compatible with other platforms.

Fonts used in this Guide

The body of the guide uses the Times font. The five other fonts in the guide help you link what you see in the guide to what you see on your screen.

- **Chicago**: Denotes menu selections and dialogs. For example, Manipulate ► Simplify tells the reader to select the menu item Simplify under the Manipulate menu.
- **Courier**: Instructs the reader what keys to press to input equations to the workspace. For example, when instructed to input $\sin(x^2)$, you will know that you type:

\[
\sin(x^2)
\]

- **Helvetica 8pt**: Notates screen shots and side-column notes.
- **Helvetica 18 and 10pt Bold**: Main section and side headings.
- **NC Schoolbook**: Variables and some dialog text, in the body of the guide.

Screen Shots

The guide displays equations in the New Century Schoolbook font captured from Macintosh notebooks (using a screen-shot utility). Because equations and graphs, in some cases, are scaled down to fit in a particular area, they may appear smaller than what you see on your screen.
Introducing MathView

Many times, screen-shots are of only part of the whole Theory (a Theory is a group of related mathematical propositions). Therefore, your workspace may show more than what the guide shows. In addition, some of the screen-shots show manipulations which only temporarily display on your screen. On occasion, the guide shows what you will see during these manipulations.

A picture of the cursor in the screen-shot normally indicates where a selection occurs or where a mouse click occurs.

Expressions the guide highlights in gray, in most cases, show the selected portions of the equation before you invoke the manipulation. In most, but not all, cases the guide shows highlighted results, too, because MathView highlights results after manipulations occur.

Manipulations

You will manipulate equations by using one of four methods: by menu selection; by Command key action; by clicking on Palette icons; and by using the “Hand” (see section to follow). The Chicago font notates menus, with arrows designating sub-menus. Thus, the Auto Simplify Preference item, is noted as Manipulate ➤ Manipulation Prefs ➤ Auto Simplify. This means that you let go of the mouse after you have navigated to Auto Simplify. Do this by dragging the mouse to the Manipulation Prefs choice under the Manipulate menu. A sub-menu will open so you can drag the mouse to Auto Simplify.

MathView provides you several methods of performing manipulations. The guide will attempt, in the beginning, to describe most of these to you. As you progress, however, the guide will only mention one or two of these methods. In most cases, the manipulation method you use is a personal choice.

The guide does not discuss the use of the Command key equivalent keystrokes in the main body of the text because they are not the same on all platforms. You will find a list of most of these in the appendix. The menus also display many of these next to the commands. You may want to make a list of Command key keystrokes to have next to your computer as you learn. Many of them will become the method of choice for your manipulations.

Side Column Icons

Icon images in the side column represent Palette methods. They are there to remind you that you can click on the same image on the palette to achieve the results described in the text. For example, you generate a linear graph by selecting the menu choice: Graph ➤ y = f(x) ➤ Linear. The icon in the side column to the left of this paragraph indicates that you can click on this palette image to perform the same action.

Hand Manipulations

MathView allows you to move variables and expressions around the screen by invoking the “Hand” cursor. In some cases, the guide will show the expression or equation in the middle of one of these manipulations. That part of the expression in gray is the selection and that part in reverse video is the target. Reverse video is white-on-black in this guide, white-on-color on your screen if you have chosen a background color for your system.
### Writing Conventions

**Keyboard Actions**  
The guide notates keyboard actions in one of two ways. The first is to write out the action, as in, “press the Return key”. The second is to show an image of the key itself, which has the same meaning.

**Examples**  
- Bulleted, indented paragraphs indicate the steps of examples.

**Space key**  
Blank spaces may appear to be included in example input. Do not include a space (by pressing the Space key) in your inputs unless specifically directed to do so with the words “press the Space key” or “press ‘ ‘”. Pressing the Space key (or if you prefer, Space bar) is a special short-cut in MathView for multiplication. For the most part, examples will display the asterisk (*) to denote multiplication. You can use the Space key short-cut rather than typing an asterisk for most, if not all, multiplications.

**Notes**  
Text in the side column are notes that contain additional information about the current subject.

**Teacher’s Notes**  
These areas discuss teaching tips.

**Return key**  
The Return key on many DOS machines is labeled Enter. If you are using the Windows version of MathView, when requested to press the Return key, this means that you should press the Enter key on the main keyboard. In all versions, the Enter key on the numeric keypad has a totally different function (see page 17).

**RHS/LHS**  
LHS and RHS are abbreviations for the Left Hand Side and the Right Hand Side of the equation respectively.

\[
\begin{align*}
\text{LHS} & \quad \text{RHS} \\
\begin{array}{c}
\sqrt{x^2 + y^2} \\
\end{array} & \quad 2xy
\end{align*}
\]
Introducing MathView

A First Example

This example is for those of you who want to get right to work and would prefer to read the guide after a little experimentation. Followed very carefully, this example should give you a good start. After you complete the example, you are encouraged to continue on in this guide in a sequential manner, or you can go to individual subject areas.

Desktop

After installation, you will see the following images on your desktop. For the Macintosh, depending on where you have chosen to place the files, your window should look similar to the following.

The Windows desktop will look something like the following.
A First Example

Opening MathView • To open a MathView document on a Macintosh, double-click on either the program icon or the notebook called “New Notebook”. A document will open which looks like the following.

The Palette showing is the Variable Palette. If you click on the large $x$, it will change to the Function Palette.

When you open the Windows version by double-clicking on the program icon, or by clicking on the notebook called “Newnote”, the following window will display. Below is the Function Palette which you obtain by clicking, again, on the $x$ in the Variable Palette.
Introducing MathView

Starting Example #1

The screen-shots in the examples are taken from the Macintosh version. They apply to the Windows version as well, but may look somewhat different on your screen.

Notice that you have a highlighted ? in your Notebook. MathView opens the document ready for input.

- The ? is highlighted (if not, select the ? by clicking on it). Type the following. means press the Escape key.

You have entered a Proposition (abbreviated in the guide as Prop).

- To show an alternative way to input the equation, select the Proposition by clicking once on the rounded square icon to the left and press f.

This time you will use the Palette to input the same equation.

- Click on the 2 on the Variable Palette.
- Select the multiplication operator inside the a+b Pop-up menu on the Function Palette (a-b). A ? will appear awaiting an input.
- Click the Superscript icon on the Function Palette.
- Click on an x on the Variable Palette.
- Click on the superscript ? to highlight it, and click on 2 on the Variable Palette.
- Click once on the Select out icon 3 times to highlight the $2x^2$ and select the addition operator inside the a+b Pop-up menu.
- Click on 1 twice, choose the multiply operation again (a-b), and then click on the variable x.
- Click once on the Select out icon and select a+b. Click on y.
- Click on Select out once to select the whole expression.
- Choose the a=b operator under the a+b Pop-up menu and click on x.
- Click on the Superscript icon again.
- Click on 3, click Select out twice, and choose the addition operator (a+b).
- Click on the number 1 and the number 2.

This method looks tedious on paper, but as you learn all of the ways to input expressions, you will find this method very useful for much of your input.

- In order to graph this equation you must isolate, or solve for, $y$. You can do this in one of three ways. Each requires you to select $y$ first. Do this by dragging the mouse across $y$ or double-clicking on $y$ until it highlights.
A First Example

The first method is to choose **Isolate** under the **Manipulate** menu. The second method is to click on the **Isolate** icon on the Functions Palette (the icon in the column to the left of this paragraph).

The third method is to use the “Hand” cursor to drag the \( y \) over to the Prop icon. After you select \( y \), move the mouse over it. Hold down the \( \text{F5} \) key (Macintosh) or the \( \text{Ctrl} \) key (Windows). The cursor will turn into a Hand. Press down on the mouse button and, while continuing to press down, drag away (you can let up on the key now). A dotted outline will follow the mouse around the screen. Move the mouse cursor to the Prop icon and let go. This action isolates \( y \). Below are three screen-shots showing the selection, the manipulation, and the result.

Results have a rounded triangle shaped icon in front of them. A rounded triangle indicates that the result is a conclusion to a manipulation. **Assumptions** are inputs (rounded square icons), and **Conclusions** are answers (rounded triangle icons), which result from a **MathView** manipulation. Notice the word **Isolate** to the right of the result. After every Conclusion, **MathView** displays the manipulation that caused the result. You can turn this feature off by choosing **Show Steps** under the **Notebook** ➤ **Notebook Prefs** menu. To turn it back on, choose it again; it toggles on and off each time you choose it. **Show Steps** is a global command, meaning that it affects all of the manipulations in the notebook.

- While the equation is still highlighted, choose **Copy** under the **Edit** menu.
- Select the first Prop by clicking once on the square icon (this action selects the Prop and the equation) and choose **Paste**. **MathView** generates a new Assumption Prop, (preceded with a rounded square icon) below the two original Props containing a copy of the conclusion. This step demonstrates how you can use the results of a manipulation in a new problem.
- The original Prop is not necessary now, so select it by clicking once on the the rounded square icon in front of the equation and press \( \text{f} \). Remaining will be the newly manipulated equation.

If you give \( x \) a value, what is \( y \)?

- Press \( \text{F9} \), to generate a new Assumption Prop, and type \( x = 3 \). Select this new equation by clicking once on the equal sign and move it, with the Hand, to the Prop icon of the \( y \) equation and let go. This action will substitute the

---

**Isolate**

Try each method by choosing **UnDo** under the **Edit** menu after each manipulation.

Make sure you get the pointer all the way over and into the Prop icon. If you do not make it all the way, you will be doing a **Commute** manipulation. **UnDo** will let you start over if you make this mistake.

**Copy**

**Paste**

On DOS machines, you press the Enter key on the main keyboard.
value of 3 into all occurrences of \( x \) in the equation.

\[
\begin{align*}
\square y &= x^3 - 2x^2 - 11x + 12 \\
\triangle y &= \square x = 3
\end{align*}
\]

Select \( x = 3 \) and with Hand move to Prop.

\[
\begin{align*}
\square y &= x^3 - 2x^2 - 11x + 12 \\
\triangle y &= \boxed{-12} \quad \text{Substitute} \\
\square x &= 3
\end{align*}
\]

To demonstrate \textbf{Always ReManipulate}, select the 3 in the \( x = 3 \) Prop and change it to a 5. \textbf{Always ReManipulate} works like a spreadsheet with auto-calculate turned on, it recalculates the result. You can turn this feature on and off by choosing \textbf{Always ReManipulate} under the \textbf{Manipulate} menu.

To invoke a \textbf{ReManipulate} when you have \textbf{Always ReManipulate} turned off (no check mark), choose \textbf{ReManipulate Now} under the \textbf{Manipulate} menu.

\[
\begin{align*}
\square y &= x^3 - 2x^2 - 11x + 12 \\
\triangle y &= \boxed{12} \quad \text{Substitute} \\
\square x &= 5
\end{align*}
\]

\[
\begin{align*}
\square y &= x^3 - 2x^2 - 11x + 12 \\
\triangle y &= \boxed{32} \quad \text{Substitute} \\
\square x &= 5
\end{align*}
\]

\[
\begin{align*}
\square y &= x^3 - 2x^2 - 11x + 12 \\
\triangle y &= (x-4)(x+3)(x-1) \quad \text{Factor} \\
\triangle \boxed{0} &= (x-4)(x+3)(x-1) \quad \text{Result}
\end{align*}
\]

\[
\begin{align*}
\triangle 0 &= (x-4)(x+3)(x-1) \quad \text{Factor} \\
\square \boxed{0} &= 0 \\
\triangle \boxed{x} &= 4 \quad \text{Isolate} \\
\triangle \boxed{x} &= -3 \quad \text{Isolate} \\
\triangle \boxed{x} &= 1 \quad \text{Isolate}
\end{align*}
\]

One way to find the roots of this equation is to factor the expression on the RHS, set \( y \) equal to zero, and solve for each \( x \).

- Select the RHS by double-clicking on one of the operators (either a + or a − sign).
- Choose \textbf{Factor} under the \textbf{Manipulate} menu. When the dialog box appears warning that it may take a long time, click on the \textbf{Yes, go ahead} button, or press \textbf{factor}.

\[
\begin{align*}
\triangle 0 &= (x-4)(x+3)(x-1) \\
\triangle \boxed{x} &= 4 \quad \text{Isolate} \\
\triangle \boxed{x} &= -3 \quad \text{Isolate} \\
\triangle \boxed{x} &= 1 \quad \text{Isolate}
\end{align*}
\]

- Create a new Prop and enter \( y=0 \). Substitute this equation into the equation above, then select each \( x \) in the resulting Conclusion separately and \textbf{Isolate}.

\[
\begin{align*}
\triangle 0 &= (x-4)(x+3)(x-1) \quad \text{Factor} \\
\square \boxed{y} &= 0 \\
\triangle \boxed{x} &= 4 \quad \text{Isolate} \\
\triangle \boxed{x} &= -3 \quad \text{Isolate} \\
\triangle \boxed{x} &= 1 \quad \text{Isolate}
\end{align*}
\]
MathView has a root finder that you can use when you plot the function.

- Select the last Prop and press $f$ until the original equation remains. Click anywhere inside the equation (you do not have to select the whole equation), and choose Graph $\rightarrow y = f(x) \rightarrow$ Linear.

- To see more of the graph, zoom out once by clicking on the Rocket ship. The plot will zoom out by a factor of two each time you click on it.

To find the roots, you need to zoom in on the $x$-intercepts (where the line crosses the $x$-axis).

- Click once on the Knife and move the mouse into the Viewport and select a root by clicking to the left and above one of the $x$-intercepts. While you still have the mouse depressed, drag down and to the right, creating a dotted rectangle defining a new view. Let go of the mouse and watch the graph re-draw, showing only the area defined by the dotted rectangle.

- Choose Find Graph Root under the Manipulate menu. This action generates a self-contained Case Theory defining the value of $x$ at $y = 0$.

- To find the other roots, select Undo under the Edit menu. The graph goes back to its original view. Perform the manipulation again at a new crossing. The Undo will not affect the Case Theory containing the first root.

You can generate a table to further study this function. You must first create a Case Theory so the work you do with the Table will not conflict with the other work in the Notebook.

- Select the last Prop in the Notebook by clicking on its leading icon. Press $\text{Enter}$ on the numeric key pad. The square icon turns into

Viewport is the term the guide uses to refer to the visible area of a Graph Theory containing the plot.

Do not perform any other action between the generating of the root and the Undo. If you make a mistake, delete the graph by clicking on the Graph icon at the upper left of the graph and press $f$. Now start over.

You can change the action of the Return and Enter keys by selecting Edit $\rightarrow$ Editing Prefs $\rightarrow$ Enter Key...
Introducing MathView

a balloon icon indicating that it is now a text area. The cursor should be blinking next to the icon. If not, click the mouse in that area.

Type, generating a table using the function:

• Press \( \text{Create a new Assumption Prop.} \)
• Go up to the first Assumption Prop in the Notebook and select the function again by clicking once on its equal sign. Select \( \text{Copy} \) and then \( \text{Paste} \) it to the new Prop inside of the Case Theory. Make sure to select the \( \text{?} \) before you \( \text{Paste} \).

• Select the equation again and choose \( \text{Edit} \ \uparrow \ \text{Copy as Picture} \). Click just to the right of the colon in the text area and \( \text{Paste} \). MathView copies the equation, in real mathematical notation, to the comment area.

You can control the appearance of your comments, including their size, by using the Comment Palette area.

• Click on the balloon icon in the upper left of either the Variables or the Functions Palette and hold down the mouse button. The following pop-up menu will display.

By sliding the mouse over to the ruler icon just to the right of the balloon and letting go of the mouse, a ruler allowing you to adjust the tabs and size of the comment area will open in each Comment area.

The largest Prop in the Theory determines the width of Case Theories. In this case, the largest Prop is the comment, even though the text does not fill the comment area. By reducing the width of the comment, the outline of the Case Theory will shrink.

• Since this comment area may be too large to fit on your screen, click on the size handle on the right of the ruler and slide it over to the left. The comment will wrap to the next line if the ruler is shorter than the existing text.

The other items in the Comment editor allow you to change the type and style of the font, along with the color of the font. This Palette Pop-up menu allows you to change small areas of a particular comment. To globally change the comment areas, and to change the font characteristics of equations, you choose \( \text{Notebook Font...} \) under the \( \text{Notebook} \) menu.

• Select the ruler icon in the Comment Palette area again and the rulers will disappear.
• Select the RHS of the equation, and choose \( \text{Generate...} \) under the
A First Example

Remember, the icons in the side column are to remind you that you can click on the Palette icon to perform the same operation as indicated in the text.

**Manipulate ▶ Table** menu. When the New Table dialog opens make sure you have selected \( x \) as the variable and change the value range from \( 0 \ldots 6.3 \) to \(-5 \ldots 5\) with 51 points. Press \( \text{OK} \) or click \( \text{OK} \) to generate the Table.

![New Table dialog](image)

To generate a Graph Theory using the data points in the Table, you must give the table a name.

- Click on the ? in the phrase, “Tabulate ? with...” and type a \( T \). Clarify the Notebook by choosing **Clarify** under the **Notebook** menu and declare \( T \) a User Defined Function. Hold down the mouse button on **Variable**, drag down to **Function** and let go. Finish by pressing \( \text{Enter} \) or clicking on the User Defined button.

![Clarify](image)

- Select the Table by clicking once on its icon and generate a plot by choosing **Graph ▶ Scatter ▶ Linear**. Choose \( x \) as the \( x\text{-axis} \) variable and \( y \) as the \( y\text{-axis} \) variable leaving the \( n \text{ parameter} \) as arbitrary. Press \( \text{Enter} \).

![Generating a Table using the function](image)

Zooming out, by clicking on the rocket, shows the domain limitations when you created the table \((-5..5)\). Zoom back in by holding down the \( \\
\text{Control} \) key (Macintosh), \( \text{Ctrl} \) and \( \text{Alt} \) (Windows), while clicking on the Rocket Ship.

- So that you are looking at the same plot as above, open the graph details by clicking on the Details icon and change the Viewport to the following. Select...
Introducing MathView

each number without selecting the attached minus signs and type the numbers shown below.

\[-3.5...5 = \text{left...right} \quad \text{Stretch to Fit} \quad \text{Moderately} \]
\[-20...25 = \text{bottom...top} \quad \text{cropping} \quad \text{Moderately} \]

Below the Viewport are the Scatter Plot details. Experiment changing the style of the markers by clicking on the pop-up menus and choosing different styles and colors. You can change the Viewport itself by selecting different items in the pop-up menus above (Stretch to Fit and Moderately).

- Change to Red Squares and close the details by clicking on the Details icon again.
- Plot a line on top of the data by selecting the Table and choosing Add Line Plot under the Graph Additional menu. Choose x & y as the axes and press [ ]. Open the Graph details again and change the Line detail to match the following. Change the domain of the line from Left...Right to -2...4, and the line weight from normal to heavy. Close the details.

The Graph Theory will reflect any change you make to individual points in the table. First move the Table to below the Graph Theory for better viewing during this operation.

- Select the Table by clicking on its leading icon and drag to below the Graph Theory with the Hand, using the same method you used to move variables earlier in the example. When you are in the right location, a black square highlights the area. Let go of the mouse.

- Open the Table Details by clicking on its Detail icon and change the \( T(3) \) value from -12 to a value of 0. You will need to scroll your screen down a bit.

\[ T(3) = 0 \]
A First Example

The Case Theory will look like the following after you have closed both Details.

You can extract individual values from the table by setting up a Prop defining a function.

- Select the Table and press \texttt{\textasciitilde} to create a new Assumption Prop.
- Type $y =$, click on the Palette image of $T(x)$ (on the Functions Palette) and type an $x$.
- Press $\texttt{\textasciitilde}$ and type $x = 5$.

$\begin{align*}
\Box & \quad y = T(x) \\
\Box & \quad x = 5
\end{align*}$

- Select the $x = 5$ equation by clicking on the equal sign, and this time hold down the Shift key (\texttt{\textasciitilde}) while selecting the $x$ in the function. The method of selecting more than one item at a time is called Shift-Clicking.

$\begin{align*}
\Box & \quad y = T(x) \\
\Box & \quad x = 5
\end{align*}$

- Choose \texttt{Manipulate} \texttt{\textasciitilde} \texttt{Other} \texttt{\textasciitilde} \texttt{Substitute}. Declare $T$ a User Defined Function when the dialog box opens.
- After the substitution has occurred, select the RHS of the new equation, $T(5)$, and \texttt{Manipulate} \texttt{\textasciitilde} \texttt{Calculate}. The Theory will look like the following.

$\begin{align*}
\Box & \quad y = T(x) \\
\Box & \quad x = 5
\end{align*}$

You can now change the value of $x$ to immediately obtain other $y$ values when you have \texttt{Always ReManipulate} turned on. Try this by selecting the 5 in the $x = 5$ equation and changing it to a 2.

To demonstrate some calculus manipulations, create a Case Theory below everything in the Notebook.

- Select the last Prop in the notebook (it should be the last Case Theory) and press $\texttt{\textasciitilde}$.
Introducing MathView

To make the Comment area smaller, first change the global width of comment areas.

- Choose Comment Rulers... under the Notebook ▶ Notebook Prefs menu, change the width to 4 inches and press [Space].
- Enclose the Assumption in a Case Theory (with the Prop selected, choose Case Theory under the Notebook ▶ Insert menu). Press [Space] to turn the Assumption into a Comment, and type Calculus After pressing [Space], type the equation \( y = 3x^2 + 4x - 11 \)
- Generate a Linear Graph Theory and zoom out once.
- Select the Prop with the equation and press [Space] to create a new Prop.
- To find the derivative of this function, click on the Derivative Op icon on the Palette. Type a \( y \), † and type an \( x \). The Case Theory will look like the following.

![Click here once to zoom the graph out.]

- Select the \( y \) equation (click once on the equal sign), and with the Hand, drag it to the Derivative Prop. MathView will produce the derivative function.

\[
\begin{align*}
\frac{dy}{dx} &= y' = 6x + 4
\end{align*}
\]

You can have the Graph Theory dynamically show the function and its derivative by adding a line plot you define as the derivative of \( y \).

- Eliminate the derivative assumption Prop and its conclusion by selecting and pressing f.
- Select the Graph by clicking on the Graph icon in the upper left corner of the graph and choose Graph ▶ Additional ▶ Add Line Plot. This adds a second line detail with the same characteristics as the first, except for a new line color. Open the details and select the \( y \) in this detail.

You can also select the equation and choose Add Line Plot.

- With the \( y \) highlighted, click on the Derivative Op again and type an \( x \). The Graph Theory is now set up to change both plots when you change the original equation.
A First Example

- Select the power of \( x \) in the original equation (2) and replace it with \( a \). Press and type \( a = 2 \). The graph will re-draw after a Clarify (under the Notebook menu). Change the value of \( a \) and watch the Graph Theory re-draw, both the function and the new derivative. The screen-shot below shows \( a = 4 \).

To complete this example you will find the function whose derivative is \( 3x^2 + 4x - 11 \). In other words, you turn the equation above into a differential equation, and solve.

- Create a new Case Theory below the Calculus Case Theory, by clicking on the circle icon, pressing and choosing Case Theory under the Notebook ► Insert menu. Press on the numeric key-pad, and type Differential Equation.

- Input the function in differential form. You do this in the following manner. Press and type \( \frac{d}{dx} \) times each side.

- Select the whole equation, by clicking on the equal sign, and choose Apply under the Manipulate menu. MathView selects both sides of the equation, at the same time, for you. Type \( d\times \)to multiply the differential to both sides. Once you have performed this step, select the whole equation again by clicking on its equal sign and choose Manipulate ► Simplify.

- Your notebook should still have the equation selected; if not, select it now. Apply again, then type a $ sign (\( \frac{d}{dx} - 4 \)), which applies the Integral Op to both sides. Select the equation and Simplify with Auto Casing turned on. Choose Auto Casing under the Manipulate ► Manipulation Prefs menu.

Do not use the Palette image of the integral in this example, as it will add a second differential.
Introducing MathView

prior to the simplify.

\[
\Delta \int dy = \int (3x^2 + 4x - 11) \, dx \quad \text{Apply}
\]

\[
\Delta y + c_{100} = x^3 + 2x^2 - 11x + c_{101} \quad \text{Simplify}
\]

- **Isolate** \( y \) and combine the constants by selecting both and typing a \( c \) without a subscript. A new Assumption generates because you have changed the Conclusion.

The subscripts for \( c \) may be different in your notebook. Do not worry, you will learn how to change them later in the guide.

- Many times you will want to have a hard copy of a MathView session. To print this notebook, choose **Print Notebook...** under the **File** menu. Choose the print settings you want when the dialog opens and press **[Print]**.

This completes the first example. It does not demonstrate all of the manipulations available within *MathView*, but should give you a good start. The next section starts at the beginning and works its way through many of the basic features of *MathView*. The later chapters introduce many features through the use of examples.
Preliminaries

MathView Files...The Notebook 28
Beginning Concepts 31
Operators 38
Entering and Selecting Equations 39
Command Manipulations 46
Hand-Mouse Manipulations 58
Name Declarations and Transformation Rules 63
Case Theories 68
Graph Theories 71
Tables 85
Matrices 89
When you double-click on the *MathView* program icon in Windows, you open a new document named *Untitled1.the*. On a Macintosh, a new document named *Untitled 1* opens.

The large window—named “*Untitled 1*” and “*UNTL1.THE*” in these examples—is your *Notebook*, or work area. The Notebook is analogous to a word processor document or a spreadsheet program file, but as you will learn soon, works more like an outlining document.

*MathView* documents are called Notebooks. When you start *MathView* by double-clicking on the program icon, a blank document opens like the ones above. The windows, within the respective platforms, work as normal windows do in regards to moving them around the screen, re-sizing them, and closing them. You can close and re-open the Palette by toggling on and off the special menu choice, `Notebook` ▶ `Windows` ▶ `Palette`.

You can have multiple notebooks open on your desktop at the same time, limited only by memory. Each of these notebooks is independent of the other, so calculations in one do not affect the others in any way. To create a new notebook, choose `File` ▶ `New Notebook`. To open an existing file, choose `File` ▶ `Open Notebook`.

When you open the program by double-clicking on the program icon, the new notebook that opens is called *Untitled1* (Mac) or *Untitled1.the* (Win). These documents are linked to the notebook called *New Notebook* (Mac) and *Newnote.the* (Win), both of which came on the distribution CD. These files include a basic set of Declarations which represent the rules and definitions that control how *MathView* solves problems in that particular notebook. Consider the declarations as a kind of Mathematical Rules library.
You can change the configuration of the **New Notebook** by adding or subtracting rules and declarations and saving the file to your disk under the same name: **“New Notebook”** (Mac) or **“newnote.the”** (Win). This file will replace the old one, so you may want to make a back-up copy of the old one, in case you want it later.

From that point on, anytime you choose **New Notebook** from the **File** menu, the untitled document that opens will contain those new rules and declarations. You have created a template notebook.

You can configure your notebooks to cover as much mathematics as you want. Rather than load its whole set of rules and declarations, **MathView** only loads a basic set which, for most elementary work, is more than adequate. Anytime you attempt to perform an operation that needs a new rule, **MathView** requests that you activate that rule. This adds to both the size and the capability of the program.

To create a special notebook, add or subtract rules and declarations to the **Untitled1** or **Untitled.the** document you have opened and save it. In future sessions when you open this document by double-clicking on its icon, it will open configured with those rules and declarations.

A set of **Distribution Notebooks** which contain several configurations which you can use for special subject areas came with your CD. These notebooks are full of rules and declarations which can expand the capabilities of the program. You can copy various rules or declarations out of these notebooks and add them to your own, to create custom notebooks. Select the rule or declaration by clicking on its leading icon and choose **Copy** under the **Edit** menu. **Paste** into your custom notebook, preferably in the **Declaration** area.

**Saving Notebooks**

You can change the configuration of the **New Notebook** by adding or subtracting rules and declarations and saving the file to your disk under the same name: **“New Notebook”** (Mac) or **“newnote.the”** (Win). This file will replace the old one, so you may want to make a back-up copy of the old one, in case you want it later.

From that point on, anytime you choose **New Notebook** from the **File** menu, the untitled document that opens will contain those new rules and declarations. You have created a template notebook.

You can configure your notebooks to cover as much mathematics as you want. Rather than load its whole set of rules and declarations, **MathView** only loads a basic set which, for most elementary work, is more than adequate. Anytime you attempt to perform an operation that needs a new rule, **MathView** requests that you activate that rule. This adds to both the size and the capability of the program.

To create a special notebook, add or subtract rules and declarations to the **Untitled1** or **Untitled.the** document you have opened and save it. In future sessions when you open this document by double-clicking on its icon, it will open configured with those rules and declarations.

A set of **Distribution Notebooks** which contain several configurations which you can use for special subject areas came with your CD. These notebooks are full of rules and declarations which can expand the capabilities of the program. You can copy various rules or declarations out of these notebooks and add them to your own, to create custom notebooks. Select the rule or declaration by clicking on its leading icon and choose **Copy** under the **Edit** menu. **Paste** into your custom notebook, preferably in the **Declaration** area.

**Printing Notebooks**

You save a notebook by choosing **Save** or **Save As**, under the **File** menu. If you have entered anything in a notebook and try to close it, by either clicking on the close button or by choosing **Close** under the **File** menu, **MathView** will ask if you want to save it before it closes.

The menu choice **Revert to Saved** under the **File** menu allows you to revert to the last saved version at anytime during a **MathView** session.

You can have **MathView** periodically save the document you are working on by toggling on **AutoSave** under the **File** menu. You must turn this feature on each time you open a document if you want **MathView** to work this way.

To print notebooks, choose **Print Notebook...** under the **File** menu. You control the fonts that your document uses by choosing **Notebook Font...** under the **Notebook** menu. The style you choose for the main part of the notebook, the mathematics that is, is all going to be the same. In other words, **Notebook Font** is a global command. You can change the default font for individual characters in comments. See page 36.

Sometimes you may have a expression that extends past the right border of a page. If this happens, **MathView** will alert you when printing and will print an extra page labeled 1b, if the long Prop is on page 1. Alternatively, you have a menu choice called **Auto Collapsar** (found under the **Manipulate ▶ Manipulation Prefs** menu), which will “collapse” the expression so it will fit. Choosing a smaller size of font, or printing in landscape mode, may help too.
Case Theories (page 68) present another problem when printing. The enclosure created by MathView, when generating a Case Theory, stretches to include the largest expression within that Case Theory. Not only will the offending expression print on page 1b, the boxed outline that defines the Case Theory will too. Sometimes you may not have an expression that looks like it goes over to the other page, but the box still prints on a second page. This may occur because you have defined your rulers too wide. Choose Comment Rulers... under the Notebook ► Notebook Prefs menu and change to a smaller size. For those rulers you have already generated in existing comments, choose the ruler icon in the palette to place those rulers in view. Click on the size bar of the offending ruler or rulers and drag to the left. You can tell if an expression or Case Theory will fit on the page by comparing it with the tick mark in the upper and lower right corners of the notebook. These tick marks define the width of the printed page.

Case Theories that extend downward too far will create a similar problem. They are printed over on both pages, sometimes with expressions split in two. To fix this, make sure you do not have Case Theories that are longer than one page. You can split them up into two or more theories to solve this problem. If a Case Theory is shorter than a full page, but large enough to spill over to the next page, MathView will move the whole theory to the next page rather than split it up. Inserting a page break, found under the Notebook ► Insert menu, will be of help in some situations.

The way your notebooks look on the screen depends upon the system you are using. Anytime you define fonts that your system does not have installed, you will have poor looking output. You can change the printed header in your printouts by choosing Printing Prefs... under the File Menu.

MathView will print whatever you type in the dialog box, printing the file name, vertical page number, and horizontal page letter, according to the instructions in the dialog box you see above.

Show Icons
The icons in front of propositions print along with your notebook unless you choose Never or Unless Printing under the Notebook ► Notebook Prefs ► Show Icons menu.
Beginning Concepts

The fundamental structure in MathView is the **Proposition**. Notebooks contain a set of propositions organized hierarchically. Propositions can contain other propositions (in an outline form) which often refer to additional propositions in various ways. A **Theory** is a list of related propositions. The main theory is essentially the Notebook itself and contains all of the propositions that you enter.

Below is a list of the different types of Propositions in MathView. This guide introduces them as they become relevant within the context of the current subject. Every proposition has a unique leading icon, which this guide will portray in the side column.

- Statements
  - Assumptions
  - Conclusions
  - Working Statements
- Comments
- Name Declarations
- Transformation Rules
- Case Theories
- Graph Theories
- Independence Declarations

**Theories**

A **Theory** is a collection of related propositions (see below). When you input equations, manipulate equations, or create graphs, you generate a series of propositions. These **Props** (the abbreviation used in this guide for proposition) correlate with each other and make up, what MathView calls, a Theory. Each Theory inside the notebook represents a type of mathematical train of thought.

You can create separate Case Theory areas within each notebook. See the discussion on page 68. Self-contained, Case Theories allow you to explore divergent trains of thought.

**Propositions**

Two MathView Propositions appear at the top of a newly opened default notebook. The first one, labeled “**Declarations**”, with a quotation bubble in front of it, is a **Comment Proposition**. You can notate the notebook with text and imported graphics in these areas. This particular comment has some special rules and definitions nested within it, which appear when you double-click on the bubble icon. See Name Declarations, on page 63, for a more complete discussion.

The second Prop is a **Statement**, called an **Assumption Proposition**. You enter mathematical expressions or equations in this type of proposition. The Comment Prop has a quotation bubble icon to its left, the Assumption Prop has a rounded-corner square icon. After you manipulate an equation, MathView returns an answer, preceded with a triangle icon, called a **Conclusion**. See page 46.

You initiate additional assumptions by pressing the Return key and additional comments by pressing the Enter key on the numeric key pad.
Preliminaries

• Press \[\text{alt}+\text{m}\] now and a bubble icon appears with a blinking cursor. Type “\text{Mathview}”. Press \[\text{shift}+\text{f6}\], to add a line to the current comment. Type “\text{Rules}”.

• Use the mouse to select the word “\text{Rules}.” Drag over it or double-click on it to make the selection. If you press \(f\) (or the Backspace key) while the word \\text{Rules} is selected, it will disappear. You will find a complete discussion of Comments below, after the Notebook Structure section.

You select a proposition by clicking once on its leading icon. You select an equation by clicking once on its equal sign.

• Press \[\text{ctrl}+\text{c}\] and type \(z = 1.5^x \sin(y)\).

• Click on the equal sign to select just the equation.

• Click on the square assumption icon to select the whole Prop.

Notice the differences in the highlighting.

You delete propositions by clicking on the Prop icon and pressing the Delete key, \[\text{del}\], on the keyboard. You delete equations by clicking once on the equal sign and pressing \[\text{del}\]. A \(?\) placeholder will remain. See Entering and Selecting Equations (page 39), for further discussion.

Notebook Structure

\text{MathView} allows some degree of flexibility in arranging propositions and works in a similar fashion to an outlining program. The best way to explain this is to look at an example.

• In a new notebook, type the number 1 and press the Return key. Type a 2 and press the Return key again. Repeat this process through the number five. Each \[\text{ctrl}+\text{i}\] generates a new Assumption Prop.
Moving a Proposition

- Click once on the second Prop to select it.

  Select the second Prop by clicking once

  Hold down

  Drag the Prop icon around screen

  • With the mouse over the icon, hold down the ⌘ key (Mac) or ⌘ key (Windows). Notice how the pointer turns into a pointing hand. With ⌘ or ⌘ held, click and drag the second icon about the screen. Once you start dragging, you may stop holding the key, but continue to hold the mouse button down. Notice that an outline of the proposition follows the mouse around the screen and the cursor turns to the normal pointer.

  Also notice that at certain locations on the screen, dark highlights appear under the cursor. These are locations where you can drop whatever the hand is holding. Most places between propositions can accept a new proposition. If a location does not highlight, you may not place anything there.

  • Drop 2 between 4 and 5. Then take 5 and move it to the right of 1.

  • You can select and move more than one Prop in one operation. After rearranging the Props back to the original order, select Props 4 and 5 and move them between Props 1 and 2. After this is done move 2 to the right of 1.

  To select multiple Props, hold the Shift key down as you click on more than one Prop. This is called a Shift-click.

Hand-Mouse Manipulation

- You can also use the Hand Cursor to manipulate mathematical expressions and equations. A detailed discussion starts on page 58.

In-Line Propositions

Every MathView proposition can have another to its right, called an “in-line” proposition. More properly, 2 is an “in-line” of 1. This option is useful, for instance, for putting several short equations all on one line, or for putting two or more graph propositions side by side.

Daughter Propositions

- Put the Props back in order again and grab proposition 5 and move below and slightly to the right of 1 so it is indented below 1. In this configuration, 5 is a
Preliminaries

daughter of 1. Now move 2 directly below 5.

Configured like this, 5 and 2 are daughters of 1. You can also refer to them as sisters of one another.

- This time make 3 and 4 daughters of 1 by selecting each and choosing Notebook ➤ Indent Right. To move them back, you would reverse the process by choosing Notebook ➤ Indent Left.

By double-clicking on Prop #1 MathView demonstrates how its outlining feature works. You can also choose Notebook ➤ Collapse to do the same thing.

- Double-clicking on Prop #1 again will open up the collapsed Theory.

Notice the dots under the 1. The ..... under the 1 denote a collapsed proposition. MathView’s ability to collapse Props allows you to hide information from view. For instance, expose the first proposition in the notebook, Declarations (double-click on its icon). Name declarations for different variables appear. Do not worry about them now. You will explore them at length later in the guide. If left expanded, they would take up an inordinate amount of room. Having the ability to collapse propositions allows you to have a more concise workspace.

Shortly you will learn how to manipulate equations. When you manipulate an equation, MathView automatically generates a Conclusion Prop. Conclusions become daughters of the Assumption to which they refer.

\[ y + x^2 = 2x - 3 \]

When you manipulate an equation, MathView creates a cascade of indented propositions beneath the Assumption called Conclusions. Selecting the first Prop in a hierarchy highlights all indented Props beneath it. If you press the Delete key, or select Copy, MathView deletes or copies all Props associated with that selection. If you double-click the Prop icon, the cascade will be hidden beneath
You can also delete, copy, or collapse part of a cascade by clicking or double-clicking on a Prop in the middle of the cascade.

More on Comments

Pressing \[\text{35}\] on the numeric keypad generates a special proposition called a comment (introduced earlier). You can type normal text into a comment and MathView does not try to interpret it as an equation. You can place mathematical expressions in comments too, but you cannot mathematically manipulate them. Like in a word processor, you can click, drag, and delete comments.

- Create a new comment by pressing \[\text{35}\] on the keypad.
- Type “The quick brown fox jumped over the lazy dog” select the word “quick”. Press and hold down the palette button that looks like a balloon (this brings up the Comment pop-up menu). Now drag your mouse over to the long button with the font name. This does the same thing as selecting Comment Font... in the Edit menu. In the resulting dialog choose a different font family and click OK.
- In the sentence, select the word “brown”. Choose Comment Font... again and enter a larger absolute point size, such as 24, and click OK.
- Select the word “fox” and using the Comment Style submenu, make it boldface.
- Finally, if you are using a color monitor, select the word “jumped” and change its color with the Comment Color submenu.

You format alignment style and tabs with the help of a ruler which is usually invisible. To show all comment rulers in a notebook, choose the ruler icon from the Comment pop-up palette.

The comment ruler has different tab stops and justification options, similar to a word processor. Only the right margin is adjustable, however, and not the left.

- Grab the margin handle on the right of the ruler for the quick brown fox comment, and drag it left a few inches so the ruler is approximately half its original size. Notice how the comment text breaks up over multiple lines to compensate for the smaller margin.

When comment rulers are showing, dots appear where spaces are in the comment text. These dots are a visual aid and do not appear when you print the notebook. To hide all comment rulers in a notebook, choose the ruler icon from the pop-up palette again. Ruler settings remain in effect whether the rulers are showing or hidden.

You can add pictures to comments by pasting them from the clipboard directly to
Preliminaries

the location of your insertion point.

- To see how this works, copy a graphic from another program to the comment above.

You can also use MathView to act as an equation typesetter.

- Create an equation in the main part of the notebook. Select the equation by clicking on the equal sign, copy it as a picture (choose Copy as Picture under the Edit menu) and then paste it into your text editor (the screen-shot below is of a Claris Works document). You are taking a snapshot of the equation.

- If you use the regular Copy command you will get the equation in command-line format (also shown in the graphic above).

\[ y = \sin(x^2) \]

Notebook Font

- From the Notebook menu, choose Notebook Font... A dialog appears, in which you may set the default font, size, and italic style.

These font specifications determine the “default font” for the whole notebook. The Notebook Font affects not only comments, but also expressions in assumptions, conclusions, and graph propositions.
• Change the Notebook Font family and sizes to something of your own choice and click **OK**. All propositions change to the new specifications. Notice the word “quick” remains in the font family you specified earlier, and the bold style is still applied to the word “brown.” When you specify a new Notebook Font, *MathView* changes the main comment font but leaves untouched those parts which have had explicit font or size instructions. Keep in mind that the Notebook Font defines all of the mathematical propositions. You cannot change individual parts of assumptions, conclusions and graph propositions.
Operators connect expressions in an equation. In the expression \( a + b \), the Addition Op (abbreviation for operator) connects the two expressions \( a \) and \( b \) to create a new expression.

Operators enclose expressions. Unary Ops enclose a single expression and binary Ops enclose two expressions. Two Ops (\( + \) and \( \times \)) are n-ary; they can enclose any number of expressions (for example, \( 1+2+3+4 \)). When you select an Op, you also select the expression or expressions it encloses.

Ops describe relations between names and quantities. To have MathView act on an expression enclosed with an Op, you must perform a manipulation on it. For example, if you enter the simple expression \( 4 + 5 \) (number-Op-number), you must select the whole expression and perform a Calculate to have MathView add the two numbers together.

You have twenty-three Ops available to you. You can enter every Op from the keyboard and each has a button on the palette.

### Table 1:

<table>
<thead>
<tr>
<th>Op</th>
<th>Notation</th>
<th>Op</th>
<th>Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>+</td>
<td>Negation &amp; Subtraction</td>
<td>–</td>
</tr>
<tr>
<td>Factorial</td>
<td>( x! )</td>
<td>Multiplication</td>
<td>*</td>
</tr>
<tr>
<td>Division</td>
<td>/</td>
<td>Equals</td>
<td>=</td>
</tr>
<tr>
<td>Relational</td>
<td>( \neq, &lt;, &gt;, \leq, \geq )</td>
<td>Power</td>
<td>( x^8 )</td>
</tr>
<tr>
<td>Index</td>
<td>( x_8 )</td>
<td>Absolute Value</td>
<td>(</td>
</tr>
<tr>
<td>Square Root</td>
<td>( \sqrt{x} )</td>
<td>Adjoint</td>
<td>( x^4 )</td>
</tr>
<tr>
<td>Matrix</td>
<td>[1, 2] [3, x]</td>
<td>Dot Product</td>
<td>( \cdot )</td>
</tr>
<tr>
<td>Cross Product</td>
<td>( \times )</td>
<td>Partial Derivative</td>
<td>( \partial )</td>
</tr>
<tr>
<td>Integral</td>
<td>( \int_0^x x^2 , dx )</td>
<td>Summation</td>
<td>( \Sigma )</td>
</tr>
<tr>
<td>Evaluate At</td>
<td>( x = \left{ \begin{array}{ll} \sin(x) \ 0 &amp; \text{if } x &lt; 0 \ 2x &amp; \text{if } x \geq 0 \end{array} \right} )</td>
<td>Conditional</td>
<td>( \left{ \begin{array}{ll} 0 &amp; \text{if } x &lt; 0 \ 2x &amp; \text{if } x \geq 0 \end{array} \right} )</td>
</tr>
<tr>
<td>Pi Product</td>
<td>( \Pi )</td>
<td>Range</td>
<td>(-1\ldots1)</td>
</tr>
</tbody>
</table>
Entering and Selecting Equations

MathView gives you two methods for entering expressions and equations: **keyboard** entry and **palette** entry. Keyboard entry consists of typing formulas, as in a programming language or spreadsheet. Palette entry allows you to use the mouse to click on palette buttons on the screen. These buttons insert various symbols and operators.

**Palette Entry**

You can use the rectangular palette at the top of the screen to enter equations. Like any window, you can drag it to other locations on the screen and you can have the palette showing or hidden. Actually, it consists of two palettes in one. The variables palette, labeled with the big $x$, is for showing and entering names for variables and constants. The functions palette, labeled with the big $f(x)$, is for showing and entering operators and functions. Clicking on the big $x$ or $f(x)$ button toggles between the variables and functions palettes. Do this now and watch the palette switch between these two modes. Also notice the common items between the two palettes. These include buttons for parentheses, edit menu items, and special selection tools. See the discussion later in this section.

When you click on a palette button, the desired symbol, function, or operator appears in your notebook at the insertion point and the palette switches, anticipating your next entry.

- For example, click on the $a$ on the variables palette; MathView switches over to the functions palette. Click the on the exponent button and the palette toggles back to the variables. Click on the $y$. The process continues. What you just created is the palette equivalent of the keyboard entry $a^y$.

You can prevent the palette from switching automatically. Choose Palette Autotoggle under the Edit ➤ Editing Prefs menu. Alternately, if you choose it again, MathView will reinstate the Auto-toggle mode.

**Keyboard Entry**

MathView allows two ways of entering expressions from the keyboard. The first method uses the Escape key for much of its entry. The other style, “Fortranish”, works like the FORTRAN or Pascal programming language. The significant difference between Fortranish and non-Fortranish is the escape level behavior. For example, the method for coming out of a superscript back down to the baseline of the expression is different between the two.

For both methods, you can type in expressions in a manner similar to the way you would type them into a computer spreadsheet or into a Pascal program. You invoke addition and subtraction with the familiar “+” and “−” characters; multiplication is “∗” and division is “/”.

- With Fortranish turned off (the default mode) type the equation $(a^2) = (x^2) + 2xy + y^2$

  \[ a^2 = x^2 + 2xy + y^2 \]

- Choose Clarify from the Notebook menu to eliminate the unnecessary parentheses.

  \[ a^2 = x^2 + 2xy + y^2 \]
Preliminaries

Notice that MathView figures out what to do as you type. For instance, when you type \((x^2)+2\) it gives you \(x^2+2\). To change this grouping, type without parentheses. To enter \(x^2+2\), type \(x^2+2\).

- As an example, try pressing \(\text{[MathView]}\) and typing \(y=x-1/x+1\).

\[
y = x - \frac{1}{x+1}
\]

- Now press \(\text{[MathView]}\) and type \(y=(x-1)/x+1\). This time you get the following.

\[
y = \frac{x-1}{x+1}
\]

Parenthesis

As you type the expression, the “(“ makes both the opening and closing parentheses ( ). When you type the closing parenthesis “)” MathView places the blinking cursor to the outside of the parentheses. With this feature, you never have mismatched parentheses.

Sometimes MathView changes parentheses to brackets and braces, and vice versa. This has no effect on equation manipulation, it only affects the screen display. You may even type [ ]s, { }s, and ( )s at will, as they are interchangeable. Internally, MathView knows what expression the parentheses encloses, and does not care which type you use. Use them to make your equations more readable.

MathView removes parentheses that you no longer need after a manipulation or a Clarity. Even though MathView does not always show parentheses, you generally have to use parentheses while entering expressions, or MathView can misinterpret your meaning. When you need to enclose something in parentheses after you have typed it in, select it whole and type an open parenthesis: “(“.

You may find using [ ] makes for quicker entry as you do not have to hold down the shift key as you would using ( ). You can also click on the palette button.

In many cases, you can enter expressions without the unneeded parentheses. The Escape key \(\text{[MathView]}\) moves the selection (the blinking cursor) so parentheses are not necessary. For example, if you wanted to create the expression \(x^2+2\) with the Fortranish option off, you could type \((x^2)+2\) or you could type \(x^2\) \(\text{[MathView]}\) +2. Notice how, as you press the Escape key, the cursor moves from the superscript area back down to the baseline, level with the \(x\).

Fortranish

Above, you can see how MathView interprets keyboard entry with the Fortranish option off. If you like entering formulas as most spreadsheets and programming languages require, you may prefer the Fortranish keyboard entry.

- Press \(\text{[MathView]}\) and type \(\text{x^2+2}\). Notice how the \(+2\) stays at the exponent level.
Entering and Selecting Equations

Changing modes does not affect previous input. You may also switch back and forth between methods at any time. If you want to change the default to Fortranish, create a template notebook (page 28) with Fortranish turned on.

Hiding the Palette

Choose the Fortran item from the Edit ▶ Editing Prefs submenu. Press $x^2 + 2$ Notice how the cursor automatically drops to the $x$ level for the $+2$.

$x^2 + 2$

You may want to experiment with this feature throughout this guide to determine the method which best suits your needs.

If you find you prefer keyboard entry, you may want to remove the palette at the top of the screen. Choose Notebook ▶ Windows ▶ Palette to un-check the menu item and hide the palette. You will find you have more room for your notebook window. You can also click on the close box in the upper left corner.

Selecting

You make a selection so that you can then instruct MathView to change, delete, or otherwise modify the selection by some action. Most manipulations and commands need a selection in order to work.

You can select any part of any equation or expression simply by clicking or dragging with the mouse. However, you cannot select an Operator, such as $=$ or $+$, by itself; you must include the terms on which it operates.

There are shortcuts for selecting with the mouse. For instance, you can select an entire equation by clicking once on its equal sign:

$y = x^2 + 2x + 3$

Another shortcut is to select a sum of terms by double-clicking on an addition, or subtraction sign in the expression.

$y = x^2 + 2x + 3$

Of course, you get the wrong answer because the division should take place before the multiplication, which should take place before the addition. With Fortranish turned on this time, enter the same expression and Calculate.

$6 + 12 ÷ 2 * 3$

Select the expression by clicking on the Prop icon and choose Calculate under the Manipulate menu.

$6 + 12 ÷ 2 * 3$

$6 + 12 ÷ 2 * 3 = 8$

Teacher’s Note

By switching Fortranish on and off, you can study the beginning Algebra subject “Order of Operations”. Input the following expression with Fortranish turned off.

$6 + 12 ÷ 2 * 3$

Select the expression by clicking on the Prop icon and choose Calculate under the Manipulate menu.

$6 + 12 ÷ 2 * 3$

$6 + 12 ÷ 2 = 8$
Preliminaries

You may select integrals by clicking on the integral sign.

\[ \int_0^\infty \sin(x) \, dx \quad \text{Single-click} \quad \int_0^\infty \sin(x) \, dx \]

Double-click here, and drag to the right just a bit.

\[ y = \frac{1}{2}(x^2 + 2x + 3) \quad \text{Double-click \& drag} \quad y = \frac{1}{2}(x^2 + 2x + 3) \]

Select cross products by clicking on the cross product symbol.

\[ x \times y = z \quad \text{Click once} \quad x \times y = z \]

The general rule of thumb is to click or double-click on the symbol or operator. Try experimenting with selection shortcuts by creating large equations and clicking and dragging at various locations within the equation.

Multiple Selections

You can make multiple selections by Shift-clicking, which means holding down as you click. Try making two or three selections in different equations in your window. Then, try typing something in. Whatever command you choose or whatever you type affects all the individual selections simultaneously.

\[ y = \frac{1}{2}(x^2 + 2x + 3) \]

Select \( x = 3 \) \( \text{Shift-click} \quad x \text{ in equation} \)

\[ y = \frac{1}{2}(x^2 + 2x + 3) \]

Every time you click without Shift, you start another selection, de-selecting your previous selection. After the first click, every Shift-click adds to the set of selections. If you try to add another selection that is inside (or another part of) an existing selection, you de-select both.

Multiple selections are possible for whole Props. Try selecting two or more blank Props, with a Shift-click, and entering something. Whatever you enter displays in each of the selected Props. You may also Copy and Paste multiple Props.

Selection Tools

The palette has five buttons especially made for changing the selection. Enter the following expression to explore these selection tools.

- Make a new assumption (press \( \text{\textbullet\textbullet} \)) and click the Summation palette button, then fill in the question marks to make the following equation. After entering the Summation, type the following.

\[ \sum_{k=1}^{4} x^k = y \]

- Click the equation’s equal sign to select the whole equation. Click the Select In button to make the following multiple selection.

\[ \sum_{k=1}^{4} x^k = y \]
• Select the $k$ in the summation index. Click the Select Next button on the Palette repeatedly and notice the selection change. Pressing † or typing a colon is another way you can do this.

$\sum_{k=1}^{4} x^k = y$

• (Leave the 4 selected.) Press $\mathbb{R}$ and click Select Next repeatedly and notice the changing selection.

$\sum_{k=1}^{4} x^k = y$

• Select $x^k$. Click the Select First button to select the first element in the current selection, which happens to be $x$.

$\sum_{k=1}^{4} x^k = y$

• Click the Select Out button.

$\sum_{k=1}^{4} x^k = y$

• Click Select Out twice again and notice the changing selection.

$\sum_{k=1}^{4} x^k = y$

• Click the Select In button repeatedly and notice the selection change each time.

$\sum_{k=1}^{4} x^k = y$

• Click anywhere in the equation and click on the Select Prop button and you select the entire equation. If no equation is present, this operation will select the whole Prop.

$\sum_{k=1}^{4} x^k = y$

You should be able to select just about any individual character or expression with these selection tools, but you always have the standard click and drag method for those occasions when the tools do not help.
Preliminaries

Modifying Equations

If you are trying to delete something, select the item and press Delete one or more times until it is gone. Frequently, Delete leaves a question mark ? as a place-holder, which you then delete with the next keystroke. As you continue to press Delete, it gradually unravels the whole equation or expression.

- Create a new notebook. Type $y+z+3 \times x^2$ Select the 2. Press Del. Keep on pressing Del until you have nothing left. Repeat as often as necessary in order to understand the process.

If you are trying to replace something, select what you want replaced, and then type in the new expression.

- Create a new assumption (press ) and enter the previous expression again.
- Select the 2 and type $5+n$.
- Select the $x$ and type $\text{sqrt}(2)$.
- Select the $y+z$ and type $\sin(x)$.
- Clarify to remove extra parenthesis.

When augmenting an expression with new parts, the new parts almost always start with an operator. In this case, select what you want to enclose in the Op and then type the operator or click it from the palette.

- Create a new assumption (press ) and type $3x^2$. Select the 3. Type $-a$. Then, press twice to get rid of it.
- Select $x$. Type $+a$, then press twice to get rid of it.
- Select the 2. Type $+a$, then press twice to get rid of it.

When you replace a negated expression, you must press Delete before typing the new expression.

- For example, place the cursor to the right of the 2 and type $-a$. Press $f$ three times to get rid of it. Two Deletes are not enough to remove the negation.

To change the sign of a term from a positive to a negative you select the term and type a negative sign ($-$). You can also click on the palette image of negation ($-a$). To change a negated term to a positive term, you can either select the term along with the negative sign and re-type the term or you can select the term, with or
Try this. Select \(-a\) and type a negative sign over and over again.

Without the negative sign, and type another negative sign.

- Type a negative \((-\) or press \(-a\) \(\rightarrow\) \(-a\)
- Select the term and the negative sign and type the term again, or select the term, or the term and the negative sign, and type another negative sign \((\rightarrow)\).
Command Manipulations

A **Statement** is a mathematical expression in a *MathView* notebook. Statements are either assumptions or conclusions. Every statement you enter is an **Assumption**. Statements which evolve from a manipulation are called **Conclusions**. With one exception, only you can create assumptions and only *MathView* can return conclusions. See the discussion of this exception on the next page.

**Assumptions & Conclusions**

- In a blank notebook, enter the following equation using one of the techniques discussed in the prior section or as shown below.

  Type the following: \( y = \sin(x) \)

  **Result:** \( y = \sin(x) \)  
  **Assumption**

  You have created an Assumption. Below, *MathView*’s isolate manipulation generates a Conclusion. Assumptions have a rounded square icon in front of them and Conclusions have a rounded triangle icon in front of them.

**Isolate**

- Solve for \( x \). Select by clicking on the \( x \) or by dragging through it.

  \( y = \sin(x) \)  
  **The highlighting shows that \( x \) is selected.**

- Choose **Isolate** under the **Manipulate** menu. *MathView* solves for \( x \) and generates a new equation with the correct answer, called a Conclusion.

  \( y = \sin(x) \)  
  \( x = \arcsin(y) \)  
  **Isolate**  
  **Conclusion**

*MathView* highlights Conclusions, indents them starting the cascade, and precedes them with rounded triangle icons.

The Conclusion indents to the right showing that it connects to the Assumption Prop above it. If you click on the Assumption icon once, you will select both equations, and if you double-click, you will collapse the Conclusion into its Assumption.

If you have several conclusions under an assumption, you can collapse part of the Cascade by selecting the last prop you want showing and double-clicking.

To the right of the second Prop is the manipulation that created the conclusion. In this case, it is **Isolate**. You can turn this global feature of *MathView* off by toggling off **Show Steps** under the **Notebook ➤ Notebook Prefs** menu.

You can perform the same manipulation by using the Hand Cursor.
Command Manipulations

The Hand is the best method to use for the Isolate command. See the section Hand-Mouse Manipulations (page 58) for additional discussion.

- Using the same equation, select x and hold down $\frac{\text{Command/Ctrl-key}}{\text{Option/Alt-key}}$ as you move the cursor over the selection. Click the mouse down and drag to the Prop icon. Let go for the answer.

1. $\bigcirc y = \sin(x)$
2. $\bigcirc y = \sin(x)$
3. $\bigcirc\text{drag Prop icon until it highlights}$

Result

Manipulation in Place

If you want the Conclusion displayed without the Assumption, hold down the Option key (Mac), or Alt key (Win), while you do the manipulation with the Hand. MathView will replace (at the same location) the original Assumption with a new, manipulated, Assumption.

- Select $x$ and Isolate using the Hand while holding down $\text{Command/Ctrl-key}$ or $\text{Option/Alt-key}$ keys.
- $\bigcirc x = \arcsin(y)$

After Manipulation in Place.

If you are using the Palette or the menu to perform the manipulation, you must hold down the Command key and the Option key (Mac), or Control key and Alt key (Win), before you click on the isolate icon or you choose Isolate from the Manipulate menu.

Solve to the Right Side

You can solve an equation and have the isolated variable on the right side.

- Select $x$ and drag with the mouse to the right side of the equation. When you move the mouse approximately two characters to the right of the equation, a rectangular highlighted area will appear. Letting go of the mouse solves for $x$ and displays the equation with $x$ isolated on the right.

$\bigcirc y = \sin(x)$

With Hand drag to the right of the equation and let go...

Result

There is no equivalent menu or palette manipulation.

You just used MathView’s “solve-for” manipulation, Isolate, to demonstrate the basic idea of manipulation. What follows is a short discussion of MathView’s other manipulations. You activate each by either using the menu, or by clicking on the associated Palette image. In addition, you have command key equivalents for most
Preliminaries

of the manipulations. These command key equivalents show in the pull-down menus, to the right of each selection. You can also find them in the Appendix.

The functions palette contains the manipulation images across the top. They are basically in order of their location in the Manipulation menu, and each is available at the click of the mouse. The only exceptions are the seven manipulations located in the “Hammer” pop-up menu. They correspond to the items under the Manipulation ▸ Other sub-menu. You activate these manipulations by releasing the mouse when the pointer is over your choice.

Balloon help (Mac) or Tool Tip help (Win) will display the action of icons in the palette. Put the cursor over a particular icon, without clicking, to display the help.

Calculate and UnCalculate

Calculate generates a numeric evaluation of an expression and works in similar fashion to a pocket calculator. In the examples which follow, select the expression by dragging through it or click once on the Assumption icon. Choose the Calculate command under the Manipulate menu to have MathView perform the calculation. Alternatively, you can click on the Calculate Palette image.

Number 3 above has important implications. MathView allows you to selectively calculate, or for that matter perform most manipulations, on portions of an equation or expression.

48
Command Manipulations

- Enter the following expression: \( \ln(x) + \sin(1) - 50 \)

  \[ \square \ln(x) + \sin(1) - 50 \]

- Select only the trigonometric expression and **Calculate**.

  Select | Result
  ------|------
  \[ \ln(x) + \sin(1) - 50 \] | \[ \ln(x) + \sin(1) - 50 \]
  \[ \Delta \ln(x) + \sin(1) - 50 = \ln(x) + 0.84147 - 50 \]

**Calculate** reduces expressions to a number if you have given variables a value somewhere else in the notebook.

- Input \( y = \sin(x) \) \( x = 1 \)

**Working Statement**

No calculation will occur if you place \( x = 1 \) in a Case Theory (page 68) unless you **Substitute** (page 60) \( x = 1 \) into the \( y = \sin(x) \) Prop. The substitution automatically establishes the link, making \( x = 1 \) the Working Statement.

You can choose a different Working Statement, thereby changing the value 
*MathView* uses. You do this by selecting a new equation (say \( y = 3 \)), and choosing **Make Working Stmt** under the **Notebook** menu.

The Assumption Prop icon in front of the \( x = 1 \) proposition above has a dot inside it after the manipulation has taken place. This denotes a **Working Statement**. If you have **Guess Working Stmts** toggled on (the default under the **Notebook** menu), *MathView* looks through the notebook for values given to \( x \) and automatically substitutes the first value it finds into the calculated expression. If it finds none, or if you have **Guess Working Stmts** toggled off, no calculation will occur.

In the first illustration below, \( x \) has a value of 2, but \( y \) has none. In the second, \( x \) has one value and \( y \) has two. *MathView* uses the first \( y \) it finds.

When you calculate, select just the RHS of equations, and not the whole equation or whole Prop. If you select the Prop (or the whole equation), *MathView* calculates both sides.
Preliminaries

Uncalculate

UnCalculate attempts to undo a calculation, or recreate simple fractions or constants from decimals.

- Enter the following equation and choose Manipulate ► Other ► UnCalculate.

The Palette image for UnCalculate, found in the hammer sub-menu, is an up-side down calculator.

UnCalculate requires the selected decimal to be exact to approximately ten to thirteen digits of precision (regardless of the selected display precision).

Simplify

Simplify executes a wide range of operations designed to reduce the complexity of an expression. It combines constants, terms, and factors, using rational arithmetic; cancels where possible; and arranges expressions into standard form.

Calculate gives decimal answers. Simplify gives symbolic answers. A simple example demonstrates.

- Input the addition \(3 + 4\) in a new Prop. Select the whole proposition by clicking on the Prop icon, and Calculate.

Now, select just the expression \(3 + 4\) and Simplify.

- Now select the 3 in the Assumption and click the Square Root Operator on the Palette.

Note two items from this manipulation. First, the same Assumption was used to perform two manipulations. Secondly, Simplify appears to do the same thing that Calculate does. This presumption is not true. Although you get the same answer, the underlying mathematics is different.
Always ReManipulate

MathView automatically re-manipulated both of the conclusions above, in the same manner as a spreadsheet would do with its automatic re-calculation turned on. While the re-manipulation is in progress, MathView covers the conclusions with a hatching, indicating "work-in-progress". This hatching may disappear too quickly to be visible with a simple problem like the one you just performed, but for larger problems you will see it clearly.

- Continuing the example, select the 4 and apply the Square Root Operator.

### Selection

\[ \sqrt{3} + 4 \]

- Result

\[ \sqrt{3} + \sqrt{4} \]

\[ \sqrt{3} + 4 = 3.7321 \]

\[ \sqrt{3} + 4 = \sqrt{3} + 2 \]

You can toggle **Always ReManipulate** off by selecting it in the **Manipulate** menu. Once off, you can initiate a ReManipulation by choosing **ReManipulate Now** under the same menu.

This time MathView calculates the first conclusion and is able to reduce the second somewhat. It can go no further, however, because the square root of 3 is already in a simplified form.

Not only can you change operators, you can change numbers and variables, and have MathView re-manipulate.

- Using the same problem, first change the 3 to a 4; then go back and change the first 4 back to a 3 and the second 4 to an x.

### Selection

\[ \sqrt{4} + \sqrt{4} \]

- Result

\[ \sqrt{3} + \sqrt{x} \]

\[ \sqrt{4} + \sqrt{4} = 4 \]

\[ \sqrt{3} + \sqrt{x} = \sqrt{x} + \sqrt{3} \]

Ripple Changes Immediately

This feature is a similar, but weaker version of **Always ReManipulate** and **Always ReDraw** (page 73). When you have Always ReManipulate toggled on, MathView may take longer to ReManipulate larger Notebooks containing complicated theories and graphs. Delays may occur when you type changes, as MathView re-calculates equations and re-draws graphs after every keystroke.

When you toggle **Edit ▶ Editing Prefs ▶ Ripple Changes Immediately** off (no check mark), you can make changes to your equations and MathView will not enact them until you click somewhere in the Notebook outside of your selection.

Auto Simplify

When you first open a notebook, **Auto Simplify** defaults to on. To turn it off, choose **Auto Simplify** under the **Manipulate ▶ Manipulation Prefs** menu.

With **Auto Simplify** turned off, MathView proceeds through a Simplify manipulation, step by step as you perform additional manipulations.

- To demonstrate, input the following expression and turn **Auto Simplify** off.

\[ x^{-4} \text{ Esc } * y^{-5} \text{ Esc } * a^{2} \text{ Esc } * b^{3} \]
Preliminaries

- Select and Simplify twice.

Expand and MiniExpand

Expand executes a range of operations designed to break up and expand an expression to its most explicit form.

- Input the expression \((x+2)^4\), select it, and choose Expand under the Manipulate menu (or click on the palette button).

MiniExpand works on the “outside” layer of an expression.

- Input the expression \((x+2)^4 \text{ Esc} +5\ Select \ Out \ Select \ Out \ Select \ Out\).
- Choose MiniExpand under the Manipulate ▶ Other menu.

Collect

Collect separates out common terms of a sum and orders the remaining terms as a polynomial in a given variable.

- Input the expression \(4*x^3 \text{ Esc} +15*x^2\).
- Select and choose Collect under the Manipulate menu.

Applied to a sum of fractions, Collect adds the fractions together and collects all terms over a common denominator.
Command Manipulations

Notice the alternative method of entering division.

- Enter the expression $/1 x y z + /1 y z + /1 z$.
- Select the expression by double-clicking on one of the plus signs, and choose Collect under the Manipulate menu.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\frac{1}{x} + \frac{1}{y} + \frac{1}{z}$</td>
<td>$\frac{1}{x} + \frac{1}{y} + \frac{1}{z}$</td>
</tr>
<tr>
<td>$\frac{1}{x} + \frac{1}{y} + \frac{1}{z}$</td>
<td>$\frac{xy + (x + y)z}{xy + xz}$ Collect</td>
</tr>
</tbody>
</table>

With Auto Simplify turned off, Collect can distribute power sums and integer powers. See page 113.

- Using your favorite method, input the following two expressions. Select and Collect each expression in order.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>$x^a + b$</td>
<td>$x^a + b = x^a y b$ Collect</td>
</tr>
<tr>
<td>$x^5$</td>
<td>$x^5 = \underbrace{x x x x x}$ Collect</td>
</tr>
</tbody>
</table>

You can use Collect with Auto Simplify turned off to turn an intermediate conclusion into a different form.

- Enter the following expression, select, and Collect with Auto Simplify turned off.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\frac{x^2 y}{z^2}$ Collect with Auto Simplify off.</td>
<td>$\frac{x^2 y}{z^2}$ Collect</td>
</tr>
<tr>
<td>$\frac{x^2 y}{z^2}$</td>
<td>$\frac{x^2 y}{z^2} = \alpha^{-1} z^{-2} x^2 y^2$ Collect</td>
</tr>
</tbody>
</table>

- Turn Auto Simplify back on. Select just the $\alpha^{-1}$ of the resulting conclusion and Simplify.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\frac{x^2 y}{z^2}$</td>
<td>$\frac{x^2 y}{z^2} = \alpha^{-1} z^{-2} x^2 y^2$ Collect</td>
</tr>
<tr>
<td>$\frac{x^2 y}{z^2}$</td>
<td>$\frac{x^2 y}{z^2} = \alpha^{-1} z^{-2} x^2 y^2$ Collect</td>
</tr>
</tbody>
</table>

53
Preliminaries

• Select the remaining terms of the new conclusion and Simplify one more time for the final answer.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{x^2 y}{\alpha z^2} )</td>
<td>( \frac{x^2 y}{\alpha z^2} )</td>
</tr>
<tr>
<td>( \triangle \frac{x^2 y}{\alpha z^2} = \alpha^{-1} z^{-2} x^2 y )</td>
<td>( \triangle \frac{x^2 y}{\alpha z^2} = \alpha^{-1} z^{-2} x^2 y )</td>
</tr>
<tr>
<td>( \triangle \frac{x^2 y}{\alpha x^2} = \frac{1}{\alpha} z^{-2} x^2 y )</td>
<td>( \triangle \frac{x^2 y}{\alpha x^2} = \frac{1}{\alpha} z^{-2} x^2 y )</td>
</tr>
</tbody>
</table>

Factor

Factor places an expression into its most fundamental terms. MathView factors sums as polynomials and converts integers into their prime factors. In general, Factor breaks down an expression more completely than Collect.

• Input the following, select, and choose Factor under the Manipulate menu.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>( x^2 - x - 6 )</td>
<td>( x^2 - x - 6 )</td>
</tr>
<tr>
<td>( \triangle x^2 - x - 6 = (x - 3)(x + 2) )</td>
<td>( \triangle x^2 - x - 6 = (x - 3)(x + 2) )</td>
</tr>
</tbody>
</table>

If you select a cubic or quartic polynomial for factoring, a dialog asks whether you want to proceed numerically or symbolically. MathView uses the Cubic formula and the Quartic formula to symbolically factor third-order and fourth-order polynomials. This operation can be time consuming, especially if the intermediate expressions do not cancel. Numerically factoring these expressions (a choice in the dialog that will appear) is usually very fast.

MathView factors fifth, and higher order polynomials numerically because no general formula exists. When the roots of these polynomials are real or complex numbers, they are accurate to thirteen digits.

• Input the following polynomial and Factor.

\[ x^4 - 19x^2 - 6x + 72 \]

The following dialog box opens giving you the choice of having MathView factor symbolically or numerically, or to cancel the operation. Click Yes, go ahead to
have it processed symbolically.

\[
\begin{align*}
\text{Apply} & \quad \text{is a generic selection manipulation that provides a technique for performing} \\
& \quad \text{operations to separate areas of an expression or equation at the same time. When} \\
& \quad \text{you select an equation and choose Manipulate} \rightarrow \text{Apply, MathView appends both} \\
& \quad \text{sides of the equation with an input placeholder. Anything you input will apply to} \\
& \quad \text{both sides of the equation.}
\end{align*}
\]

- Input the equation \(-2x+y=3x^2\) \(\text{Esc}+3\). Select the equation by clicking once on the equal sign and choose \text{Apply}.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>(-2x+y=3x^2+3)</td>
<td>(-2x+y=3x^2+3)</td>
</tr>
</tbody>
</table>

You now have both sides of the equation selected.

- To solve for \(y\) by adding \(2x\) to both sides, type: \(+2x\). The one input simultaneously applies to both sides.

\[
\begin{align*}
\text{Apply} & \quad (\text{an} - 2x+y + 2x = (3x^2+3) + 2x)
\end{align*}
\]

- Select the equation again (alternatively you can select the Prop).

\[
\begin{align*}
\text{Apply} & \quad (\text{an} -2x+y + 2x = (3x^2+3) + 2x)
\end{align*}
\]
Preliminaries

- Choose **Simplify**.

\[ -2x + y = 3x^2 + 3 \]
\[ \sqrt{(-2x + y) + 2x} = \sqrt{3x^2 + 3} + 2x \quad \text{Apply} \]
\[ y = 3x^2 + 2x + 3 \quad \text{Simplify} \]

You must input an operator before typing a number. If you do not type the operator, MathView replaces the selections with what you have typed. In the example above, you entered the plus sign before the 2x.

If you select a fraction and choose **Apply**, you will select both the numerator and the denominator.

- Enter \(1/\sqrt{3}\) and **Clarify**.

You can achieve the same answer by selecting the initial expression and choosing **Simplify**.

- Select the expression.

\[ \frac{1}{\sqrt{3}} \]

- Choose **Apply**.

\[ \frac{1}{\sqrt{3}} = \frac{\sqrt{3}}{3} \]

- Click on Square Root Op.

\[ \frac{1}{\sqrt{3}} = \frac{\sqrt{3}}{3} \]

- Type a 3.

\[ \frac{1}{\sqrt{3}} = \frac{\sqrt{3}}{3} \quad \text{Apply} \]

- Select RHS and **Simplify**.

\[ \frac{1}{\sqrt{3}} = \frac{\sqrt{3}}{3} \quad \text{Simplify} \]

Transform

The transform manipulation is a flexible and extensible way to invoke PreDefined or User Defined algebra rules. **Transform** searches through your notebook for transformation rules that match a given algebraic pattern, and then changes those situations to a different expression based upon a replacement pattern.

To invoke **Transform**, simply select the expression you want to transform and choose **Transform** from the **Manipulate** menu.

- Input the expression \(\tan(x)\), select, and **Transform**.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\tan(x))</td>
<td>(\tan(x) = \frac{\sin(x)}{\cos(x)} \quad \text{Transform} )</td>
</tr>
</tbody>
</table>

This manipulation works because the “New Notebook” has the following rule inside the Declaration area.

\[ \text{Upon Transform transform tan}(x) \text{ into } \frac{\sin(x)}{\cos(x)} \]
Command Manipulations

By default, your notebook has several dozen transformation rules in it, each describing an algebraic identity. You can add more rules, or for greater speed, you can remove them. You can derive rules yourself, or you can get them from notebooks in the Mathematics directory, or from colleagues. See “Transformation Rules” on page 65, for a more complete discussion.

In some cases, more than one rule may match a given expression. When this happens, a dialog box will open with a list of the rules available. You then click on the one that applies to your problem.

- To see how this works input the expression, \((\cos(x))^2\).
- Select Transform. Choosing the first choice in the dialog box which opens, gives the answer below.

\[ (\cos(x))^2 \]

\[ \Delta (\cos[x])^2 = -\sin[x]^2 + 1 \]

Taylor Series and Integration by Parts

You find these two manipulations in the Other sub-menu under Manipulate, and in the Hammer pop-up Palette. Both are command manipulations discussed later in the guide. You can find Taylor Series in the Differential Calculus section on page 154. You can find the Integration by Parts manipulation in the Integral Calculus section on page 174.
Preliminaries

Hand-Mouse Manipulations

You will find the following manipulations most easily performed using MathView’s Hand-cursor, although they are all available in the menu or by clicking on the palette image.

- Isolate
- Move Over
- Commute
- Substitute

The manipulation method is very similar for Isolate, Move Over, and Commute. They all are manipulations to a single Prop. All three require you to move an object in an expression or equation, to a new location in the same expression or equation. Where you place this object determines which of the three you invoke. Substitute, on the other hand, requires you to involve at least two Props. The discussion which follows describes these methods and the results of the manipulations.

To activate the Hand-cursor, hold down the * key (Mac) or the Ç key (Win), while you move the mouse over a selected object.

When the mouse turns into a Hand, press and hold down the mouse button. As you drag away from the expression you have just selected (you may let up on the key, but continue to hold down the mouse button), you will find that a rectangular outline of the selected object follows the cursor around the screen.

As you move the mouse around to different areas within the Notebook, several highlighted areas will show up as you go over them. These highlighted areas are the places to which this expression will locate if, when over one of them, you let go of the mouse button.

The x on the far right is the selection in the graphic below. The black areas are possible destinations. When you are working in MathView, each in turn will highlight as you cross over its location with the hand and the outline.

- Input the following equation: \( y = (x - 3) \times (x - 2) \times x \)
- Select the x on the far right side by double-clicking on it. Hold down the \( x \) or \( ç \) key, click down on the selected x, and drag away. Move to different locations, without letting go of the mouse button. The graphic below shows these locations. The discussion which follows, describes what happens when you let go of the mouse button over the numbered locations.

---

Hold down:

- Mac
- Win

while you move the mouse over a selected object to get the Hand.
Isolate

- Letting go of the mouse over position #1 or #5 isolates, or solves for, this particular variable \(x\), to one side of the equation or the other.

\[
\begin{align*}
\text{Manipulation in progress} & \quad \text{Result} \\
\#1 & \quad \begin{cases} \color{red}y = (x-3)(x-2)x \\
\Delta \quad x = \frac{y}{(x-3)(x-2)} \quad \text{Isolate} \end{cases} \\
\#5 & \quad \begin{cases} \color{red}y = (x-3)(x-2)x \\
\Delta \quad \frac{y}{(x-3)(x-2)} = x \quad \text{Isolate} \end{cases}
\end{align*}
\]

Move Over

- Letting go of the mouse over position #2 moves \(x\) to the other side of the equation. \MathView maintains the property of equality by using appropriate mathematical operations to complete each manipulation. In the first example below, \MathView divides both sides by \(x\). In the second example, \MathView subtracts \(y\) from both sides.

\[
\begin{align*}
\text{Manipulation in progress} & \quad \text{Result} \\
\#2 & \quad \begin{cases} \color{red}y = (x-3)(x-2)x \\
\Delta \quad \frac{y}{x} = (x-3)(x-2) \quad \text{Move Over} \end{cases} \\
\end{align*}
\]

- You solve for zero by moving \(y\) over to the RHS of the equation. \MathView knows to subtract \(y\) from both sides.

\[
\begin{align*}
\text{Manipulation in progress} & \quad \text{Result} \\
\Delta \quad \color{red}y = (x-3)(x-2)x \\
\Delta \quad 0 = (x-3)(x-2)x - y \quad \text{Move Over}
\end{align*}
\]

Commute

- Letting go of the mouse over position #3 or #4 commutes the selected \(x\) to those locations.

\[
\begin{align*}
\text{Manipulation in progress} & \quad \text{Result} \\
\#3 & \quad \begin{cases} \color{red}y = (x-3)(x-2)x \\
\Delta \quad y = \frac{x}{(x-3)(x-2)} \quad \text{Commute} \end{cases} \\
\#4 & \quad \begin{cases} \color{red}y = (x-3)(x-2)x \\
\Delta \quad y = \frac{x}{(x-3)(x-2)} \quad \text{Commute} \end{cases}
\end{align*}
\]

The palette and menu method of \textit{Commute} requires a different selection. You must select a sum or multiple expressions before choosing the manipulation.
**Preliminaries**

Substitute is a method of replacing one type of expression with an equivalent one of a different form. You can determine a value for \( y \) by giving \( x \) a value in a second Prop and substituting it into the first equation. You can also substitute the value given to \( x \) into one or more of the \( x \)s in the target equation.

- Enter the equation, press \( \text{equi} \), and input \( x = 4 \)

\[
\begin{align*}
\square \ y &= (x - 3)(x - 2)x \\
\square \ x &= 4
\end{align*}
\]

- Select the \( x = 4 \) equation by clicking on the equal sign and, with the Hand, drag to the Prop icon of the target equation. Notice how all occurrences of \( x \) become targets as you move the mouse to the Prop icon. When you let go of the mouse the substitution occurs.

You can turn off Auto Simplify to have MathView show the intermediate step.

- Turn Auto Simplify off and perform the substitution. Select the RHS of the resulting equation and Simplify.

Same manipulation with Auto Simplify turned off

Selection \( \square \ y = (x - 3)(x - 2)x \)

\( \square \ x = 4 \)

Result \( \Delta y = 8 \) Substitute

\( \square \ x = 4 \)
Hand-Mouse Manipulations

You can substitute into any one $x$ in the target equation. For this example, use the Hand to do the substitution.

- Select the $x = 4$ equation with the Hand and drag the mouse to the second $x$ in the expression. You will see that MathView only highlights that one $x$. Let go of the mouse and observe the conclusion.

```
Selection
\[ y = (x - 3)(x - 2)x \]
\[ x = 4 \]
```

```
Target only one $x$
\[ y = (x - 3)(x - 2)x \]
\[ x = 4 \]

Auto Simplify turned off
```

```
Result after a Simplify
\[ y = (x - 3)(x - 2)x \]
\[ \Delta y = (x - 3)(4 - 2)x \]
\[ \Delta y = 2(x - 3)x \]
\[ x = 4 \]
```

You can achieve this last manipulation by using the palette icon or the Substitute menu choice under the Manipulate ▶ Other menu. The next example demonstrates how you can target one or more occurrence of $x$.

- Select the $x = 4$ equation again, and this time Shift-click one or more occurrences of $x$ in the target equation. After the selection, choose Substitute under the Manipulate ▶ Other menu or choose the substitute icon under the Hammer pop-up menu. Try choosing two of the $x$s (see below).

```
Selection
\[ y = (x - 3)(x - 2)x \]
\[ x = 4 \]
```

```
Palette icon chosen
\[ y = (x - 3)(x - 2)x \]
\[ \Delta y = (x - 3)(4 - 2)x \]
\[ \Delta y = 2(x - 3)x \]
\[ x = 4 \]
```

With the Hand you can selectively substitute into the target equation.

- Select the $x = 4$ Prop and move it, with the Hand, to the RHS of the equation. As you move the selection around, notice how one or all of the $x$s highlight as you navigate to different spots. Experiment with this manipulation to help in your understanding. Try choosing the $x$ on the far right of the expression. Now, choose all occurrences by moving the mouse down a little. The difference is subtle.

```
\[ y = (x - 3)(x - 2)x \]
\[ x = 4 \]

Mouse is on top of the $x$
```

```
\[ y = (x - 3)(x - 2)x \]
\[ x = 4 \]

Mouse is a little below $x$
```
Preliminaries

**Substitute** can recognize some substitutions which, at first, you may think require a manipulation before the equation matches the target expression exactly.

- Enter the first equation from the last example, press the Return key, and enter \(x^* (x-3)=z\)

\[
\begin{align*}
\square y &= (x - 3)(x - 2)x \\
\square x(x - 3) &= z
\end{align*}
\]

You may think that you need to solve for \(x\) before making the substitution. You do not.

- Select the second equation by clicking once on its equal sign and **Substitute** with the Hand into the first equation.

\[
\begin{align*}
\square y &= (x - 3)(x - 2)x \\
\square x(x - 3) &= z
\end{align*}
\]

Normally, to reverse the process, you would solve for \(z\) in the Assumption Prop and substitute the result into the Conclusion Prop to have *MathView* return the original target equation. **Substitute** can also substitute a variable isolated on the RHS, as \(z\) is in the Assumption Prop above, for single occurrences of that variable in a target Prop (as in the Conclusion Prop above).

- Select the Assumption Prop and Substitute it into the \(z\) of the Conclusion Prop (there is no equivalent menu or palette manipulation).

\[
\begin{align*}
\square y &= (x - 3)(x - 2)x \\
\triangle y &= (x - 3)(x - 2)x \\
\square x(x - 3) &= z \\
\square x(x - 3) &= z
\end{align*}
\]

If you have more than one occurrence of the variable in the target equation, you will have to make several separate substitutions.
You assign constants, variables, and functions distinctive names in MathView. You define names in a special proposition called a Name Declaration, and normally catalogue them in the Comment Prop called Declarations. To view the default names, open the first Prop in a “New Notebook” by double-clicking on its icon.

Name Declaration propositions designate the **Class** and **Behavior** of each name in your notebook. Each name declaration appears with a flag icon.

The proposition above declares that the name \(i\) is of class **Constant** and has the PreDefined behavior called **Square root of \(-1\)**. Since this name has a defined behavior, it will operate as such when used in the notebook.

- **Enter** \(\sqrt{-1}\) select, and **Simplify**.
- **In another Prop multiply** \(i\) times itself, select, and **Simplify**.

Names can be of class **Constant**, **Variable**, **M-Linear Operator** (matrix operators), **D-Linear Operator** (differential operators), or **Function**. The behavior of a name can be one of over sixty predefined behaviors, or it can be a behavior you define yourself. Defining the behavior of a name can be as simple as creating an equation using that name.

**User Defined Names**

You have two methods of creating a new User Defined name in MathView. First, you can create one by merely using it in a manipulation, or by typing it in and **Clarifying** the notebook. The first time MathView sees a new name, a dialog box opens asking you to define it. The default is usually **User Defined Variable**. When you hold the mouse down on the **Variable** button, a pop-up menu displays, giving you the opportunity to change the class.
Preliminaries

- Type the word `acceleration` into a Prop and choose `Notebook ▶ Clarify`.

![Declare Name](image)

- When you hold down the Variable pop-up menu, a list of the class choices opens. For now, release the mouse over `Variable` and press `Enter` to accept the default, `User Defined`.

The second method is to choose `Name Decl.` under the `Notebook ▶ Insert` menu. A blank declaration opens, in the now opened Declarations area, with a highlighted `?`. Using this method, you would type in `acceleration` and close the Declarations area by double-clicking on the balloon icon.

You have now declared the name `acceleration` as a User Defined variable. Both methods place the declaration at the top of the list inside the Declarations area and display `acceleration` on the variables palette.

You can change the class or behavior of a declaration by clicking on the pop-up menus in the name declaration proposition (now located inside the Prop called `Declaration`). You can also change the spelling of a name. Changing the spelling, class, or behavior of a name globally reflects throughout the notebook. Keep in mind, however, that changing the class or behavior of a name may invalidate existing derivations; `MathView` does not re-execute manipulations.

PreDefined Names

If you declare a name that `MathView` recognizes as a conventional mathematical term, it will give you the chance to define it as such, or it will allow you to assign your own definition. In other words, you can User Define the name. For example, enter `I` and choose `Clarify` under the `Notebook` menu. The dialog box which opens gives you the chance to `User Define` `I` or to `PreDefine` `I` as the modified Bessel function.

`MathView` has over five dozen `PreDefined Names`, each with an associated pre-defined behavior. The default “New Notebook” has several of these declared (all showing up on the palette). You can activate the remaining names as you need them. To see all of the names available, hold down the pop-up menu on the right side of any declaration and navigate through the various sub-menus.

You can have `MathView` display pre-defined definitions by selecting a name and choosing `Get Info` under the `Notebook` menu. The name’s behavior displays in a dialog box. Click the `More Info` button for further definition.
Transformation Rules

Transformation Rules are a powerful way to extend the capabilities of MathView. You use transformation rules to “transform” an expression of one type (the pattern) into an expression of a different type (the replacement) that is logically equivalent. You choose the manipulation which invokes each rule by selecting from a pop-up menu attached to the proposition. You can choose one of three manipulations: Transform, Simplify, or Expand. The manipulation you choose is up to you and depends on the type of rule you have created.

Transformation Rules can be quite simple. For example the trigonometric identity
\[ \tan(x) = \frac{\sin(x)}{\cos(x)} \]

is a rule already in the default notebook. The rule defines \( \tan(x) \) as the pattern and \( \frac{\sin(x)}{\cos(x)} \) as the replacement. You use the rule by selecting \( \tan(x) \) in your notebook and choosing Transform under the Manipulate menu. The expression \( \tan(x) \) is replaced by \( \frac{\sin(x)}{\cos(x)} \).

The default notebook has many rules inside the Declaration proposition and you will find many more inside the Distribution notebooks which came with your program. You can copy these to the notebook you are using, individually or as sets. You do this by clicking on the Prop icon (a lighting bolt) of the desired rule or the balloon icon if they are sets, and select Copy from the Edit menu. Click on the Declaration icon and select Paste to add them to your notebook. You can also copy nonadjacent rules by using the shift-click method of multiple selection.

Transformation rules do not have to be logical in the mathematical sense. You can create simple “macro” rules to help you in your work. For example, the following rule transforms the word line into the equation for a line, point slope form.

\[ \text{Upon } \text{Transform } \text{line into } y - y_1 = \frac{y_2 - y_1}{x_2 - x_1}(x - x_1) \]

- Create the rule by selecting Notebook ► Insert ► Transform Rule, and enter the parameters above.
- After you have created the rule, enter the word line in a new Prop, select line and choose Transform while you hold down Control (Mac) or Command (Win).

MathView replaces the word line (after you have declared line as a User Defined variable) with the equation for a line, awaiting your inputs for a particular point and a slope.

Wildcard Variables

You can use regular variables to define transformation rules or, for more flexibility, you can use Wildcard variables. If you use Wildcard variables, you can use any variable as an argument in your expressions. You are not limited to the variable used to define the rule. The next example demonstrates this feature.

Below is a well-known rule that you can find in the default notebook. Look in Declarations , under the Standard Rules ► Logarithms & Powers area.

\[ \text{Upon } \text{Simplify } \text{transform } \ln(x^2) \text{ into } 2 \ln(x) \]

The Simplify command (from the palette or Manipulate menu) will transform
Preliminaries

Remember, you can use regular, as opposed to Wildcard, variables in Transformation Rules, but the rule will only work if you use that explicit variable as your argument in the notebook.

\( \ln(\text{any variable}) \) to “any variable”. In other words, the independent variable does not have to be \( x \). It can be \( y \) or \( p \) or \( z \).

- Enter the following expression, select, and Simplify. MathView will ask you to define \( p \). Define \( p \) as a User Defined variable.

  Enter & Select \( e^{\ln(p)} \)
  Result \( e^{\ln(p)} \)

  \( e^{\ln(p)} = p \)

Look at the Transformation rule (located in the Declaration area) and notice two things: the use of the Wildcard variable \( x \); and the Transform pop-up menu. Wildcard variables allow you to use any variable as the argument, as stated above. This includes expressions. For example, if you have

\[ e^{\ln(2x + 3y)} \]

MathView treats \( 2x + 3y \) as \( x \) when you execute the Simplify command, transforming the expression as follows.

\[ e^{\ln(2x + 3y)} = 2x + 3y \]

Look at the Pop-up menu on the Transformation rule. It allows you to choose which manipulation invokes the rule. Hold down the menu and the choices appear.

As mentioned earlier, you can make your own rule by choosing Transform Rule under the Notebook ➤ Insert sub-menu. A blank rule opens where you can define your new rule. Below you create a basic trigonometric type. You will not find this rule in the default notebook.

- Enter the rule by selecting Notebook ➤ Insert ➤ Transform Rule and duplicate the inputs below.

Choose \( x \) in the Palette or Type ? \( x \)

New Rule \( \text{Upon Transform} \ \text{transform} \ ? \ \text{into} \ ? \)

Use the Pop-up palette to enter Wildcards or type a \( ? \) then the variable.

\( \text{Upon Transform} \ \text{transform} \ 1 \ \text{csc}\left(\theta\right) \ \text{into} \ \sin\left(\theta\right) \)

- Enter \( 1/(\csc(\theta)) \), select, and choose Transform from the Manipulate menu.

\[ \frac{1}{\csc\left(\theta\right)} = \sin\left(\theta\right) \]

Because you used the Wildcard variable \( x \) to define the rule, you were able to use
the non-matching variable $\theta$ as the argument. In fact, you could have used an expression as the argument. Try transforming $1/(\csc(x^2))$.

You can define patterns which contain more than one Wildcard variable. For example, in the Standard Rules subsection within the Declarations area there is the following trigonometric Transformation rule.

Upon $\text{Transform} \ ightarrow$ transform $\cos(\theta + \gamma)$ into $\cos(\theta)\cos(\gamma) - \sin(\theta)\sin(\gamma)$.

If you enter the following expression, select it, and choose $\text{Manipulate} \ \rightarrow \text{Transform}, \ MathView$ will give you the option of generating the following equation.

\[
\Delta \cos(x + y) = \cos(x)\cos(y) - \sin(x)\sin(y) \quad \text{Transform}
\]

There are some restrictions built into Wildcard variables however. For example, if you enter the expression $\sin(\gamma x)$ expecting $\text{MathView}$ to return the following. It will not work.

\[
\cos([y - 1]x)\sin(x) + \cos(x)\sin([y - 1]x)
\]

This is because $y$ is defined as a variable. For this transformation to work the first parameter in the expression must be a constant as demonstrated below.

\[
\Delta \sin(2x) = \cos((2-1)x)\sin(x) + \cos(x)\sin((2-1)x) \quad \text{Transform}
\]

Use following table as a guide when using Wildcard variables.

<table>
<thead>
<tr>
<th>Wildcard Variables</th>
<th>Matches</th>
</tr>
</thead>
<tbody>
<tr>
<td>$a - h$</td>
<td>Any constant expression, except matrices</td>
</tr>
<tr>
<td>$i - n$</td>
<td>Any non-negative literal integer</td>
</tr>
<tr>
<td>$o - q$</td>
<td>Any expression, except functions</td>
</tr>
<tr>
<td>$r - z$</td>
<td>Any constant or variable expression</td>
</tr>
</tbody>
</table>
Case Theories

Case theories are self-contained work areas that you can use to explore divergent trains of thought. For example, in a particular mathematical situation, you can explore a world where \( x = 3 \) and another where \( x = 99 \). If you have \textit{Always ReManipulate} turned on, you have learned that by merely changing the value of \( x \) you can observe different results. See page 51. To display both results in your notebook at the same time, however, requires two separate Case Theories. Each Case Theory must contain an equation defining \( x \).

- Input the following three Props.

  \[
  \begin{align*}
  & x^2 + 3x - 8 \\
  & x = 3 \\
  & x = 99
  \end{align*}
  \]

- Select the two “ \( x = \) ” Props, one at a time, and enclose in Case Theories by choosing Case Theory under the Notebook \( \textbf{Insert} \) menu.

- Select each case of \( x \) (one at a time again) and substitute with the Hand into the first Prop containing the target expression.

  | First manipulation | \( x^2 + 3x - 8 \) | \( x = 3 \) | \( x = 99 \) |
  |---|---|---|
  | Result after both substitutions | \( x^2 + 3x - 8 \) | \( x = 3 \) | \( x = 99 \) | \( x^2 + 3x - 8 = 10 \text{ Substitute} \) | \( x^2 + 3x - 8 = 10090 \text{ Substitute} \) |

Notice that the results inside each Case Theory are independent of each other. To help you keep track of the substitution, \textit{MathView} generates an equation which includes the target expression. When you have \textit{Always ReManipulate} turned on, you can use Case Theories to, not only explore, but display solutions using different values of \( x \).
Auto Casing

If you turn on Auto Casing (choose Manipulate ▶ Manipulation Prefs ▶ Auto Casing), any manipulation that has multiple solutions creates a Case Theory for each solution.

- For example, if you solve the following equation for \( x \) by making a multiple selection (each \( x \) highlighted) and selecting Isolate, MathView will display both solutions.

Select both \( x \)s

\[ x^2 - 4x = 4 \]

and Isolate

Result

\[ x^2 - 4x = 4 \]

\[ x = \frac{1}{2}(4 \pm \sqrt{32}) \]

Independence Declarations

As mentioned earlier, you use Case Theories to isolate divergent trains of thought. An example is the use of the Independence Declaration to perform partial differentiation. When you place an Independence Declaration inside a Case Theory, you can find partial derivatives without the declaration affecting the rest of the notebook, where you may need these dependencies. For an example, see page 165.

You enter an Independence Declaration by choosing Notebook ▶ Insert ▶ Independence Decl. The following Prop will appear with the ? highlighted, awaiting your input.

\[ \text{The variables are independent of each other} \]

Enter the variables you want to be independent of each other in vector form. Below \( x \) and \( y \) are declared independent of each other. Type \( x, y \) (MathView will automatically add the parenthesis). You can also have chosen variables independent of all other variables by selecting from the Pop-up menu to the right.

\[ \text{The variables \( \{x, y\} \) are independent of all variables} \]

Independence Declarations only affect manipulations after you have inserted the declaration into your notebook. They will affect all subsequent manipulations in the notebook unless you place them inside a Case Theory where they will only affect manipulations inside that Case Theory, or any Case Theory nested inside. They do not affect manipulations outside the Case Theory they are in.
Another use of Case Theories is to isolate Graph Theories (Graph Theories are introduced on page 71). MathView allows only one graph within the main theory (the notebook) for each dependent variable. This occurs because the same variable may have two or more definitions (for example $y = \sin(x)$ and $y = x^2$). If you try to generate two Graph Theories using both of the equations above, MathView will choose to plot the equation which occurs first in the notebook in both Theories. If you try to force the second Graph Theory to plot the second equation, by making it a Working Statement, both graphs will plot the second equation. To plot more than one equation using the same dependent variable, use a Case Theory to isolate each equation (this allows more than one Working Statement within the notebook). See the end of the Traces example (page 136) for an example.
Graph Theories

When you select an equation and choose the appropriate Graph menu item, you create a self-contained Graph Theory. Graph Theories contain a picture of the plot along with various Plot Propositions and tools used to control the display of the plot.

Plots dynamically link to the equation you use to generate the Graph Theory. This means that changes to the original equation immediately reflect inside the Graph Theory. In addition to controlling the actual plot with equations located outside the Graph Theory, MathView allows you to control graph details using definitions located outside the Graph Theory.

For the most part, MathView requires a function in explicit form to generate graphs. You must have the dependent variable isolated on the LHS before you can generate a Graph Theory. MathView does not require you to select the equation, only to have the cursor somewhere inside the equation, to generate a graph. Therefore you can select the Prop, select the equation in whole, or just have the cursor blinking inside of the equation prior to choosing the graph type.

Two-Dimensional Graphs

You generate a two-dimensional (2-D) graph, by selecting an equation and choosing the type of plot you want from the Graph menu, or by clicking on the appropriate palette icon (you can find the four most used graph types on the functions palette). Once you generate the Graph Theory, MathView provides a powerful set of tools to control the Viewport and the line details of the plot.

• Enter the equation \( y = \sin(x^2) \). Select the equation and choose Linear under the Graph \( \Rightarrow y = f(x) \) menu.

If you are working in a new notebook, the Graph Theory will automatically appear with the dependent variable, \( y \), as the ordinate and the independent variable, \( x \), as the abscissa. See the next page. If you have more than one independent variable in the equation, as in \( y = \sin(x + k) \), or if your notebook has several different variables in use, the dialog box below will open, asking you to define the \( x \) and \( y \) axes. Choose the appropriate pair and click OK.

MathView will label the axes with the variables of the equation according to your choice. You can, however, change these labels by opening the graph details and choosing another declared variable. See “Graph Labels” on page 74.
Preliminaries

- The following Graph Theory will appear, after you have defined the axes.

Graph Viewport Controls

The window containing the plot is called the Viewport. You have several tools available for customizing the Viewport.

The top button on the right side of the graph is called the Knife. You use this tool to zoom in on a portion of the plot. Clicking on it once, and moving the mouse to the Viewport turns the cursor to a picture of a knife. When you click down and drag across diagonally, a boxed marque appears defining a new Viewport. Let go, and the graph re-draws with the new bounds.

- Zoom in with the Knife

- To zoom out, click once on the Rocket-ship icon. Each time you click it, MathView zooms out by a factor of two. Using the results of the last operation, click three times on the Rocket to generate the following view.

To zoom-in, you hold down the Option-key (–Win, –Mac) while clicking on the Rocket. This reverses the zoom-out operation. Each time you click on the Rocket now, MathView zooms in by a factor of two.

- Perform this operation three times to go back to first zoom.
You can also adjust the Plot by using the mouse button. Before you try this, adjust
the Viewport, using the skills introduced to this point, so it looks similar to the
graph on the left below.

- As you move the mouse into the Viewport, it will turn into the shape of a
  Hand. This hand has a somewhat different shape than the hand used to
  manipulate equations. Click and drag the Hand to re-position the plot within
  the Viewport.

**MathView** has an option called **Always Redraw** (under the **Graph** menu). When
you have this option toggled on, graphs will automatically redraw when you
change the equation associated with that graph. If you change the equation with
**Always Redraw** toggled off, a “barber-striping” appears over the graph, and the
graph does not redraw. Click anywhere in the Viewport or choose **Redraw Now**,
under the **Graph** menu, to have **MathView** redraw the graph.

**Graph Details**

Your graph may look somewhat different and may have different
values, depending upon what you have done up to this point.

- You can fine tune the Viewport by opening the graph details and adjusting
  various controls. Open the details by clicking once on the details icon.

At the top of the details are the Viewport controls. To fine tune the Viewport, select
each of the numbers defining the Viewport and change them to the values below.
The Pop-up menus to the right allow you to change the proportions of the graph
and the cropping of the graph within the Graph Theory.
Preliminaries

To change a decimal, double-click on the number, type a zero, and then the decimal. Or double-click to select the whole number, and press the Delete key. Now input the decimal. MathView automatically places a zero and the decimal point.

- Use the following choices.

  -2 \ldots 2 = \text{left..right}
  -0.1 \ldots 1 = \text{bottom..top}

  Proportions

  Cropping

Your graph will look like the one below. Experiment on your own with the Proportions and Cropping.

Graph Resolution

You control the resolution of the graph with the accuracy icons located just beneath the Rocket icon. The More Accuracy button increases the resolution and the Less Accuracy button decreases the resolution of the plot. As you click on the buttons, the resolution briefly shows up to the left of the icon. Below, the screen-shot captures the Theory in the middle of a reduction in accuracy (from 8 to 4).

A default graph starts out with a resolution of 8. This has no practical meaning other than it is how MathView draws curves (8 line segments make up a 90° curve). When you click on the More Accuracy button the resolution will increase. The available range is from 1 to 1024. Keep in mind that the more accurate you make the graph, the more time it will take MathView to plot the graph.

Graph Labels

When you open the graph details by clicking on the detail button, you will find two propositions inside. The first is the Declarations comment Prop. The second is the Line Detail Prop.

- Open the first Prop by double-clicking on its icon. Inside are the plot propositions you use to control the grid-line details and the axis details.

The Pop-up menus attached to each contain the PreDefined names and colors which MathView uses to define that particular detail. Click on each of them to see the choices within.
The last four Name Declarations are the left, right, bottom, and top graph constants. These are special declarations that every graph contains. The grid line and axis propositions are at the top. You use these definitions to determine their respective characteristics. Left means the leftmost boundary of the Viewport; Right means the rightmost boundary of the Viewport; and so on. You can change these default values in the grid line and axis Props by selecting and changing them to some other constant value. A purpose for this would be to limit one or more of these details. The screen-shot below displays the y-axis grid lines changed (left changed to 0).

![Graph with y-axis grid lines changed](image)

Below is the resulting graph after you have removed the y-axis grid lines for values less than zero.

![Graph with y-axis grid lines removed](image)

There may be a situation where you want to change the graph labels. Perhaps Force and Time would be better than $F$ and $t$. To demonstrate, re-label the $x$ and $y$-axis Props.

```
3: Axis at (left, y) where y = bottom ... top labeled Force on other side ... colored Lilac
4: Axis at (x, bottom) where x = left ... right labeled Time on this side ... colored Lilac
```

New axes labeled Force & Time

Set cropping to Moderately Wide.
Preliminaries

You can eliminate any graph detail by selecting the whole Prop (click on its leading icon) and pressing the Delete key.

**Line Detail**

The Prop at the bottom of the detail area is the Line detail. The Line detail is the dynamic link between the Graph Theory and the equation.

\[ y = \sin(x^2 + 1) \]

The variable \( x \), the first element of the vector \((x,y)\), represents the independent values `MathView` assigns to the graph. You have defined the second element, \( y \), as \( \sin(x^2) \), outside of the Graph Theory. Any change to the expression defining \( y \) will automatically change the graph.

- Select the \( x^2 \) in the original equation and type +1. The plot immediately re-draws, reflecting the new equation.

Not only is the line dynamic, the details inside the theory are dynamic. For example, you can change the line plot by changing the Line detail.

- Set up two Props giving \( a \) and \( b \) values and `Clarify` to have the graph re-draw. You can now change these values to have the domain change automatically.

Plot Range

restricted to values assigned to
\( a \) and \( b \)
Adding Additional Lines to a Plot

You add a line plot to an existing Graph Theory by creating an equation in a new Prop, selecting it, and choosing Add Line Plot from the Graph ▶ Additional menu. The new equation must have a different dependent variable from the original equation for the Graph Theory to plot both lines.

You can use the same variable if you change it in some way, such as indexing it, or labeling it with a subscript.

- Enter the $y = \sin(x^2)$ generate a line plot, and press (OK).
- Enter $y' = -\cos(x^2)$ Choose Add Line Plot from the Graph ▶ Additional sub-menu.

You must define this new variable, so when the Name Declaration box opens, accept the default User Defined Variable (by pressing (OK) or clicking OK). Since MathView will not know the dependencies, it will ask you to define them by presenting you with the following dialog.

- Make sure $y'$ is the choice for the $y$-axis and $x$ the $x$-axis; click OK.

The Graph Theory will re-draw, adding the new line.

Opening the graph details reveals the new line detail with the line defined as $(x, y')$.

Every new line plot will take on a new color according to MathView’s rules. You can change these by clicking on the color Pop-up menu for each line detail and choosing a different color.
Preliminaries

Super Knife

You can reverse multiple knife zooms with the Super Knife. Normally, when you perform a zoom, the knife de-selects itself immediately after the zoom. To perform a second zoom, you must select the knife again. Getting back to the original proportions of the Graph Theory is not possible unless you remember the original Viewport bounds, because an **UnDo** only takes the Plot back to the last zoom that you performed.

The Super Knife eliminates this problem by allowing you to perform multiple zooms. To choose the Super Knife, double-click on the knife. A new knife icon, which looks like a dagger, appears when you move the mouse into the Viewport. The knife will stay selected for multiple zooms and an **UnDo** will take the graph back to its original appearance.

You cannot perform any other action between zooms; otherwise, you interrupt the chain of zooms, and an **UnDo** will only take the detail back to the place where the interruption occurred. Try using the Super Knife to perform several zooms on a plot. Click on the More Accuracy button, then perform a couple of more zooms. Choosing an **UnDo** will only take the plot back to the place you chose to increase the accuracy and not to the original plot.

The Super Knife mode works for all Graph Theories (2-Dimensions and 3-Dimensions) according to how the knife works in that type of Graph Theory.

Three-Dimensional Graphs

You generate and manipulate three-dimensional plots in much the same way as two-dimensional plots.

- Type this equation into your notebook: \( z = 1.5^y \sin(x) \)
- With the blinking cursor in the equation, choose **Graph** ➤ \( z = f(x,y) \) ➤ **3D**. A dialog appears asking you to confirm the axis variables. Match the variables to their axes, and click **OK**. A three-dimensional graph theory appears with a surface plot.

As with two-dimensional graphs, the cursor becomes a hand for scrolling the graph. This time, it works differently. As you click and drag the image left, right, up, or down, the portion of three-dimensional space displayed in the Viewport rotates as if you had your hand on a globe.

As with 2-D graphs, if you have **Always Redraw** turned on, the graph will continually redraw as you change the equation.
Below, the Hand cursor rotates the example plot.

As you drag the plot in the Viewport, the movement takes on a type of animation. When you click and grab the plot, move the hand, and release the mouse button while the hand is still, the plot redraws in the new orientation. However, if you click and grab the plot, move the hand, and while the mouse is still moving release the mouse button, MathView continually redraws the plot along the desired rotation path.

The grab-and-stop method is like someone slowly moving a globe to position it at a specific location, whereas the grab-and-swipe method is like spinning the globe. You determine the amount of momentum by how short or long the “swipe” is—grab a corner and swipe to the opposite corner for lots of momentum or grab in the middle with a short swipe for a less radical rotation.

A feature unique to three-dimensional graphs is the orientation guide in the lower left of the graph proposition. It displays a cube which you can think of as the 3-D graph space. The cube by itself indicates you are looking at your graph’s original orientation. The cube with an arrow pointing to one of its sides indicates which side you are looking at (in the graph above, the left pointing arrow indicates that you moved the plot from right to left). You click on the icon to return the graph to its original orientation.

The More Accuracy button increases the number of data points for a higher resolution plot, which makes certain types of plots smoother. When you click on the More Accuracy button, the square panels which make up the surface become more numerous and smaller, indicating better resolution. Click once or twice on the button now to increase the resolution.

Rotate the graph to see the effects of the higher resolution. The more detailed graph looks pretty, but has a slower drawing speed. Higher resolution makes better looking pictures, but you will probably want to keep the accuracy low while working with MathView, no matter how fast your computer.

The Less Accuracy button has the opposite effect of the More Accuracy button. It decreases the number of data points for a lower resolution plot. Give the Less Accuracy button several clicks now, and take the resolution all the way down to 1. Notice that the plots become less appealing as you go. Click the More Accuracy button a few times to bring the resolution back to its original setting of 8. Notice the slower drawing speed as you go.
Preliminaries

The knife, which zooms in on a specific section of the graph to see more detail, works somewhat differently in three dimensions than in its two-dimensional counterpart. To see how it works, re-orient the graph so you are looking down at the top of the surface (or up from below). This process works best when you are looking at a surface perpendicularly. Click on the knife, as before. Your cursor turns into a knife, ready to slice out and enlarge a piece of the graph. This time, you slice out a section of the graph by dragging on the surface itself. The piece you slice out constitutes a number of whole panels. To reverse the zoom, choose UnDo from the Edit menu.

3-D Graph Details

The graph details of three-dimensional plots are very similar to two-dimensional graph details, with the exception that you have a third axis. The easiest way to visualize this is to think of tipping a normal 2-D graph (with x-y axes) into the computer screen and adding a third axis, the z-axis, in the place of the old y-axis. The dependent variable now becomes the z-axis.

Three items are different from the details in 2-D Graph Theories. First, you have a third Viewport control to accommodate the third axis. In addition, MathView labels these controls differently than in the 2-D counterpart.

Secondly, to accommodate the third dimension, the Axis and Grid line Props are somewhat different. An additional Axis Prop (z-axis) appears, but the Theory still only has two Grid line Props. This is so the Theory does not become too cluttered. In addition, MathView defines and places new 3-D constants inside the graph Declarations Prop.

Lastly, MathView generates a Surface Plot detail, rather than a Line detail. A surface plot has additional controls, not found in line details. These control the color and shading of the plot.

• Input the following equation and generate an Illuminated 3-D Graph Theory.
  \[ z = \frac{x + y}{2} \]
To achieve the best reproduction of your graphs with black and white printers, choose **Illuminated** for the surface-characteristic.

First note the Viewport details. *MathView* uses geographic names to refer to the Viewport bounds. The x-axis range is west...east, the y-axis is south...north, and the z-axis is bottom...top. The first two controls are the same as the x and y-axes in 2-D graphs. The control for the z-axis acts like a zoom-lens. The best way to learn what these controls do is to experiment.

The surface detail has several controls which you will learn best by experimenting with them. They include surface-characteristic, surface-mesh, and surface-coloring.

**Adding Surface Plots**

You add additional surface plots to existing 3-D Graph Theories by entering a new equation in its own proposition and choosing **Add Surface Plot** from the **Graph** ➤ **Additional** menu. As was true with 2-D Graph Theories, you must use a new dependent variable.

You can add Surface Plots to 2-D Graph Theories to shade areas between curves. See page 182.

**Plotting External Data**

You can plot data obtained from external sources that have **equally** spaced independent values. First you select the data and paste into a blank table. See page 87. From here you select the table and choose the type of plot you want from the **Graph** menu. You can use this method to plot both 2-D and 3-D imported data. See page 21 for an example of plotting table data.

If you have unequally spaced independent values, you must import them into a named matrix and then generate the plot. See the section on matrices, starting on page 89. You copy the external data and paste into the matrix you have created. Select the equation containing this matrix and plot. You can only use scatter plots for this type of data (either 2-D or 3-D). You can find an example showing how you plot data, once in this form, in “Scatter Plots & Data Analysis” on page 126.

**Animating a Graph**

*MathView*’s animation facility lets you view a family of related graphs in quick succession. The animation creates the illusion of movement by creating several versions of a graph as one variable changes, saving these images, and displaying them in rapid succession.

The first step in the animation process is to modify a graph by incorporating an extra “time” or “animation” parameter into an expression. This animation parameter changes in value from one frame of animation to the next.

Because animation is memory-intensive, before you use it you should make sure *MathView* has as much memory as possible. If you do not have sufficient memory, the animation will become choppy and will take longer to run. You can help matters by increasing the memory available to *MathView*, or by reducing the size of the graph using the re-size box.

- Start by animating a simple two-dimensional graph. Create a new notebook and type \( y = \sin(x) \) Generate a Linear Graph Theory.

Next you add an animation parameter. The added variable chosen for this example causes the phase of the sine wave to vary from one frame to the next when the animation begins.

- Select the \( x \) and type \(+a\).
After typing \(+a\), the error message below appears in the Viewport. You have not assigned \(a\) a value yet, causing the error message. The message will go away as soon as you start the animation because MathView assigns several values to \(a\) automatically.

- Select the animation parameter, \(a\), and choose **Start** under the **Graph Animation** menu. The animation appears in place of the graph proposition.

The animation begins at a start value and increments by the step value for each frame until it reaches the ending value. The first time through the sequence, MathView draws each frame slowly and carefully on the screen, saving each frame in memory. After MathView has saved the last frame in this manner, the actual animation begins.

To halt the animation click the mouse anywhere in the notebook. To resume, click within the graph Viewport. To stop the animation and return the viewport to the inanimate graph state, choose **Graph Animation Stop**. The animation will stop and MathView throws away the rendered frames currently in memory, and deletes the animation controls box below the graph.

While the animation is in a suspended state, you can use all zooming and accuracy controls. After making adjustments to the Viewport, click inside the Viewport to resume the animation.

When the animation is running, MathView displays a copy of the Viewport, but without the editing icons.

Below the animation are the animation controls, including a statement with some settings and pop-up menus.
The statement says “**Animate this graph for**” followed by the animation variable and the domain over which the animation variable will vary. This domain often defaults to run from zero up to $2\pi$. You can change either or both of these values.

Functions that are naturally periodic should use the “in a cycle” setting. Images for the starting and ending values should appear the same. If your function is non-periodic, use the “one-way” setting which pauses briefly between the last and first frame.

To the right of the domain is the total number of frames to use in the animation. More frames produces smoother animations, but available memory limits the actual number of frames that you can create. The number of frames defaults to ten (regardless of the available memory). If more memory is available, you can increase the number of frames. If not enough memory is available, decrease the number of frames (otherwise MathView re-generates frames during the animation, which is slow and undesirable).

When you increase the number of frames, the step value decreases and the visual resolution of the animation improves. You can determine the step value by dividing the range of values by the number of frames. Changing the starting or ending domain values (or both) adjusts the step size but does not change the number of frames. Changing the step size directly affects the number of frames.

You use the speed pop-up menu to set the speed of the animation playback. Speeds range from one frame every two seconds (1/2 fps), to thirty frames per second. One additional setting, “Maximum,” displays the images as fast as your machine can move them from memory to the screen.

- When you stop, the animation parameter will show as an error again. Select the equation and press [Clarify]. Type \(a = 1\) and Clarify the notebook. The graph re-draws and you can now change the value of \(a\) to study individual translations.

**3-D Animation**

You can select \(a\) or you can select the \(a=1\) Prop or just have your cursor somewhere inside the \(a=1\) Prop.

You animate a 3-D graph the same way you animate a 2-D graph.

- Type in the equation: \(z=1.5^y \sin(x)\)
- Select the \(x\) and type \(+a\).
- Select \(a\) and start the animation.

For comparison, most cinematic movies display using thirty frames per second.

For a better view rotate the plot to the left and down so you are looking on top of, and somewhat down, the \(x\)-axis.
Preliminaries

Blank Slots

*MathView* has a feature under the **Graph ▶ Additional** menu called **with blank slots**. When you have this menu item toggled on, choosing any **Add..** item in the same menu will produce that item with '?'s in place of most parameters. This feature allows you to add plots to a Graph Theory without creating superfluous equations. It also allows you to add a different type of plot to a Graph Theory. For example, a surface plot detail to a linear graph. See an example on page 183.

Below is an example showing the results of adding a line plot when **with blank slots** is toggled on.

```
// Line at (?;?) where ? = left ... right with a
\normal/ line, colored \Red/.
```
Tables

A table is a proposition used to hold data values. You can create tables from expressions, graphs, or data imported from an external source. You can extract individual data values from tables, as well as manually change individual values. You can also export the data within the table to other programs.

Tables are much more efficient at storing large quantities of numbers than expressions. Whereas matrices of over 100 rows can get unwieldy; tables can easily hold tens of thousands of entries. Available memory is the only limit to the size of a table.

MathView has two table types: Real-valued and Complex-valued. Real tables contain a list of real values for the function. Complex tables allow two numbers, one for the real part and one for the imaginary part of each value. Both contain information about the allowable domain, and the correspondence between the domain and range values.

MathView tables store numerical values in a convenient condensed format. A table proposition in a MathView notebook consists of a proposition icon, table name, snapshot, and details icon.

- Input the expression $\sin(x)$, select, and choose Generate... under the Manipulate ▶ Table menu. The following dialog opens.

![Table Proposition Dialog]

- Click OK to accept the default. A Table proposition generates which looks like the following.

![Table Proposition]

The snapshot depicts the numerical values stored in the table. In the example above, the table looks like it contains values corresponding to a single cycle of a sine wave. The wider the snapshot, the more values are in the table. The snapshot has a logarithmic relationship to the data, so you will see a representative view no matter how large or small the table. In the graphic below, both tables have the same domain, but the first has 64 data points while the second has 200.

![Table Comparison]
The table creation dialog, which displays when you first generate a table, allows you to specify the type of table (real or complex), the domain of $x$ values, the number of points to calculate and store, and the variable that advances over the domain of the table. Notice how the dialog box shows the expression you are evaluating ($\sin(x)$ in this case).

- The highlighted $?$ indicates a letter or word which allows you to define a function using the table. Enter $T$ as the name of the function. **Clarify** and define $T$ as a User Defined function.

The table proposition acts like an equation that defines the function $T$, just like a working statement, allowing you to treat it like any other User Defined function.

The table details icon button at the right of the proposition allows you to see the details (data), stored in the table. It behaves in a manner similar to the graph details button. See page 73.

- Click on the button now, to see the data in the table.

The four buttons immediately below the snapshot allow you to export or import data to or from external files or the clipboard. Subsequent sections explain data transfer with these buttons.

The domain numbers define the $x$ value distribution of the data points. The range numbers show the minimum and maximum $y$-values present in the table. In this discussion, $x$ and $y$ refer to the domain and range; in practice, any variable can be used. The increment number, labeled “inc”, defines the increment along the $x$-axis between $x$ values. The points number shows the total number of data points in the table. You can edit the non-italic numbers in the table. See page 22 for an example.

**Complex Tables**

Complex tables look very much like real tables except the table snapshot will be in color. The height represents the real part. The colors tell you the complex phase, using the rules below.

- yellow = positive real (the lightest color)
- blue = negative real (the darkest color)
- strawberry red = positive imaginary
- sea green = negative imaginary

You can find the real and imaginary parts of a complex table by using the PreDefined functions $\text{Re}$ (Real) and $\text{Im}$ (Imaginary).

**IMPORTANT**

You must always have equally spaced independent values in MathView tables. This includes imported data.
• Input the expression $e^{ix}, (e^{i\cdot x}),$ in a new Prop. Select and choose
Manipulate ► Table ► Generate. Name the table $T$ (User Defined Function).

$e^{ix}$

With a color monitor, the table snapshot will be a rainbow of colors, each representing parts of the output, according to the list above.

• You can extract the imaginary and real parts from the table by setting up the following equations. Give $x$ a value and substitute it into each of the equations. MathView will give the associated values. Be sure to pre-define $\text{Im}$ and $\text{Re}$ as the real and imaginary functions (the default when the dialog box opens).

$y = \text{Im}[T(x)]$

$\Delta y = \text{Im}(T')$

Create a Prop where $x = 2$

$y = 0.0083$

Substitute

$\Delta y = \text{Re}(T')$

$y' = \text{Re}(T')$

Substitute

$y' = -0.41915$

Calculate

$x = 2$

• Plotting the two equations in the same graph theory produces the expected sine/cosine waves.

$y = \text{Im}[T(x)]$

$y' = \text{Re}[T(x)]$

Importing Data to a Table

Tables allow you to import data from external sources, such as a spreadsheet.

• Create an empty table by clicking the palette button (or choose Manipulate ► Table ► Generate...). Click OK at the dialog; the settings are not important because you will replace everything shortly.

• Go to your spreadsheet program. Type in random numbers, pressing $[\text{Enter}]$ after each. Type in a dozen numbers or so, then select the whole column.

• Choose Copy from the spreadsheet program’s Edit menu. Go back to MathView, open the table details and click on the Paste button in the table.

(Do not choose Paste from the Edit menu or use the command keystroke). Using the table Paste button allows MathView to adjust the length of the table to fit the data you are importing.

If you place is a comma in a number, MathView interprets your input as two numbers. For instance, MathView interprets the text “12,345” as two numbers, “12” and “345”. Set the formatting options in the spreadsheet so the numbers will not have commas.
Preliminaries

You can load data from a text file into a table.

- Go to the spreadsheet program and save the worksheet as a text file. Go back to MathView and your table. Click on the Load button and use the file selection dialog to open the file you just saved.
- This button lets MathView read in a text file that has numbers in it. The syntax rules for the text file are exactly the same as for the Paste data.

<table>
<thead>
<tr>
<th>Save</th>
<th>Load</th>
<th>Copy</th>
<th>Paste</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

If you are importing data which contains the independent values, they must be equally spaced, or MathView will over-ride them with its own values which are equally spaced.

Use a Matrix to study data with unequally spaced independent values. See page 89.

Reading data into a complex-valued table is similar to that for a real-valued table, except that instead of one or two columns of data (the first column of a two column real data list must be the independent values), you must have two or three columns of data; the extra column is the imaginary part.

Exporting Table Data

Create a table of data using one of the methods described in the previous section.

- Open the table details. Click on the Save button, which brings up a file selection dialog. The dialog allows you to give a file name and a location where you can save the data from the MathView table. The data is now in a text file which you can use in most spreadsheet and word processing programs. The data for a real table is always a single column of numbers, separated by new lines. Complex tables have two columns, one for the real part, and one for the imaginary part.
- You can transfer data from a table to the clipboard. Simply click on the Copy button. MathView places the dependent data values onto the clipboard.

Other Tables

MathView has two other table generators. First is the Differential Equation table generator. You can take a selected differential equation and generate values using either the Euler or the Runge-Kutta numerical methods. You can then plot the table in a graph theory. You can compare this plot to the solution of the differential equation by adding the solution curve to the Graph Theory. See “Numerical Methods” on page 197 for further instruction.

The second is the Fourier Transform and Inverse Fourier Transform. Generate a table you want to transform, select the table, and choose Fourier Transform or Inverse Fourier Transform from the Manipulate ➤ Table menu. MathView creates a new table with the results of the Transform in it.
Matrices

You have two methods of entering matrices. First is to select the Pop-up menu located on the Functions palette. When you hold down the button, several matrix configurations appear. Move the mouse to the row/column number desired and let go. MathView generates the selected matrix with the members as ? marks, awaiting input. Type the first number and † to input the second and subsequent numbers.

**Method 1**

- Select a $3 \times 3$ matrix from the Pop-up menu. The following will appear.

  $\begin{pmatrix}
  \text{??} \\
  \text{??} \\
  \text{??}
  \end{pmatrix}$

- Type $1, 2, 3; 4, 5, 6; 7, 8, 9$

**Method 2**

The second input method is by command line. Input the first member and type a comma (,). Type the second member in the first row, type a comma, and so on. To go to the second row type a semi-colon (;).

- Type $1, 2, 3; 4, 5, 6; 7, 8, 9$

**Importing Data to a Matrix**

You import data from an external source by copying the data and pasting it into an empty matrix. The following example assumes that you have a two column set of data which you want to import to a MathView matrix.

- Select a two column, one row matrix from the Pop-up menu.

  $\begin{pmatrix}
  \text{??} \\
  \text{??}
  \end{pmatrix}$

- Go to your spreadsheet or word processor and copy the data you want to import. Be sure to format the numbers without commas, before you copy them.

- Select both ? marks in the matrix (important).

  $\begin{pmatrix}
  \text{??} \\
  \text{??}
  \end{pmatrix}$

- Choose Paste from the Edit menu.

You use matrices in MathView to study data which has unequally spaced independent data values.
Preliminaries

Numeric Addition and Multiplication

• Press \[ \begin{pmatrix} 1 & 2 \\ 3 & 4 \end{pmatrix} \] and input the following. \( (1, 2; 3, 4) \times (5, 6; 7, 8) \)

\[ \begin{pmatrix} 1 & 2 \\ 3 & 4 \end{pmatrix} \]

You can add or subtract these matrices using the appropriate \( \text{Op.} \)

• Select both matrices together or click once on the Prop icon and \textbf{Calculate}.

Symbolic Operations

\textit{MathView} can also add, subtract, and multiply symbolically. Delete just the conclusion from the last manipulation by clicking on the Prop icon, and pressing \textit{Delete}.

• Change the 2 in the first matrix to an \( x \).
• Select both matrices again and this time click the \textbf{Expand} button (or choose \textit{Manipulate} \( \gg \) \textit{Expand}).

MathView considers a scalar (single number or variable) the same as a diagonal matrix.

• Go back to the first matrix you made and select just the matrix by dragging through it. Type \( + x \). Select the whole expression by clicking on the Prop, and \textbf{Expand}.

Matrix Inverse

You can find the (multiplicative) inverse of a matrix in several ways. You can use division or you can use the typical notation of raising the matrix to the \(-1\) power. Note that you can apply the matrix operations directly to the matrix itself or, as you will see in the following example, to a symbolic name which represents the matrix (for example, \( A \), \( B \), etc.).

• Begin by typing \( A = \begin{pmatrix} 1 & 1 & 2 \\ 3 & 9 & 2 \\ 2 & 4 & 2 \end{pmatrix} \) create a named matrix.
• \textbf{Clarify} the notebook and declare \( A \) to be an \textbf{M-Linear Operator}, the name definition which includes matrices.
• Below the matrix, in its own Prop, make another proposition for the inverse of
Matrices

\[ A, \text{ by typing } A^{-1} \]
\[
\begin{bmatrix}
1 & 2 \\
3 & 2 \\
\end{bmatrix}
\]
\[ A^{-1} = \begin{bmatrix}
1 & 2 \\
3 & 2 \\
\end{bmatrix}^{-1}
\]

- **Substitute** the first equation, the one which defines \( A \), into the expression for its inverse.

  Substitute Manipulation

  **Result**

  \[ A^{-1} = \begin{bmatrix}
1 & 2 \\
3 & 2 \\
\end{bmatrix}^{-1} \]

- After substituting, select the RHS (you can click slightly below the –1) and **Expand** twice.

  Select RHS by clicking below the exponent.

  \[ A^{-1} = \begin{bmatrix}
1 & 2 \\
3 & 2 \\
\end{bmatrix}^{-1} \]

  **Result after Expanding**

  \[ A^{-1} = \begin{bmatrix}
1 & 2 \\
3 & 2 \\
\end{bmatrix}^{-1} \]

  \[ A^{-1} = \begin{bmatrix}
10 & 6 & -16 \\
-2 & -2 & 4 \\
-1 & 4 & 2 \\
\end{bmatrix} \]

  **Expand**

  \[ A^{-1} = \begin{bmatrix}
-5 & -2 & 4 \\
2 & 2 & 1 \\
-1 & 2 & -3 \\
\end{bmatrix} \]

  **Expand**

To obtain a numeric solution, **Calculate** the RHS. To go directly to the decimal answer, **Calculate** the \( A^{-1} \) Prop from the start.

  Select inverse Prop

  **Result**

  \[ A^{-1} = \begin{bmatrix}
-2.5 & -1.5 & 4 \\
0.5 & 0.5 & -1 \\
1.5 & 0.5 & -1.5 \\
\end{bmatrix} \]
Preliminaries

Generally, you use **Expand** for operations involving symbolic matrices with variables or irrational numbers, and **Calculate** for numeric operations.

Determinants

You can find determinants by following the next example.

- Start by turning off **Auto Simplify** by choosing **Auto Simplify** from the **Manipulate ▶ Manipulation Prefs** submenu.
- Type \( B = \begin{pmatrix} 2 & 3 & 5; 4 & 1 & 5; 7 & 3 & 4 \end{pmatrix} \). *MathView* provides the closing absolute bar.

Alternatively, you can use the Absolute Value palette button to input \(|B|\). Select the \( B \) in the second Prop and click on the Absolute Value image.

- **Clarify** and declare \( B \) as a **M-Linear Operator**. Drag the equation defining \( B \) into the expression for the determinant of \( B \) and **Expand** the RHS. **Calculate** that result.

\[
\begin{align*}
\Delta |B| &= \begin{vmatrix} 2 & 3 & 5 \\ 4 & 1 & 5 \\ 7 & 3 & 4 \end{vmatrix} \\
\Delta |B| &= 2(1 \cdot 3 \cdot 4) - 3(2 \cdot 3 \cdot 4) + 5(2 \cdot 1 \cdot 7) + 5(2 \cdot 3 \cdot 7) - 3(4 \cdot 3 \cdot 4) + 5(4 \cdot 1 \cdot 7) \\
\Delta |B| &= 60
\end{align*}
\]

If you have **Auto Simplify** turned on, the substitution simplifies automatically to \(|B| = 60\).

Of course, you can only calculate determinants for **square** matrices. If the matrix you select is not square, you will get a warning message from *MathView*.

Cross Product

The Cross Product Op takes two 2-vectors or two 3-vectors (either row or column) and returns the cross product. You can define the vector elements as Constants, Variables, M-Linear operators, or D-Linear operators. The result is a scalar for 2-vectors or a 3-vector for 3-vectors. You enter the Cross Product Op by clicking on the Palette image and using the Tab-key to enter the vectors. Alternatively you can type “##” between the vectors. You can also use variables to define the vectors and perform the manipulation on the variables (see below).

- Enter the two Props below, defining the vectors along with a third defining the Cross Product of the two variables.

\[
\begin{align*}
x &= (1, 2, 3) \\
y &= (2, 3, 1) \\
x \times y
\end{align*}
\]

Enter with the Palette or type \( x \ ▶ ▶ y \).
Matrices

- You generate the cross product by selecting the Cross Product Prop (or you can click once on the × Op) and performing a Calculate.

Alternatively you can enter the vectors directly. Expand works here.

$\mathbf{v} = (1, 2, 4)$

$\mathbf{w} = (1, 4, 5)$

$\mathbf{v} \times \mathbf{w} = \begin{pmatrix} 6 \\ -12 \\ 8 \end{pmatrix}$

You can show the intermediate step by substituting $x$ and $y$ into the Cross Product Prop first and then performing a Calculate or an Expand on the result.

Dot Product

The Dot Product Op returns the pairwise product of the elements of two vectors. The two must have the same number of elements, but can be either row or column vectors. The result is a scalar.

Enter by using the palette image or by typing the two vectors separated by "**@

- Enter the following three Props, select the Dot Product Prop, and Calculate.

Alternatively you can enter the vectors directly. Expand works here.

Simple Linear Systems of Equations

To solve multiple equations with multiple unknowns, the general strategy is to eliminate variables one by one until you have one equation in one unknown. Then you solve it. To eliminate a variable, take any equation, solve for the variable you want to eliminate in terms of the others, then substitute it into all the rest of the equations.

- Enter the following two equations in separate Props. Type $5 = y - 3x$

$25 = y + x$

- Select the $x$ in the first equation, and Isolate.

- Take the first equation (now a conclusion) and substitute it into the second equation. Make sure you select the equation for $x$. Click on its equal sign to select it.

Substitute Manipulation Result

Immediately Expand to combine the two $y$s.
Preliminaries

- Solve for \( y \) in this new equation by Isolate\((\text{e})\)ing with the mouse.

\[
\begin{align*}
\Delta x &= \frac{1}{3}(y - 5) \quad \text{Isolate} \\
\Delta y &= \frac{4}{3}y - \frac{5}{3} \quad \text{Expand} \\
\Delta 25 &= y + x \quad \text{Substitute} \\
\Delta 25 &= \frac{4}{3}y - \frac{5}{3} \quad \text{Expand} \\
\Delta y &= 20 \quad \text{Isolate}
\end{align*}
\]

- Complete by substituting the \( y = 20 \) Prop into the \( x = 1/3(y - 5) \) Prop.

\[
\begin{align*}
\Delta x &= \frac{1}{3}(y - 5) \quad \text{Isolate} \\
\Delta x &= 5 \quad \text{Substitute} \\
\Delta 25 &= y + x \quad \text{Substitute} \\
\Delta 25 &= \frac{4}{3}y - \frac{5}{3} \quad \text{Expand} \\
\Delta y &= 20 \quad \text{Isolate}
\end{align*}
\]

Verify, by selecting both the \( x \) and \( y \) Props, and substituting into one or both of the original equations.

Larger Linear Systems

You can use MathView’s Matrix Op to solve a system that has the same number of equations as unknowns. You do this by taking the inverse of the matrix defining the coefficients of the variables. The next example shows how to solve the following system of equations.

\[
\begin{align*}
5x + 6y - z + w &= 3 \\
2x + 2y + 4z - w &= 7 \\
-4x + 3y + 9z + 12w &= -4 \\
y + 3z - w &= 0
\end{align*}
\]

- Type the following in a new Prop. \((5, 6, -1, 1; 2, 2, 4, -1; -4, 3, 9, 12; 0, 1, 3, -1)^\ast(x; y; z; w) = (3; 7; -4; 0)\)

\[
\begin{pmatrix}
5 & 6 & -1 & 1 \\
2 & 2 & 4 & -1 \\
-4 & 3 & 9 & 12 \\
0 & 1 & 3 & -1
\end{pmatrix}
\begin{pmatrix}
x \\
y \\
z \\
w
\end{pmatrix}
= 
\begin{pmatrix}
3 \\
7 \\
-4 \\
0
\end{pmatrix}
\]

- Select the variables vector and Isolate.
• **Expand** the RHS two times for the answer (only the final result is shown below). While you still have the RHS selected, **Calculate**.

\[
\begin{pmatrix}
\times \\
\gamma \\
z \\
w
\end{pmatrix} = \begin{pmatrix}
35 \\
8 \\
-128 \\
40 \\
53 \\
40 \\
9 \\
10 \\
\end{pmatrix} \quad \text{Expand} \quad \begin{pmatrix}
\times \\
\gamma \\
z \\
w
\end{pmatrix} = \begin{pmatrix}
4.375 \\
-3.075 \\
1.325 \\
0.9 \\
\end{pmatrix} \quad \text{Calculate}
\]

Indexing a Matrix

You use the Index Op to select a member of a matrix. If you name the matrix B, \( B_3 \) evaluates to the third row. \( B_{(2,3)} \) evaluates to the third element in the second row.

You can generalize with the following: \( B_{(row,column)} \).

• Input the matrix used in the example on determinants.

\[ B = \begin{pmatrix} 2 & 3 & 5 \\ 4 & 1 & 5 \\ 7 & 3 & 4 \end{pmatrix} \]

Press \( B_{(2,1)} \) or use the subscript button.

• Select the second Prop and **Calculate**.

Row and Column Entry

You can insert the Row/Column numbers into a matrix by **Selecting Out** and then **Selecting In**, and choosing **Notebook ► Row/Column Number**.... The example below demonstrates this feature by developing an identity matrix.

• Insert the **Row Index + offset** (upper left element starting with 1) on a 3 × 3 matrix.

\[
\begin{pmatrix}
??? \\
??? \\
??? \\
\end{pmatrix} \quad \text{Insert Row Index + Offset starting with 1}
\]

• Press the equal sign and insert the **Column Index + offset**.

• Complete by performing a **Calculate** on the whole matrix.

Matrix Transpose

You use the Adjoint Op to generate the transpose of a real matrix, the conjugate of
Preliminaries

a complex number, or the adjoint of a complex matrix.

Given the following real matrix, interchange its rows and columns.

- Enter the matrix using the method of your choice. Select and click on the Adjoint Palette image. Alternatively, you can assign the matrix a name (making sure to declare the name a M-Linear Operator).

\[
\begin{bmatrix}
1 & 2 & 3 & 4 \\
5 & 6 & 7 & 8 \\
9 & 10 & 11 & 12
\end{bmatrix}
\]

or

\[
A = \begin{bmatrix}
1 & 2 & 3 & 4 \\
5 & 6 & 7 & 8 \\
9 & 10 & 11 & 12
\end{bmatrix}
\]

- Select either the whole matrix in #1 or the identifier in #2. Perform a Calculate on both.

You can use an Expand on #1 and achieve the same result.

\[
\begin{bmatrix}
1 & 2 & 3 & 4 \\
5 & 6 & 7 & 8 \\
9 & 10 & 11 & 12
\end{bmatrix}^\dagger
\]

\[
\begin{bmatrix}
1 & 2 & 3 & 4 \\
5 & 6 & 7 & 8 \\
9 & 10 & 11 & 12
\end{bmatrix}^\dagger = \begin{bmatrix}
1 & 5 & 8 \\
2 & 6 & 10 \\
3 & 7 & 11 \\
4 & 8 & 12
\end{bmatrix}
\]

You can Substitute the matrix Prop in #2 into the name \(A\) and Expand the RHS to achieve the same result.

\[
\begin{bmatrix}
1 & 2 & 3 & 4 \\
5 & 6 & 7 & 8 \\
9 & 10 & 11 & 12
\end{bmatrix}
\]

\[
A^\dagger = \begin{bmatrix}
1 & 5 & 9 \\
2 & 6 & 10 \\
3 & 7 & 11 \\
4 & 8 & 12
\end{bmatrix}
\]

You calculate the Conjugate Transpose of a complex matrix by performing the same operation.

- Enter the following matrix and Calculate \(D^\dagger\).

\[
D = \begin{bmatrix}
i & 3 - i \\
2 + i & -1
\end{bmatrix}
\]

\[
D^\dagger
\]

\[
\begin{bmatrix}
-i & 2 - i \\
3 + i & -1
\end{bmatrix}
\]

You generate the conjugate of a complex number by applying the Adjoint Op directly to the number and performing either a Calculate or an Expand.

\[
(1 + 3i)^\dagger
\]

\[
(1 + 3i)^\dagger = 1 - 3i
\]
Functions

Function Notation 98
Linear Functions 102
Quadratic Functions 104
Polynomial Functions 107
Rational Functions 109
Exponents & Logarithms 113
Exponential & Logarithmic Functions 118
Trigonometric Functions 121
Scatter Plots & Data Analysis 126
Function Algebra & Composite Functions 130
Piecewise-Defined Functions 133
Functions of Two Variables 134
Parametrized Curves and Polar Coordinates 138
Solving Equations Graphically 142
Functions

Function Notation

Functions take three forms in *MathView*: explicitly defined, User Defined, and PreDefined. You choose the form, depending on the scope of your problem.

Explicit Functions

You create explicitly defined functions by typing or manipulating an equation into functional form. For example, to graph the equation below, you isolate the dependent variable from all independent variables. You do this by selecting the dependent variable *y* and choosing the *Isolate* command from the menu, clicking on the Palette icon, or by moving *y* with the hand to the Prop icon.

\[-2x = x^2 - y + 12\]
\[\triangle y = x^2 + 2x + 12\]

*MathView* also allows you to create custom “User Defined” functions. You input these functions with Wildcard variables (page 64).

User Defined Functions

You enter User Defined functions by using the function notation *f(x)*, where the independent variables are input as Wildcards. To input a variable as a Wildcard, choose the letter from the Wildcard palette or type a ? prior to typing the letter.

- Input: \[f(?x)=?x^2+3*?x-33\]

\[f(\xi) = \xi^2 + 3\xi - 33\]

The function *f* is now defined, but you cannot use it until you declare it as a function.

- Declare *f* at this time by choosing *Clarify* from the *Notebook* menu. The dialog box below will open. Choose *Function* under the Pop-up menu and click *User Defined*, or press the Return key (\(\text{Return}\))

*MathView* tries to guess the class of the name you choose. In this case, *MathView* guessed that you wanted *f* to be a function, therefore the dialog defaulted to *Function*.
To use the new function, input the equation \( y = f(x) \), this time without using Wildcard variables.

\[
\begin{align*}
\Box f(x) &= x^2 + 3x - 33 \\
y &= f(x)
\end{align*}
\]

Input a value for \( x \), substitute this equation into the \( y = f(x) \) equation, and **Calculate** the RHS for a value.

MathView has dynamically linked the two equations, now that you have defined the function and have made a substitution. Any change to the substitution equation or to the function itself now changes the Conclusion. To demonstrate, change \( x = 5 \) to \( x = 3 \), or change the function (the method below).

• **Change the function to the following.** Notice how MathView displays a hatching across the old conclusion as you change the function. This hatching symbolizes that you are changing the Theory.

Do not confuse the function \( f(x) \), which will show up on the Functions palette along with the other defined functions, with the large \( f(x) \) which toggles back and forth between the Functions and Variable palettes.

A nice feature of MathView is that you can collapse cascades, hiding intermediate steps. In the example to the right, select the final conclusion \((y=140)\) and **Notebook ▶ Indent Left** until it is all the way to the left. Now double-click on the \( y=f(x) \) Prop icon. You can now change the \( x=5 \) Prop and see the result without seeing the intermediate steps.

MathView has dynamically linked the two equations, now that you have defined the function and have made a substitution. Any change to the substitution equation or to the function itself now changes the Conclusion. To demonstrate, change \( x = 5 \) to \( x = 3 \), or change the function (the method below).

• **Change the function to the following.** Notice how MathView displays a hatching across the old conclusion as you change the function. This hatching symbolizes that you are changing the Theory.

You can enter the function by itself without the \( y= \), creating an expression rather than an equation. Select the expression and **Calculate**. Since you have defined the function before using it in this example, \( f(x) \) displays on the Functions palette, allowing you to click on its image to input the Assumption.

• **Input \( x \)** below the \( x = 5 \) Prop, select \( x \), and click \( f(x) \) on the palette.

You can use more than one independent variable to create an equation to plot three-dimensional objects or to study functions with several variables. You
Functions

separate the parameters of the function with a comma.

\[ g(x, y) = x^2 + y^2 \]
\[ z = g(x, y) \]

\[ z = g(2, 3) \] Substitute
\[ z = 13 \] Calculate

\[ x = 2 \]
\[ y = 3 \] Substitute into

PreDefined Functions

MathView has approximately 47 pre-defined functions and 16 pre-defined names, each with a behavior consistent with mathematical convention. The Function palette in the standard notebook contains 16 of these functions. Each is available at the click of the mouse.

You use a PreDefined function by merely typing its name in your notebook. MathView will ask you to declare it the first time you use it or when you Clarify the notebook. For example, MathView has a predefined numeric function that rounds a number to the nearest integer, called round. The following example initiates the Declare Name dialog box, asking you to declare round. MathView presumes that you want the function round, but allows you the option of declaring it a User Defined name. If you click on the default PreDefined button, the function will act as you would normally expect (see below). By using this function once in the Notebook, it will be available to you in subsequent manipulations and the name round will show up on the Function Palette.

\[ y = \text{round}(3.58) \]
\[ y = 4 \] Calculate

When you select the RHS and choose Calculate...
this dialog box appears.

You cannot use round to round a number if you have previously defined the name “round” as a User Defined variable. If you have done this by mistake, select the round definition nested inside the Declaration Prop (double-click on the first Prop in your notebook) and change the declaration. You do this by choosing the appropriate definitions under the Pop-up menus. Change Variable ▼ to Function ▼, and defined by user ▼ to Numeric Funcs ▶ Round to nearest integer ▼.
Function Notation

- **Function**: named values behave as defined by user.
- **Constant**
- **Variable**
- **M-Linear Operator**
- **O-Linear Operator**

<table>
<thead>
<tr>
<th>Defined by User</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constants</td>
</tr>
<tr>
<td>Numeric Funcs</td>
</tr>
<tr>
<td>Calculus Funcs</td>
</tr>
<tr>
<td>Trig Funcs</td>
</tr>
<tr>
<td>Hyperbolic Funcs</td>
</tr>
<tr>
<td>Polar Funcs</td>
</tr>
<tr>
<td>Matrix Funcs</td>
</tr>
<tr>
<td>Graph Bounds</td>
</tr>
<tr>
<td>Bessel Funcs</td>
</tr>
</tbody>
</table>

- **Round to nearest integer**
- Round down to integer
- Round up to integer
- Modulus
- Real part
- Imaginary part
Linear functions are normally the first functions you study but, as you well know, they become important components of more advanced subjects. An example is the linearization of curves. In this section, linear functions help introduce the dynamic aspect of Graph Theories, the indexing of variables, and how you can plot single points.

- Input the equation $y = 3x + 5$ in its own Prop.
- With the cursor located anywhere inside the function, select Linear under the Graph menu or click on the Palette image. MathView will assign a domain to the plot and adjust the Viewport according to its internal rules.

The standard Graph Theory Declarations and a Line Plot detail appear inside the graph details area. The important item to note here is that the detail denotes the line as, $\text{Line at (x,y)}$. Even though you have defined $y$ outside the Graph Theory, you can change the expression $3x + 5$ and the plot will adjust accordingly.

You can use MathView to study the effect on the slope and $y$-intercept by giving both variable names.

- Set up your Notebook in the following manner. To observe the effects of the slope and $y$-intercept on the function, change the values given to $m$ and $b$. 

Declare $m$ as a User Defined variable. $b$ is defined as a constant, by default.

Change $m$ and $b$. 
Linear Functions

Slope

Given two points, you define the slope "m" of the line containing both as

\[ m = \text{slope} = \frac{\text{rise}}{\text{run}} = \frac{y_2 - y_1}{x_2 - x_1}. \]

Below is a Theory where you calculate the slope of the equation given the points (2,3) and (5,8).

- Using subscripted variables, define each point as shown below. Select the RHS of the slope equation by clicking once on the fraction line, and Calculate to obtain the value for m.

\[ m = \frac{y_2 - y_1}{x_2 - x_1} \]

To determine the equation for the line containing these points, solve the general equation for a line in Point Slope form for y.

- Re-input the equation using only the first point. Substitute the values determined in the conclusions above \((x_1, y_1)\) and \(m\) into the line equation, and Isolate \(y\). Expand the RHS of the resulting equation for the answer.

\[ y = 1.6667(x - 2) + 3 \]

You can now plot this equation along with the given points.

- Select the last equation and generate a linear graph.
- Add two line plots and re-define their details as \((x_1, y_1)\) and \((x_2, y_2)\) respectively. Choose a different color and pick heavy. This will help make the points show up. You can change the values of the points in the first four Props (the subscripted variables) and watch the whole Theory change, including the graph.
Quadratic Functions

This section demonstrates four methods of solving quadratic functions: Factoring, Completing the Square, the Quadratic Formula, and Reading Roots off of a graph. Use the following equation for the examples in this section.

\[ 2x^2 + 8x = 6 \]

**Factoring**

- Place the equation into standard form. You do this by subtracting 6 from each side (adding a negative 6). Use the Hand to move the 6 over to the LHS (left hand side of the equation), or **Apply** (+ – 6) to each side.

  Using **Hand** to **Move Over**
  
  Using **Apply** to add (-6) to each side

\[
\begin{align*}
2x^2 + 8x & = 6 \\
2x^2 + 8x - 6 & = 0 \\
(2x^2 + 8x) + (-6) & = 6 + (-6) \\
2x^2 + 8x - 6 & = 0 \\
2x^2 + 8x & = 6 \\
\end{align*}
\]

- Select the LHS and **Factor**, using the method of your choice.

\[
\begin{align*}
2x^2 + 8x - 6 & = 0 \\
\left( x + \sqrt{7} + 2 \right) \left( x - \sqrt{7} + 2 \right) & = 0 \\
\end{align*}
\]

- One at a time, select the xs in the result above and **Isolate** for the answers (not shown).

**Completing the Square**

You can use the method of Completing the Square to solve the equation.

- Follow the instructions on the right.

\[
\begin{align*}
2x^2 + 8x & = 6 \\
\frac{2x^2 + 8x}{2} & = \frac{6}{2} \\
\frac{1}{2} \left( 2x^2 + 8x \right) & = 3 \\
x^2 + 4x & = 3
\end{align*}
\]
Quadratic Functions

• Using Apply a second time, add the square of one half the coefficient of \(x\) to both sides. Simplify the result and Factor the LHS.

\[
\triangle (x^2 + 4x + 2^2) = 3 + 2^2 \quad \text{Apply}
\]

\[
\triangle x^2 + 4x + 4 = 7 \quad \text{Simplify}
\]

\[
\triangle (x + 2)^2 = 7 \quad \text{Factor}
\]

• Apply the Square Root Op to each side and solve for \(x\) with Auto Casing turned on.

\[
\triangle (x + 2)^2 = 7 \quad \text{Factor}
\]

\[
\triangle \sqrt{(x + 2)^2} = \sqrt{7} \quad \text{Apply}
\]

\[
\triangle x = \frac{-b \pm \sqrt{b^2 - 4ac}}{2a}
\]

• Enter the coefficients of the given equation in their own Props.
• Substitute these into two Props set up with the Quadratic Formula.
• Expand for the answer.

\[
\square 2x^2 + 8x - 6 = 0
\]

Define coefficients in separate Props.

\[
\triangle x = \frac{11\sqrt{112} - 6}{4} \quad \text{Substitute}
\]

\[
\triangle x = \frac{11\sqrt{112} - 6}{4} \quad \text{Expand}
\]

\[
\triangle x = \frac{11\sqrt{112} - 6}{4} \quad \text{Substitute}
\]

\[
\triangle x = \frac{11\sqrt{112} - 6}{4} \quad \text{Expand}
\]

Reading Roots off of a Graph

Notice that MathView generates a new Assumption Prop. This result happens anytime you change a Conclusion. Editing an Assumption, on the other hand, does not generate a new Assumption.

You must plot the equation to use the built-in root finding facility. Since the given equation is not in functional form you must first manipulate it.

• Isolate the zero on the RHS and change to \(y\):

\[
\square 2x^2 + 0x - 6 = 0
\]

\[
\triangle y = 2x^2 + 8x - 6 \quad \text{Isolate}
\]

Select 0 and type \(y\):

New assumption generated.
Functions

- Place the cursor inside this new Assumption and generate a Linear Graph Theory. Adjust the Viewport by changing the details to the following.

\[ -9 \ldots 5.2 = \text{left..right} \quad \text{Stretch to Fit} \quad -26 \ldots 36 = \text{bottom..top} \quad \text{cropping} \quad \text{Moderately} \]

- You must zoom in on each x-intercept to find the roots. Use the knife to do the zoom on the positive crossing (see above).
- Make sure only one intercept is in view in the Graph Theory and choose **Find Graph Root** under the **Manipulate** menu. **MathView** displays the root in its own Case Theory just below the graph.

- Before performing any other manipulation, choose **Undo** under the **Edit** menu. You are now back to the graph’s original view.

Notice that the Case Theory remains intact and the root is in decimal form.

- Select the number and choose **UnCalculate** (found in **Other** under the **Manipulate** menu) or click on the Palette icon found in the small hammer sub-palette.

- Perform the same operation on the other root.

Note two items here. First, if there is more than one Graph Theory in the Notebook, you will need to select the graph first, so **MathView** will know which graph to use. Click on the icon in the upper left corner of the Graph (the whole graph will highlight).

Second, you must zoom in very close to the zero crossing to have **MathView** find the precise value, \( y = 0 \). Many times \( y \) will equal a very small number very close to zero. You can sometimes use **UnCalculate** to force \( y = 0 \).
Polynomial Functions

The multiple coefficients in polynomial functions reinforce the flexibility MathView provides by allowing you to control variables outside Graph Theories.

Set up a MathView notebook in the following manner to observe the effects of changing the coefficients of a polynomial function. Use the following third degree equation for this example.

- Define each coefficient as a separate variable in four separate Props (A, B, C, and D, respectively).
- Select all of the variables by clicking on their equal signs while holding down the Shift key.
- Substitute into the first Prop with the Hand.
- After MathView displays the conclusion, generate a linear Graph Theory using this equation. Make sure the cursor is somewhere inside the new conclusion Prop before you select Graph ➤ y=f(x) ➤ Linear.

Remember to press the space bar or type an * to denote a multiplication between the coefficients and the variables.

If you want, you can skip the substitution and merely select and graph the equation in the first Prop. This action generates the same plot, but uses different Working Statements.
Functions

You may have adjust the graph depending on the coefficients you choose.

- Change the values of each of the coefficients and observe the effects. Try setting every coefficient equal to zero, and change one value to observe what happens. Then, with this one variable set to a value which best shows its form, change each of the others to observe their effects on the plot.
- Below is the Theory showing the example you used in the previous section on Quadratic Functions. See page 104.

\[ y = Ax^3 + B \ x^2 + C \ x + D \]

\[ y = 2x^2 + 8x - 0 \]

Substitute

\[ A = 0 \]
\[ B = 2 \]
\[ C = 8 \]
\[ D = -6 \]

![Graph of a cubic function with coefficients set to zero.]

Teacher's Note

The example above is an excellent one to use to introduce Taylor Polynomials. In a lab setting with groups of two or three, have the students add the sine function to the Graph Theory. In addition, have them add two more terms to the general equation.

\[ y = Ax^5 + B \ x^4 + C \ x^3 + D \ x^2 + E \ x + F \]

Now, challenge them to change the coefficients so that the polynomial fits the sine curve.

Another good use for this method is to study the parabola using the general form,

\[ y = ax^2 + bx + c, \quad a \neq 0. \]

Using the discriminant \( b^2 - 4ac \), you can study the equations for the \( x \)-axis and the \( y \)-coordinate. In addition, you can use the general equation,

\[ y = a(x - h)^2 + k \]

Set up a new notebook using the general equation or use a case theory if more than one graph is in the notebook.

\[ y = a(x - h)^2 + k \]
\[ a = 1 \]
\[ h = 0 \]
\[ k = 0 \]

Plot \( y \) and change the parameters.

Lastly, you may want to set up a Graph Theory with the equation which generated the Plot hidden so you can direct students to “guess” the function. Make the equation a daughter Prop (page 33) of the graph that the equation generated. Then, double-click on the Graph icon to hide the equation, and choose Notebook ▶ Lock Proposition. This action locks the equation in a collapsed, hidden, state.

Now create a new equation with a different dependent variable and choose Graph ▶ Additional ▶ Add Line Plot. Ask your students to mirror the original plot by changing the RHS of this new equation.
Rational Functions

You write a Rational Function as a quotient of two polynomial functions.

\[ f(x) = \frac{g(x)}{h(x)}, \quad h(x) \neq 0 \]

Analyzing the various translations of rational functions provides an excellent opportunity to demonstrate the use of MathView's Case Theories. The example that follows will show you how to set up a Theory in which multiple graphs can use the same parameters to display more than one translation at a time.

You can find the asymptotes of rational functions easily by using MathView to factor or plot the denominator of the function. In the final subject in this section, you will use a similar method to decompose a complicated fraction into its parts.

**Rational Translations**

The very simple function \( y = f(x) = 1/x \) is the basis for the following rational function. Set up your notebook in the following manner. Choose Case Theory in the Insert sub-menu under Notebook to generate a Case Theory. The general equations you will use are

\[
y = \frac{C}{x^A + B} + D \quad \text{and} \quad y = \frac{C}{-x^A + B} + D
\]

- In side by side Case Theories, input the two equations.

- Outside of the Case Theories described above, define the User Defined variables, each in its own Prop. You can locate these Props above or below the Case Theories. They are outside of the Case Theories, so changes to their values will affect variables inside both Case Theories at the same time.

To move the second Case Theory from below, where it will originally display, to the right of the first one, select the Prop by clicking on the circle icon, and with the Hand, move to the right of the box outlining the Case Theory. For help, see page 33.

- Declare each a User Defined Variable.

- Select each of the two main equations and generate a Linear Graph Theory. Change the Viewport details of both graphs to the values shown below.

-11...11 = left...right  Stretch to Fit ⌁

-8...11 = bottom...top  cropping Moderately ⌁
Functions

You do not have to substitute the variables into the equations. The equations inside the Case Theories “look outside” to find values when plotted.

Your Notebook should now look like the following.

Change these values and observe changes in the Graph Theories.

You can animate the parameters in the example above (one at a time). Below is the left graph, from above, with $C$ selected and animated (with values from 0 to 10 at 1 frame per second). The screen shot below captured the fourth frame, in which $C = 3.0$.

You will find it easier to select a parameter inside one of the Case Theories to animate. MathView can only animate one graph at a time, and will choose the first graph in the notebook if you wish to animate the graph by selecting a variable in the list outside of the Case Theory.

Finding Asymptotes

Many times you can find the asymptotes of simple rational functions by inspection, but what happens when the function is complex?

$$y = \frac{-12x^3 - 18x^2 + 2784x + 8712}{x^5 - 105x^3 - 100x^2 + 2384x + 4320}$$

Use one of two MathView techniques to find asymptotes of more complicated rational functions. The first technique is to Factor the denominator and set each factor equal to zero. In the second, you pull out each expression, set it equal to $y$, and plot the equation. You then find the roots in the Graph Theory. The first technique is below.
Rational Functions

• Select the denominator by double-clicking on one of the operators ( + or – ). Choose Factor under the Manipulate menu, or click on the Palette icon for the answer.

\[ y = \frac{-12x^3 - 18x^2 + 2784x + 8712}{x^5 - 105x^3 - 100x^2 + 2364x + 4320} \text{ Select denominator} \]

\[ \Delta y = \frac{-12x^3 - 18x^2 + 2784x + 8712}{(x-9)(x+8)(x-6)(x+5)(x+2)} \text{ Factor} \]

The second technique requires you to create a new equation defining \( y \) equal to the denominator.

• Input the equation into a new Prop and plot. Zoom in on the five \( x \)-intercepts, as you did on page 106, to find the roots. Shown below is the plot along with the first root.

Partial Fractions

If the degree of the denominator of a rational polynomial function is greater than the degree of the numerator, and if you can factor the denominator into non-repeating linear factors, you can write the original fraction as the sum of simpler fractions. This technique is important when studying integration where the integrand is one of these functions. See page 177 for an example.

This operation is the reverse of finding a common denominator of several fractions that you add together. You can learn several methods by hand, but with MathView at your command, you can use the power of the computer to automate the procedure.

• Enter the same function you used in the prior example, select the denominator, and Factor.

\[ y = \frac{-12x^3 - 18x^2 + 2784x + 8712}{x^5 - 105x^3 - 100x^2 + 2364x + 4320} \]

\[ \Delta y = \frac{-12x^3 - 18x^2 + 2784x + 8712}{(x-9)(x+8)(x-6)(x+5)(x+2)} \text{ Factor} \]

• Select the RHS, by clicking on the fraction line, and Expand.

\[ \Delta y = \frac{-12x^3 - 18x^2 + 2784x + 8712}{(x-9)(x+8)(x-6)(x+5)(x+2)} \text{ Factor} \]

\[ \Delta y = \frac{3}{x-9} - \frac{2}{x+8} - \frac{8}{x-6} + \frac{3}{x+5} + \frac{2}{x+2} \text{ Expand} \]

You can also use a semi-manual method to demonstrate the mathematical concept.
Functions

- First input the following new expression and Factor the denominator.

\[
\frac{6x^2 + 6x - 6}{x^2 + 2x^2 - 5x - 6} = \frac{6x^2 + 6x - 6}{(x + 3)(x - 2)(x + 1)} \text{ Factor}
\]

- In a new Prop re-input as follows.

\[
\frac{6x^2 + 6x - 6}{(x + 3)(x - 2)(x + 1)} = \frac{A}{x + 3} + \frac{B}{x - 2} + \frac{C}{x + 1}
\]

- Manually take the denominator on the LHS times both sides (each term on RHS) and simplify the results.

\[
\frac{6x^2 + 6x - 6}{(x + 3)(x - 2)(x + 1)} = \frac{A(x + 3)(x - 2)(x + 1)}{x + 3} + \frac{B(x + 3)(x - 2)(x + 1)}{x - 2} + \frac{C(x + 3)(x - 2)(x + 1)}{x + 1}
\]

\[
\frac{6x^2 + 6x - 6}{(x + 3)(x - 2)(x + 1)} = \frac{A}{x + 3} + \frac{B}{x - 2} + \frac{C}{x + 1} \text{ Simplify}
\]

- Make a Prop giving a value to \( x \) so that one of the factors on the RHS goes to zero. Give \( x \) the value of \( -1 \) so both \( A \) and \( B \) will go to zero.

- Substitute and solve for the remaining variable (\( C \) in this case).

\[
\frac{6x^2 + 6x - 6}{(x + 3)(x - 2)(x + 1)} = \frac{A}{x + 3} + \frac{B}{x - 2} + \frac{C}{x + 1} \text{ Simplify}
\]

\[
\frac{6x^2 + 6x - 6}{(x + 3)(x - 2)(x + 1)} = \frac{-6C}{x + 3} \text{ Substitute}
\]

\[
x = -1
\]

- Copy the result to a new Prop and change \( x \) to make the other factors go to zero and solve for \( A \) and \( B \). Substitute these into the original equation for the answer (shown below).

\[
\frac{6x^2 + 6x - 6}{(x + 3)(x - 2)(x + 1)} = \frac{3}{x + 3} + \frac{2}{x - 2} + \frac{1}{x + 1}
\]

Teacher’s Note

The example above, along with others in this guide, is reverse engineered. \textit{MathView} makes this a very easy task and can help you create examples and test questions which serve your academic purposes.

Taking the first example under Partial Fractions, first enter the desired result.

\[
\frac{3}{x - 9} - \frac{2}{x + 8} - \frac{6}{x - 6} + \frac{3}{x + 5} + \frac{2}{x + 2}
\]

Select the whole expression and select the \textbf{Collect} manipulation. This creates a very large expression not shown here. Now \textbf{Expand} the numerator.

\[
\frac{-12x^3 - 18x^2 + 2784x + 8712}{(x - 9)(x + 8)(x - 6)(x + 5)(x + 2)} \text{ Expand}
\]

Finally, \textbf{Expand} the denominator to obtain the final result.

\[
\frac{-13x^3 - 18x^2 + 2784x + 8712}{x^5 - 105x^4 - 1100x^3 + 2334x + 4320} \text{ Expand}
\]
Before you can effectively use exponents and logarithms in MathView, you must become familiar with their input. You must also understand the effect that Auto Simplify and Auto Casing have on manipulations containing exponents.

In MathView, you enter superscripted indexes by using either the palette shortcut or by using the conventional ^ from the keyboard (−)). Complete by typing the exponent. To come out of the exponent back to the baseline, press .

With the judicious use of the Auto Simplify command, you can demonstrate the various properties of exponents. For example, to generate the factors of , you select the expression, turn off Auto Simplify, and perform a Collect.

To reverse the process, select the RHS of this new Prop and Simplify.

You toggle Auto Simplify on or off by selecting Auto Simplify in Manipulation Prefs, under the Manipulate menu.

Positive Integer Exponents

When \( n \) is a positive integer, \( b^n \) means that you have multiplied \( n \) factors of \( b \) together. You use this definition to find an equivalent form for an expression like

\[
(b^4)(b^6) = (b \cdot b \cdot b \cdot b) \cdot (b \cdot b \cdot b \cdot b \cdot b \cdot b) = b^{10}
\]

Generalizing this statement presents the first Property of Exponents:

\[
(b^m)(b^n) = b^{m+n}
\]

Table 2 below summarizes the Properties of Exponents using MathView. Noted on the right side of each manipulation is the state of Auto Simplify. A check mark indicates whether Auto Simplify is on or off. In some cases, the manipulation will work while MathView is in either state. For the following manipulations to work properly, declare each parameter a Constant.

Table 2: Properties of Exponents

<table>
<thead>
<tr>
<th>Property #, Selection, and Manipulation</th>
<th>Auto Simplify ON</th>
<th>Auto Simplify OFF</th>
</tr>
</thead>
<tbody>
<tr>
<td>#1 ( b^m b^n ) ( b^{m+n} \ Simplify )</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Property #, Selection, and Manipulation</td>
<td>Auto Simplify ON</td>
<td>Auto Simplify OFF</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>$b^{m+n}$</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>$a^m b^n$</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$b^{m-n}$</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>$(a b)^m$</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>$a^m b^m$</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>$(b^m)^n$</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>$b^n m$</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>$(a/b)^n$</td>
<td>✔</td>
<td>✔</td>
</tr>
</tbody>
</table>

Table 2: Properties of Exponents

- $b^{m+n} = b^m b^n$ Collect
- $b^{m-n} = b^m b^{-n}$ Collect
- $b^{m-n} = b^m \frac{1}{b^n}$ Simplify
- $b^0 = 1$ Simplify
- $(a b)^m = a^m b^m$ Expand
- $a^m b^m = (a b)^m$ Factor
- $(b^m)^n = b^{n m}$ Simplify
- $b^n m = (b^n)^m$ Collect
- $(a/b)^n = \frac{a^n}{b^n}$ Expand
Exponents & Logarithms

Negative Integer Exponents

When the exponent is a negative integer then \( b^{-n} = \frac{1}{b^n} \).

### Table 3: Negative Integer Exponents

<table>
<thead>
<tr>
<th>Property &amp; Manipulation</th>
<th>Auto Simplify ON</th>
<th>Auto Simplify OFF</th>
</tr>
</thead>
<tbody>
<tr>
<td>( b^{-n} )</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>( b^{-n} = \frac{1}{b^n} ) Simplify</td>
<td>✔</td>
<td>✔</td>
</tr>
</tbody>
</table>

Rational Number Exponents

What meaning does the symbol \( b^{1/2} \) have? By definition, it is the square root of the base \( b \). According to Property #5, the following holds true.

\[
(b^{1/2})^2 = b^{(1/2)(2)} = b^1 = b
\]

So \( b^{1/2} \) is a solution to \( x^2 = b \), which means that \( b^{1/2} = \sqrt{b} \). This expression, by convention, is the Principal Square Root.

### Table 4: Rational Number Exponents

<table>
<thead>
<tr>
<th>Property &amp; Manipulation</th>
<th>Auto Simplify ON</th>
<th>Auto Simplify OFF</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \left( \frac{1}{b^2} \right)^{1/2} )</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>( \left( b^{1/2} \right)^{1/2} = \frac{1}{b^{1/2}} ) Collect</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>( \left( b^{1/2} \right)^{1/2} = b ) Simplify</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>( b^{1/2} )</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>( b^{1/2} = \sqrt{b} ) Simplify</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>( \sqrt{b} )</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>( \sqrt{b} = b^{1/2} ) Expand</td>
<td>✔</td>
<td>✔</td>
</tr>
</tbody>
</table>

MathView does not have an \( a^{th} \) root operator, so \( b^{1/n} \) will not simplify to \( \sqrt[n]{b} \).
### Functions

**Scientific Notation**

Manipulating numbers in scientific notation requires you to be familiar with the definitions and properties of integral exponents. Although the symbolic capability of *MathView*, for the most part, eliminates the need to use this notation, it does allow you to input and manipulate numbers in scientific notation. You do this by controlling the notebook display precision. In addition, *MathView* displays some numbers in scientific notation regardless of the precision setting, particularly in Graph Theories when the labels become too large.

*MathView* gives you two methods of inputting numbers in scientific notation. The first method requires you to type the non-zero coefficient, e.g., $2.34$; to type * on the keyboard (or pressing the space bar); and then to type $10$ and its exponent (i.e., $7$), delimited with a ^.

$$2.34 \times 10^7$$

You may also click on the e on the Variables palette in the area containing the numbers 0 to 9.

An *Expand* will generate the number with all of its digits showing, regardless of the Display Precision setting (up to a maximum of 9 digits or the notebook setting, whichever is greater).

The second method is to type $2.34 \, e \, 7$. Notice that you do not need to create a superscript to input the exponent. *MathView* automatically generates the times sign ($\times$), the $10$, and an exponent place-holder.

You choose the display precision by selecting *Display Precision* under the Notebook menu. Since display precision is in the Notebook menu, it affects everything in the notebook. Thus you cannot choose to display one Prop in scientific notation and another in regular notation.

You do not effect the internally maintained precision by setting the display precision. *MathView* has a maximum display precision of 15 digits.

You can show the steps of simple arithmetic using scientific notation by turning *Auto Simplify* off. The example below demonstrates this concept by adding, multiplying, and dividing two numbers ($x$ and $y$), with *Auto Simplify* turned off.

| $x = 1.1111\times10^{10}$ | Substitute into Props below |
| $y = 2.2222\times10^{10}$ |
| $x + y$ |
| $\Delta x + y = 1.1111\times10^{10} + 2.2222\times10^{10}$ Substitute |
| $\Delta x + y = 3.3333\times10^{10}$ Simplify |
| $xy$ |
| $\Delta xy = 1.1111\times10^{10}\times2.2222\times10^{10}$ Substitute |
| $\Delta xy = 2.4899\times10^{20}$ Simplify |
| $\frac{x}{y}$ |
| $\Delta \frac{x}{y} = 1.1111\frac{10^{10}}{2.2222\times10^{10}}$ Substitute |
| $\Delta \frac{x}{y} = 0.5$ Simplify |

Display Precision set to 5

Auto Simplify OFF
Common Logarithms

The common logarithm, base 10, is a PreDefined Function in MathView. You enter it by typing \( \log(x) \) or by clicking on the palette image \( \log(x) \). You generate numeric answers with a Calculate manipulation.

Enter a number, select it, and click on the palette function \( \log(x) \).

\[
\begin{array}{c}
\text{Click on } \log(x) \quad \rightarrow \quad \log(25) \\
\text{or} \quad \text{Type } \log(25) \\
\log(25) \quad \rightarrow \quad 1.3979
\end{array}
\]

Logarithm to base \( b \)

You enter logs to other bases by using a subscript. Type \( \log \), an underscore (_), and the letter \( b \). Then press \( \text{Alt}+\left(\text{shift}\right)+\left(\text{left parentheses}\right) \) prior to entering the number. You can also type \( \log \) and click on the subscript icon on the palette.

\[
\begin{array}{c}
\log_{b}(7) \\
\log_{a}(b) \quad \rightarrow \quad \log_{a}(7)
\end{array}
\]

Natural Logarithm

You enter the logarithm to the base \( e \) (page 118) as a log to the base \( b \) where \( b = e \), or you input it by using the PreDefined function \( \ln(x) \).

\[
\begin{array}{c}
\ln(7) \\
\ln(7) \quad \rightarrow \quad 1.95
\end{array}
\]

Properties of Logarithms

You can generate the Properties of Logarithms symbolically by performing an Expand with Auto Simplify turned ON.

\[
\begin{array}{c}
\log_{b}(mn) = \log_{b}(m) + \log_{b}(n) \quad \text{Expand} \\
\log_{b}(\frac{m}{n}) = \log_{b}(m) - \log_{b}(n) \quad \text{Expand} \\
\log_{b}(m^{n}) = n \log_{b}(m) \quad \text{Expand}
\end{array}
\]

You evaluate logarithms by isolating the unknown variable. In the first example below, \( \text{Isolate} \) the exponent \( x \) with Auto Simplify turned off and Simplify the results. In the second example, first apply the log function to both sides. Expand the result, Isolate the variable, and Calculate the RHS.

<table>
<thead>
<tr>
<th>#1 Auto Simplify→Off</th>
<th>#2 Auto Simplify→On</th>
</tr>
</thead>
<tbody>
<tr>
<td>( 2^x = 8 )</td>
<td>( \log(2^x) = \log(8) ) Apply ( \log(2^x) = \log(8) ) Expand ( \log(2x) = \log(8) ) ( \frac{\log(2x)}{\log(2)} ) Isolate ( \frac{\log(8)}{\log(2)} ) ( \log(2) ) ( \frac{\log(8)}{\log(2)} ) ( \log(2x) = \log(8) ) ( \frac{\log(8)}{\log(2)} ) ( 2x = \log(8) ) ( \frac{\log(2x)}{\log(2)} ) Isolate ( x = 3 ) Calculate</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>#1 Auto Simplify→Off</th>
<th>#2 Auto Simplify→On</th>
</tr>
</thead>
<tbody>
<tr>
<td>( 2^x = 8 )</td>
<td>( \log(2^x) = \log(8) ) Apply ( \log(2^x) = \log(8) ) Expand ( \log(2x) = \log(8) ) ( \frac{\log(2x)}{\log(2)} ) Isolate ( \frac{\log(8)}{\log(2)} ) ( \log(2) ) ( \frac{\log(8)}{\log(2)} ) ( 2x = \log(8) ) ( \frac{\log(2x)}{\log(2)} ) Isolate ( x = 3 ) Calculate</td>
</tr>
</tbody>
</table>
Exponential & Logarithmic Functions

The exponential and logarithmic functions are very interesting functions to analyze because of their relationship to each other, their importance in the study of calculus, and their connection to the scientific study of growth and decay.

In this section, you will use the same method described in the sections on Rational and Polynomial functions to study the exponential function and its transformations. You will use both linear graphs and tables to analyze the irrational number $e$. Finally, you will create Parametric Graph Theories by plotting both the natural log and the natural exponential function in the same graph, thereby demonstrating their inverse relationship.

The Exponential Function and Its Transformations

In a New Notebook, or in a separate Case Theory, input the general exponential function $b^x$, expanded to show its transformations. Use capital letters for the transformation variables, so as to not conflict with any of MathView’s pre-defined variables. Choose a base of 2 and generate a Linear Graph Theory.

\[ y = A b^{x + C} - D \]

Change each parameter to observe its affect. Of particular interest is the comparison between $B$ between zero and one, and $B$ greater than one. Animate $B$ from 0 to 10 to see a very interesting process.

The Natural Exponential Function

A particularly important function in the study of higher mathematics is that of the natural exponential function. Based on the irrational number $e \approx 2.7182818\ldots$, this function is just the regular exponential function using $e$ as the base.

The following example shows you how plotting the function $y = (1 + 1/x)^x$ graphically displays a relationship which can help in the understanding of this important number.

- Input the function and generate a Linear Graph Theory. After the plot generates, notice that for values of $x$ approaching $\pm\infty$, the plot approaches the number $e$. 

118
Exponential & Logarithmic Functions

- Add to this graph a new line plot and change the $y$ to the constant $e$ in the detail. The new detail and the resulting graph follows.

  \[ y = \left(1 + \frac{1}{x}\right)^x \]

  You can approximate the value for $e$ by using this same function and MathView's Table generator.

- Select the RHS of the equation above and choose Table $\Rightarrow$ Generate... under the Manipulate menu. Set the range for $x$ from 0 to 10,000 and click OK. Open the table by clicking once on the Details icon and scroll to the end to see the value approach $e$.

  \[ y = \left(1 + \frac{1}{x}\right)^x \]

  The Logarithmic Function

  The inverse of the Exponential Function is the Logarithmic Function.

  - To demonstrate this, input either the Common Log base $b$, or the Natural Log function. Select the variable $x$ and Isolate. Replace the $x$ with a $y$ and the $y$ with an $x$.
Functions

You can plot both in the same Graph Theory to demonstrate this relationship.

- Plot the Natural Log function.
- Add a line plot and change its detail so that it equals the exponential function.
- Add a third line defined as \( y = x \). Use True Proportions.

\[ y = \ln(x) \]

Both of the examples on this page require you to add two line plots. You do this by selecting the graph in question and choosing Add Line Plot from the Graph Additional menu, twice. You add two line details with parameters identical to the original plot. Change these details to the functions listed. Both examples show the details open to guide you.

MathView has a Parametric graph which can also demonstrate this relationship. To create a Parametric plot, you must select two equations of the form \( x = f(t) \) and \( y = g(t) \) at the same time before you plot. You do this by selecting one equation (click once on the equal sign), holding down the Shift key, and clicking on the other. After you have selected both, choose Other \( \triangleright x=f(t), y=g(t) \) Parametric under the Graph menu. Define the axes as \( x \) and \( y \), and the parameter as \( t \).

You can demonstrate the inverse relationship of the two functions in the prior example by plotting \( x \) as a function of \( t \) in one Prop, and \( y \) as a function of \( t \) in the other. The resulting straight line verifies the inverse relationship.

- Input \( x = e^t \) and \( y = e^t \), select both equations, and plot. Add two line plots and define them as \( y = t \) in one and \( x = t \) in the other. These two additional plots are the Log and Exponential functions, respectively.
Trigonometric Functions

MathView uses Transformation Rules to implement trigonometric identities. In this section, you will learn how these rules work. You will also use the PreDefined functions, ToPolar and FromPolar, to create an interesting graph.

For this section, use MathView’s distributed notebook called “Trig Functions”. You can find it in the Transcendental Functions Folder located inside the Mathematics Folder which comes with the program CD. Alternatively, you can copy the Trigonometric Declarations out of that notebook and paste them into your working notebook. See page 29 for instruction.

PreDefined Trig Functions

MathView has twelve PreDefined trigonometric functions which include the six normal functions and the six inverse functions. In addition, MathView has twelve hyperbolic functions and six polar functions.

All of these PreDefined functions work in the normal manner of all MathView functions. You use them by either selecting an argument and clicking on the function palette image or by typing the function name, an open parenthesis, and the argument. You plot a trigonometric function by creating a functional equation and generating a linear Graph Theory.

You can analyze trigonometric transformations by setting up your notebook in the following manner using User Defined variables.

• Set up the notebook with a function in Sinusoidal form and add to the Theory the variables $A$, $B$, $C$, and $D$. You can change, or animate each variable to study its effects.

Degrees vs. Radians

You can define the six basic trigonometric functions by using the ratio of the sides of a right triangle. These relationships provide information about the associated acute angle. This angle is in degrees which, in most cases, you must translate into radians.

121
MathView uses radians to represent all angle measurement, so to analyze angles given in degrees, you must first translate degrees into radians. You can have MathView transform a number from degrees to radians by using the PreDefined Name, degrees. To invoke this name, you enter a number representing degrees and attach to it the degree symbol. You do this by typing the number then ‘o (or on the Macintosh, o or 8). Select the Prop and Calculate. The result is in radians. Below 45 degrees is translated into radians.

- Enter 45’o (this is o, not zero)
- Press the return key to accept the default, degrees, when the PreDefined Name declaration appears.
- Select and Calculate.

\[
\begin{align*}
\triangle 45^\circ & = 0.7854 \\
\end{align*}
\]

To demonstrate the difference between degree and radians when you use them in manipulations, compare the sine of 45° to the sine of π/4 radians.

\[
\begin{align*}
\triangle \sin(45^\circ) & = 0.70711 \\
\triangle \sin\left(\frac{\pi}{4}\right) & = 0.70711
\end{align*}
\]

Another way you can translate degrees into radians and also translate radians into degrees is to create two User Defined functions.

- Input the following User Defined functions. Remember, you must use Wildcard variables, and you must declare each name a function.

\[
\begin{align*}
\square \text{DegToRad}(\theta) & = \frac{\pi}{180} \\
\square \text{RadToDeg}(\varphi) & = \frac{180}{\pi}
\end{align*}
\]

The names given to these two functions are just suggestions. You may choose any name you want. However, descriptive names are best.

- To use the respective functions, click on their images in the Function palette where they will display after you declare them as functions.

\[
\begin{align*}
\triangle \text{DegToRad}(45) & = 0.7854 \\
\triangle \text{RadToDeg}(0.7854) & = 45
\end{align*}
\]

Trigonometric Identities

Because \(\cos(\theta)\) and \(\sin(\theta)\) are the x and y coordinates of a point on the unit circle, the following identity holds true.

\[
(\cos(\theta))^2 + (\sin(\theta))^2 = 1
\]
This relationship leads to several more algebraic identities which you can use to transform and simplify trigonometric equations. *MathView* has the basic trigonometric functions defined internally, but leaves the user flexibility by defining most trigonometric relationships as transformation rules.

The distributed *Trig Functions* notebook contains many of these, and allows you to define as many others as you want. The example below uses a rule found in the “New Notebook”. In this case, as in many others, you have more than one choice.

- Input and select the expression below. Choose *Transform* from the *Manipulate* menu, and click on one of the choices in the choice box.

\[
\sin \theta = \frac{\text{Opposite side}}{\text{Adjacent side}}
\]

\[
\cos \theta = \frac{\text{Adjacent side}}{\text{Hypotenuse}}
\]

\[
\tan \theta = \frac{\sin \theta}{\cos \theta}
\]

\[
\cot \theta = \frac{\cos \theta}{\sin \theta}
\]

\[
\sec \theta = \frac{1}{\cos \theta}
\]

\[
\csc \theta = \frac{1}{\sin \theta}
\]

**Polar vs. Rectangular Coordinates**

*MathView* uses the function *FromPolar* for polar plots, and will ask that you PreDefine it the first time you generate that type of plot.

You use two PreDefined functions, *FromPolar*(θ) and *ToPolar*(x), to translate polar into rectangular coordinates and rectangular into polar coordinates, respectively. *MathView* does not define these functions in a “New Notebook”, so the first time you try to use one, the program will ask you to define it.

- Input the following two Assumptions and calculate. Click on the PreDefined default button when asked to declare the functions. This will make them available for the present operation and all future manipulations in the notebook.
In similar fashion, three-vector conversion between rectangular and cylindrical coordinates \((r, \theta, z)\), and rectangular and spherical coordinates \((r, \theta, \phi)\), are available through the use of the \texttt{Cylindrical} and \texttt{Spherical} PreDefined functions.

**Dynamic Circle**

The next example uses the functions just discussed and demonstrates the tremendous flexibility of \textit{MathView}.

The goal of this example is to create a Graph Theory which plots a circle with its center at the origin. In addition, given a radius and an angle in degrees, have \textit{MathView} plot a line which represents the given ray. By changing the radius and angle, the circle and ray will re-draw with the new dimensions.

- In two Props enter the magnitude, \(m = 1\), and the angle, \(n = 45\) (in degrees), of the ray.
- Given a point on the circle \(p\) in polar coordinates with the angle in degrees, use the two functions discussed earlier to define the point. Define \(p\) as a \texttt{M-Linear Operator} (a matrix definition).

\[
\begin{align*}
\Box p &= \texttt{FromPolar}(m, \texttt{DegToRad}(n)) \\
\text{Select and } &\texttt{Calculate} \quad \triangle p = (0.70711, 0.70711) \quad \text{Calculate}
\end{align*}
\]

Since the angle is given in degrees, we need \texttt{DegToRad} \((n)\) to transform the angle into radians, a requirement of the \texttt{FromPolar} function. The resulting point \(p\) is now in rectangular coordinates.

- Select the RHS and \texttt{Calculate}.

\[
\begin{align*}
\Box m &= 1 \\
\Box n &= 45 \\
\Box p &= \texttt{FromPolar}(m, \texttt{DegToRad}(n)) \\
\text{Select RHS and } &\texttt{Calculate} \quad \triangle p = (0.70711, 0.70711) \quad \text{Calculate}
\end{align*}
\]

- Next you use a subscripted index to extract each coordinate from this last conclusion (you enter subscripts by typing the variable then an underline followed by the subscript).

\[
\begin{align*}
\Box \text{Select and } &\texttt{Calculate} \\
\Box p_{(1,1)} &= 0.70711 \quad \text{Calculate} \\
\Box p_{(1,2)} &= 0.70711 \quad \text{Select and } &\texttt{Calculate}
\end{align*}
\]

These two numbers define the point in \(x-y\) coordinates. You can now use them to define the ray by entering them into an equation for a line (Point Slope form).
• Input the equation for the line in a new Prop (see below); **Substitute** the points into the equation and **Isolate** \( y \).

\[
\begin{align*}
\Delta y - p(1, 2) &= \frac{p(4, 2)}{p(1, 1)} (x - p(1, 1)) \\
\Delta y - 0.7071 &= x - 0.70711 \\
\Delta y &= x - 1.1102 \times 10^{-16} \quad \text{Isolate line equation}
\end{align*}
\]

• Next, you create the Graph Theory which will plot this line along with the associated circle. Select the Prop containing the line equation above and choose **Linear** under the **Graph** menu.

• Add two line plots and define the first as the top half and the second as the bottom half of a circle. Make the circle dynamic (meaning that the plot re-draws the circle when you change the value of \( m \)) by changing the 1 in each equation to an \( m \).

• With the Knife or the Rocket Ship, adjust the Viewport to accommodate the plot of the circle, and set the details to **True Proportions**. You can now change the graph by giving new values to either \( m \) or \( n \).

You can generate this same graph by using an implicit plot (under **Other**)

\( f(x, y) = g(x, y) \) **Implicit**. Plot the circle \( x^2 + y^2 = m \) and add the line plot by selecting the Prop with the line equation and choosing **Add Line Plot**. You may have to increase the resolution of the plot to make a

---

**Declarations**

- Line at \((x, y)\) where \( x = \text{left...right} \) with a **normal** line, colored **Red**
- Line at \((x, \sqrt{-x^2 + m})\) where \( x = \text{left...right} \) with a **normal** line, colored **Black**
- Line at \((x, -\sqrt{-x^2 + m})\) where \( x = \text{left...right} \) with a **normal** line, colored **Black**
Scatter Plots & Data Analysis

- Entering and plotting Matrix values
- Log and Scatter plots
- Matrix indexing

The curve-fitting example which follows demonstrates how you enter and plot unequally spaced data points using MathView’s matrix operator and Scatter-plot Graph Theories. Using the same data, you will expand the scope of the problem, giving you experience generating a Log-Log plot.

MathView’s Table feature allows only equally spaced numbers for the x values (domain). You must create a matrix to plot a set of data points which have unequally spaced input values. In the next example you analyze a set of data by plotting the points in a scatter plot and then you determine an equation which fits that data.

- Inside a Case Theory, input the data in the D= Prop below by creating an equation with the RHS in the form of a matrix. You can enter it by typing
  \[ D = 1, .2893 ; 1.8, 5.6592 ; 2.6, 36.363 ; ... \]
  Notice how MathView automatically generates the parentheses and creates a new row after each semi-colon.

- The second method is to use the matrix palette button. Type \[ D = \] and select a two column matrix from the pop-up menu. Type the first number, a comma, and then a semi-colon. You can alternatively select a 4 row by 2 column matrix from the same pop-up palette. You would then tab through, typing the members until you get to the end of the fourth row. Type a semi-colon to add additional rows. The Prop should look like the following when complete.

\[ D = \begin{bmatrix}
1 & 0.2893 \\
1.8 & 5.6592 \\
2.6 & 36.363 \\
3.4 & 141.27 \\
5 & 993.96 \\
5.8 & 2106 \\
6 & 2500
\end{bmatrix} \]

- Clarify the notebook and declare \( D \) a M-Linear Operator (M means matrix).
- Select the equation, by clicking on the equal sign, and generate a scatter plot by choosing Scatter ▶ Linear under the Graph menu. Adjust the Graph Theory to look similar to the following.

See page 88 for further instructions on how to enter matrices.
The plot looks like it has the shape of an exponential curve. To verify that the curve is exponential, you need to determine whether a linear relationship exists between the log of the $x$s and the log of the $y$s. You can verify this relationship in one of two ways.

- First is to plot the data in a log-log plot by selecting the equation and choosing **Log-Log** under **Scatter** in the **Graph** menu. Since you have already generated one plot in the notebook, copy the equation and paste it into a new Prop. Select the Prop and create a Case Theory to keep this Theory separate from the other one. Select the equation again and generate the Log-Log plot.

The second method requires you to explicitly take the logarithms of the data.

- Copy the matrix equation again and Paste into a third Case Theory. Select the RHS by dragging the mouse through the data and perform a **Select In** (click on the palette icon or choose **Edit** > **Select In**).
- Apply the Natural Log function by clicking on the image of **ln(x)** on the functions palette.
- Select the RHS again and hold down the **Command** and **Shift** keys (Mac) or the **Ctrl** and **Shift** keys (Win), while you **Calculate**. This performs a calculation in place. Select the equation and generate a new linear scatter plot.

Below, and on the next page, are the steps and the resulting plot.
You can see that an exponential model will fit the data because both of the plots above show a linear relationship. To verify, you must determine the equation for the linear fit.

- Create the following equation for the slope of that line inside the third Case Theory.

\[
\begin{align*}
\text{Slope of the line.} & \quad \text{Calculate} \\
\triangle \gamma_2 & = \frac{D(7,0) - D(1,2)}{D(7,1) - D(1,0)} \\
\triangle \gamma_2 & = 5.0588
\end{align*}
\]

The reason you declare \( D \) an **M-Linear Operator** now becomes apparent. To determine the slope, you must extract the values of two points. You extract these values by indexing the matrix as shown above. Use the first and last points for this operation.

- Input an equation for a line using one of the points (use the 7th point) to determine \( b \) (y-intercept). Substitute \( m \) into this equation and **Isolate** \( b \).

\[
\begin{align*}
7.824 = \gamma_2(1.7918) + b \\
\triangle 7.824 = b + 9.0343 & \quad \text{Substitute} \\
\triangle b = -1.2403 & \quad \text{Isolate}
\end{align*}
\]

- Create another equation for a line, in general form, and substitute \( m \) and \( b \) into it. **Isolate** \( y \).

- Select the Graph Theory and choose Add Line Plot from the Graph Additional menu.

This plot verifies that the In model is linear.
You determine the equation that will fit the original data by using the values of $m$ and $b$ as an exponential function of $x$.

- In Case Theory #1, re-input the equations for $m$ and $b$ directly beneath the existing graph.
- Input the equation $\ln(y) = m\ln(x) + b$.
- Substitute $m$ and $b$ into this equation.
- Isolate $y$.
- Collect the RHS with Auto Simplify OFF and Calculate.

Add a line plot to the graph by selecting the last $y$ Prop and choosing Add Line Plot under Graph Additional menu. The graph will look like the following with the line fitting the data.
Functions

**Function Algebra & Composite Functions**

- Using Wildcard Variables to manipulate functions
- Turning off Auto Simplify to show steps

You can automate the combining of functions by using functions entered in Wildcard form. Once you have entered them in Wildcard form, you perform simple mathematical manipulations with them.

**Sums and Differences**

Recall, to enter a Wildcard variable, type a ? just prior to typing the letter (x in this case), or choose x from the Pop-up menu.

- Enter the following two functions in two separate Props using Wildcard variables for the independent variable.

\[
\begin{align*}
  f(x) &= \sqrt{x} + \sin(x) \\
  g(x) &= \frac{1}{x}
\end{align*}
\]

- In a third and forth Prop, enter an addition and subtraction of the functions. This time do not use Wildcard variables.

\[
\begin{align*}
  f(x) + g(x) \\
  f(x) - g(x)
\end{align*}
\]

- Select both functions by clicking on their equal signs while holding down the shift key. Substitute into each of the Props above. Turn Auto Simplify off so you can see the steps that MathView takes to solve these operations. Select the RHS of the results and Expand.

Select these two equations and Substitute into #1 and #2 below.

\[
\begin{align*}
  f(x) + g(x) &= \frac{1}{x} + \frac{1}{x} \\
  f(x) - g(x) &= -\frac{1}{x} - \frac{1}{x}
\end{align*}
\]

**Multiplication and Division**

You use the same method to multiply and divide functions. Use the same two functions for this example.
Function Algebra & Composite Functions

- Enter two new Props defining the multiplication and the division of the functions.
- Substitute the functions into the second and third Props shown below.

\[
\begin{align*}
\Box f(x) &= \sqrt{x} + \sin(x) \\
g(x) &= \frac{1}{x} \\
f(x)g(x) \\
\Delta f(x)g(x) &= \frac{\sin(x) + \sqrt{x}}{x^2} & \text{Substitute} \\
\Delta f(x)g(x) &= \frac{1}{3} \sin(x) + \frac{1}{3} \sqrt{x} & \text{Expanded}
\end{align*}
\]

\[
\begin{align*}
\Box \frac{f(x)}{g(x)} \\
\Delta \frac{f(x)}{g(x)} &= \frac{1}{3} \sin(x) + \frac{1}{3} \sqrt{x} & \text{Substitute} \\
\Delta \frac{f(x)}{g(x)} &= \frac{1}{3} \sin(x) + \frac{1}{3} \sqrt{x} & \text{Expanded}
\end{align*}
\]

Composite Functions

Composite functions play an important role in higher mathematics. Of particular interest is their use in differential calculus when studying the chain rule and in integral calculus when studying the substitution rule.

Not only can MathView help you solve these problems, it can help you visualize the results graphically. The example below uses two simple functions to show how; by looking at the graph of the two functions, and the composite, you can determine the domain of the resulting function.

- Input the two functions below along with the composite \( g(f(x)) \).

\[
\begin{align*}
\Box f(x) &= \sqrt{x} - 2 \\
g(x) &= \frac{1}{x} \\
g(f(x)) \\
\Delta g(f(x)) &= \sqrt{f(x)} & \text{Substitute} \\
\Delta g(f(x)) &= \sqrt{x^2 - 2} & \text{Substitute}
\end{align*}
\]

You must first substitute \( g(x) \) then \( f(x) \) into that result to obtain the final result.

- Create three equations defining the two initial functions and the composite function. Use different dependent variables so you can plot all three in the same Graph Theory. You can use prime notation (see below), you can index the dependent variables, or you can use entirely different User Defined variables. You merely need to distinguish the three equations for the Graph Theory to work.
Functions

- Select the first Prop above and generate a linear Graph Theory by choosing $y = f(x)$ \textbf{Linear} under the Graph menu.

- In order, select each of the other equations by clicking somewhere inside its Prop, and choose Add Line Plot under the Graph \textbf{Additional} menu. Declare each new variable User Defined.

After some adjustment, the Graph Theory will look something like the following (the composite function is the heavy line).

The plot shows that the domain of $g$ is all positive numbers, but the domain of the composite is $g(f(x)) = (-\infty, -\sqrt{2}] \cup [\sqrt{2}, \infty)$. 

Piecewise-Defined Functions

You enter piecewise-defined functions by using the Conditional Op.

- Input the following function by typing $y = \text{Conditional}$. (To input the relations, start by creating a two column matrix (click on the palette image for this). Tab through the matrix to input the expressions below.

You can also enter the Conditional Op by clicking on the palette image. This inputs a two-relation Op which you can then tab through to place your inputs.

- To add a third row, type a semi-colon at the end of the second row.

$$y = \begin{cases} ? & (x < 0) \\ ? & (x \geq 0) \end{cases} \quad y = \begin{cases} x^4 & (x \leq 0) \\ |x| & (x \leq 4) \\ -x + 8 & (x > 4) \end{cases}$$

- Select the equation by clicking on the equal sign and generate a Linear Graph Theory.

A second method works as well, but takes somewhat longer to input.

- Delete the last example and input the first conditional equation $y = x^4$ in its own Prop. Plot it by generating a linear graph. Add two line plots and redefine their details as follows. *MathView* generates the same plot.

```
Declarations
\cdot Line [x,y] where x = left ... 0 with a \text{normal} \ line, \ colored
  \text{Black} \n\cdot Line [x, x^4] where x = 0 ... 4 with a \text{normal} \ line, \ colored
  \text{Red} \n\cdot Line [x, -x + 8] where x = 4 ... right with a \text{normal} \ line, \ colored
  \text{Blue} \n```

Use these bounds.

\[ -2.6 \ldots 10.8 = \text{left..right} \quad \begin{array}{c} \text{Stretch to Fit} \Rightarrow \\ \text{cropping} \quad \text{Moderately} \Rightarrow \end{array} \]
Functions of Two Variables

With the exception of time, we live in a three-dimensional world. You can use functions of two variables to mathematically describe this world and MathView has the tools you need. The process of describing these functions and manipulating them is very similar to the two-dimensional functions introduced earlier.

You can enter functions of two variables in explicit form or as User Defined functions. Use the following function for the next example.

\[ z = \frac{xy(x^2 - y^2)}{x^2 + y^2} \]

- Enter the equation in explicit form and as a User Defined function in separate Props. In a third Prop, enter \( z = f(x, y) \).

Target Prop #1

\[ \square z = \frac{xy(x^2 - y^2)}{x^2 + y^2} \]

\[ \square f(x, y) = \frac{xy(x^2 - y^2)}{x^2 + y^2} \]

Target Prop #2

\[ \square z = f(x, y) \]

\[ \square x = 3 \]

\[ \square y = 2 \]

- Add two Props defining values for \( x \) and \( y \) (see above). Substitute \( x \) and \( y \) into each of the two target Props by clicking on their equal signs while holding down the Shift key. With the Hand move to the target Props #1 and #2.

The first substitution generates \( z \) in fractional form. The second leaves \( z \) as a function.

- Calculate the RHS of each result for a decimal answer. In #2, you could also Substitute the function (Wildcard form) into the \( z = f(3, 2) \) Prop. This method gives the same intermediate fraction as in #1. Calculate that result for the decimal answer.

#1

\[ \square z = \frac{xy(x^2 - y^2)}{x^2 + y^2} \]

\[ \triangle z = \frac{38}{13} \text{ Substitute} \]

\[ \triangle z = 2.3077 \text{ Calculate} \]

#2

\[ \square f(x, y) = \frac{xy(x^2 - y^2)}{x^2 + y^2} \]

\[ \triangle z = f(x, y) \]

\[ \triangle z = f(3, 2) \text{ Substitute} \]

\[ \triangle z = 2.3077 \text{ Calculate} \]
Color and Illuminated 3-D Plots

The difference between Illum. 3D and Color 3D graphs is merely the color and lighting. Illum. 3D graphs will appear to be illuminated by a light source over your left shoulder.

Examples of graphs which plot more than one variable in two dimensions are topographical and weather maps. The Graph Theory below shows an interesting variation on the last example by generating the contours associated with the 3-D graph.

To generate a contour plot by itself, select the z equation and choose Graph ▶ z=f(x,y) ▶ Contour 2D.

You may want to remove the grid-lines in the contour plot so you can see the contours better. Open the graph details, select the gridline detail inside the Declarations, and press .
You can plot a surface of intersection by adding a second plot and describing it as a plane. This method can help you visualize partial derivatives.

- In a new notebook, enter the following equation and generate a 3-D graph. The choice of colors and detail is up to you.

\[ z = \sin(x) + \cos(y^2) \]

- To create the plane, select with blank slots under the Graph ▶ Additional menu. This selection will place a check mark to the left of with blank slots.

- Add a Surface Plot by choosing Graph ▶ Additional ▶ Add Surface Plot. Since you have with blank slots turned on, the added surface plot will have its parameters blank.

- Change \((?, ?, ?)\) to \((2, y, z)\) and change the two ranges to \(y=\text{south...north}\) and \(z=\text{bottom...top}\). The number 2 was chosen for the location of the plane, but you can choose any number as long as it is within the range of the Viewport.

The resulting Graph Theory looks like the following after you add more points by clicking on the mesh icon.

The curve of intersection of the two surfaces graphically shows the partial derivative function with respect to \(x\). You can also graphically study the partial derivative function with respect to \(y\).
Functions of Two Variables

- Generate two new equations defining the points, \( x = 2 \) and \( y = 0 \). Surround each in a Case Theory.

\[
\begin{align*}
\Delta z &= \sin(x) + \cos(y^2) \\
\Delta x &= 2 \\
\Delta y &= 0
\end{align*}
\]

Substitute each into

- Substitute the \( x \) and \( y \) Props into the \( z \) function (see above) to generate the derived conclusions.

\[
\begin{align*}
\Delta z &= \sin(x) + \cos(y^2) \\
\Delta x &= 2 \\
\Delta y &= 0 \\
\Delta z &= \sin(x) + 1
\end{align*}
\]

Select each function and generate both a 3-D and a Linear Plot.

- Select each function and generate a 3-D plot. Select the functions again and generate a Linear plot. Move them side by side, to fit on the page, like this.

Make sure you choose the correct variables for your graphs when the dialog appears.

137
Parametrized Curves and Polar Coordinates

- Plotting and animating Parametric plots
- Plotting and animating Space curves
- Plotting and animating Polar plots

You can describe and visualize the motion of particles using parametric plots. Using polar coordinates for some relations can add simplicity and insight which is difficult using cartesian coordinates. MathView allows you to do both, using two powerful graphing facilities.

**Parametric Plots**

You can graph circles in MathView by using a Linear Graph Theory, \( \text{Graph} \uparrow \text{y} = f(x) \uparrow \text{Linear} \), where you plot the two equations defining the halves of the given circle in the same Theory. You can also use the Implicit Graph Theory, \( \text{Graph} \uparrow \text{Other} \uparrow f(x,y) = g(x,y) \text{ Implicit} \), where you plot the circle using one equation.

When you want to describe the location of a particle on a circle given the central angle, a better method to use is the Parametric Graph Theory, \( \text{Graph} \uparrow \text{Other} \uparrow x = f(t), y = g(t) \text{ Parametric} \). The example below plots a circle with a radius of one using this method.

- Enter the two equations below. Select both, by clicking on their equal signs while holding down the shift key, and choose the Parametric Graph Theory under the \( \text{Graph} \uparrow \text{Other} \) menu. Declare \( t \) as a variable and, to better show the plot, change the domain of \( t \) from \( -3 \ldots 3 \) to \( 0 \ldots 2\pi \) and the Viewport to True Proportions.

You can obtain additional insight by animating a Parametric plot.
In a new notebook, or inside a Case Theory within the notebook you just used, enter the equations for a cycloid. Select both equations and plot using the same method used in the prior example. The parameter \( a \) defines the location of the center of the circle above the \( x \)-axis. Enter \( a \) equal to 1 in a third Prop. Change the domain to \( t = 0...40 \).

\[
\begin{align*}
  x &= at - a \sin(t) \\
  y &= a - a \cos(t) \\
  a &= 1
\end{align*}
\]

By keeping the proportions Stretch to Fit as you animate, you can observe a very interesting animation.

- Add two equations \( m = 0 \) and \( n = 40 \) right beneath the \( a = 1 \) Prop. Open the graph details and change the domain to \( t = m...n \). Choose the \( n = 40 \) equation and animate (Graph ▶ Animation ▶ Start). The default animation range is short, so change it to \( n = 0...40 \) after you have stopped the animation.
- Restart the animation.

Animate on \( n \).

Change \( n \).

Change \( t \).
Functions

Space Curves
You can expand the previous example to show how MathView plots Space Curves. You do this by adding a third equation which defines the third dimension.

- In a new Prop inside a Case Theory or in a new notebook, input the same equations found in the last example. Add the equation \( z = t \). Select all three equations and choose **Graph ▶ Other ▶ x = f(t), y = g(t), z = h(t). Space Curve.** Accept the default graph variables or change to match the equation variables and click **OK**. Change the details to match the ones below.

- An interesting addition to this graph is to animate on the \( a \) variable. Select the \( a = 2 \) Prop and **Animate**.

MathView automatically declares the **Topolar** function when you ask it to graph Polar Plots. The following example again shows the interesting and powerful animation feature of MathView.

- Enter the equations below and change the values of \( A, B, \) and \( C \) (declare each variable User Defined).

For this plot, define the \( x \)-axis as \( r \) and the \( y \)-axis as \( \theta \).
• Select the $B = 6$ Prop and **Animate**. Change the animation details to generate even increments of the variable from 2 to 22. The screen shot below caught the animation at $B = 10$.

- $r = A^C \sin(B \theta)$
- $A = 3$
- $B = 6$
- $C = 1$

**Saving an Animation (Mac only)**

If you are using the Macintosh version of MathView, you can save any animation you create by choosing **Save**... under **Animation** in the **Graph** menu.

- Click on the animation to be saved and choose **Graph** ➤ **Animation** ➤ **Save**... The program will go through the animation one time, saving each frame to a file.
- When all frames have been saved, a dialog box will open where you can name the animation and save it to a file of your choice. Name the animation Polar Animation and click on the **Save** button or press the Return/Enter key.

The file placed on your disk is a QuickTime file which you can then use in various programs compatible with QuickTime. If you do not have QuickTime installed on your machine, saved animations use the PICT format. The images saved are bitmapped images with the same “depth” (number of bits per pixel) as your computer screen. If you are using more than one monitor, the screen with the deepest pixel depth determines the depth of the saved images.
Functions

Solving Equations Graphically

- Solving simultaneous equations using a Linear Graph Theory
- Solving simultaneous equations using Implicit Plots

MathView provides you several ways to solve equations. In the section on Matrices (page 88) you solved a simple system of equations using algebraic manipulation, and you solved a more complicated system of equations using matrices. In this section you will learn how to use MathView’s Graph Theories to solve equations.

Given the following two equations, solve for \( x \) and \( y \).

- In two separate Props enter the following two equations.
  
  \[
  \begin{align*}
  x + \sin(x) + y &= 3 \\
  y &= \sin(x) + 2 
  \end{align*}
  \]

  The first method to solve two equations graphically is to create a single equation by substitution.

  - Substitute the second equation into the first.
    
    \[
    \begin{align*}
    x + \sin(x) + \sin(x) + 2 &= 3 \\
    \Rightarrow 2\sin(x) + x + 2 &= 3 \\
    \Rightarrow 0 &= -2\sin(x) - x + 1
    \end{align*}
    \]

  - Move the LHS over to the RHS.
    
    \[
    \begin{align*}
    2\sin(x) + x + 2 &= 3 \\
    \Rightarrow 0 &= -2\sin(x) - x + 1 \\
    \Rightarrow 0 &= -2\sin(x) - x + 1
    \end{align*}
    \]

  - Select the zero in this new Conclusion and type a \( z \).
    
    \[
    z = -2\sin(x) - x + 1
    \]

  - Plot this function in a Linear Graph Theory, zoom in on the root and select Find Graph Root under the Manipulate menu.

Remember that if you have two expressions equivalent to \( y \), then the two expressions are equal to each other.

Assign the value \( z \) to this new equation so that MathView knows what to graph.

\[\begin{align*}
  z &= -2\sin(x) - x + 1 \\
  x &= 0.33758 \\
  x &= 0
\end{align*}\]
Solving Equations Graphically

All you need do now is **Substitute** the x Prop into one of the original equations and solve for y.

A second method uses *MathView’s* Implicit Plot facility. This facility is specifically designed for two equations and two variables. In fact, you must use this method when expressing an equation explicitly is impossible.

- Enter both equations, select the first, and generate an Implicit Plot by choosing `f(x,y)=g(x,y) Implicit` under the **Graph ▶ Other** menu. Increase the resolution and adjust the Viewport to look something like the following.

- Select the second equation and choose **Add Implicit Plot** from the **Graph ▶ Additional** menu.

- Zoom in on the plot where the curves cross and choose **Find Graph Root** under the **Manipulate** menu to obtain a numerical solution.
Differential Calculus

Limits 146
Slope of a Curve 151
Derivatives of Functions with One Variable 156
Higher Order Derivatives 161
Implicit Differentiation 163
Derivatives of Functions with more than one Variable 165
Limits

You can use MathView to solve limits using algebraic manipulation, table generation, and Graph Theories. The first two methods shown in this section are conventional in their approach. The third shows you how to creatively use Graph Theories to study this sometimes difficult subject.

Limits by 
Algebraic Manipulation

You can find the limits of all polynomials and most rational functions using substitution. In other words, the following holds true.

\[
\lim_{{x \to c}} f(x) = f(c) \quad \text{and} \quad \lim_{{x \to c}} g(x) = g(c),
\]

Then

\[
\lim_{{x \to c}} \frac{f(x)}{g(x)} = \frac{f(c)}{g(c)} \quad \text{for} \quad g(c) \neq 0.
\]

However, even when \( g(c) = 0 \), the limit of a rational expression may exist.

Finding the limit of the following function as \( x \to 2 \) poses a problem. At first look, it seems as though the limit is undefined. The limit does exist however, and you find it by factoring the expression and simplifying.

- Input the expression as an equation of \( y \) along with a second Prop defining \( x = 2 \). Substituting \( x \) into the \( y \) Prop gives an undefined value, as indicated by the ?.

- **Factor** both the numerator and the denominator and **Simplify** the result.
- **Complete** the operation by substituting \( x \) into this new result.

When you choose **Factor**, a warning may appear stating that the manipulation may take a long time. Ignore this warning by pressing the Return key.
You can also use the table generator to analyze this limit. In the next example, you
generate two tables. The first takes \( x \) values approaching from the left and the
second takes \( x \) values approaching from the right.

### Studying Limits with Tables

- Enter the expression in a new Prop, select, and generate a table defining the
domain of \( x \) as 1..2. Accept the other defaults by clicking **OK** or by pressing

  ![Graph]

  **Tabulate \( x \) with**

  ![Graph]

  **Tabulate \( f(x) \) with**

  ![Graph]

  **Bottom of Table #2**

<table>
<thead>
<tr>
<th>( x )</th>
<th>( f(x) )</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.0076</td>
<td>0.60377</td>
</tr>
<tr>
<td>2.0315</td>
<td>0.602527</td>
</tr>
<tr>
<td>2.0159</td>
<td>0.60127</td>
</tr>
<tr>
<td>2</td>
<td>0.6</td>
</tr>
</tbody>
</table>

### A Graphical look at \( \delta-\varepsilon \)

You can use a Graph Theory to explore the formal definition of a limit. Below, as
review, is the conventional definition.

\[
\lim_{{x \to a}} f(x) = L \text{ exists if and only if,}
\]

\[
given any \ \varepsilon > 0, \ there is a \ \delta > 0 \ such that \ |f(x) - L| < \varepsilon
\]

\[
\text{whenever} \ \ 0 < |x - a| < \delta.
\]

Given a point \( a \to f(a) \), \( \delta \) is the amount of input error accepted given an output
error of \( \varepsilon \). If this relationship holds, then a limit exists and is equal to \( L \).

Think of it this way. Given a positive output error \( \varepsilon \), what value of the input error \( \delta \)
gives an output that is within \( f(a) \pm \varepsilon \)?

![Graph]

147
Differential Calculus

The ability to control the Viewport of Graph Theories allows you to determine the value for which \( \delta \) produces output values \( f(\delta) \) that are within \( L + \epsilon \) and \( L - \epsilon \). You do this by adjusting the value of \( \delta \) and keeping \( \epsilon \) constant so the plot makes a diagonal within the graph bounds. With the values obtained from this procedure, you can find a relationship between \( \delta \) and \( \epsilon \) which closely approximates the one achieved when using traditional methods.

- Use a New Notebook. Enter, in functional form with Wildcards (page 64), the sine function. In separate Props below the function, enter values for the desired output tolerance \( \epsilon \) and a guess for the input tolerance \( \delta \). Define both as User Defined variables, when asked.

\[
\begin{align*}
\Box f(x) &= \sin(x) \\
\Box \epsilon &= 0.1 \\
\Box \delta &= 0.2
\end{align*}
\]

- Below these Props, input the point \( a \) defining the desired \( x \) value.

\[
\Box a = \frac{\pi}{\delta}
\]

Although not necessary for the plot, you may want to determine \( f(a) \) by entering it in a separate Prop and performing a Calculate.

- Finally, generate the plot by inputting \( y = f(x) \) and choosing Linear from the Graph menu. The following graphic shows the input thus far without the plot.

Before the graph can help determine the correct values, you must place the Viewport details in a form representing the limits of the tolerance values.

- Open the Viewport by clicking on the Graph details icon and change the ranges to the values below.

\[
\begin{align*}
\text{Add a small amount to } a \\
\text{so MathView can generate the plot where } x \text{ may be at a discontinuity, or where the limit possibly does not exist. In most cases, a small amount added to } a \text{ will not affect the results.}
\end{align*}
\]
Limits

- Below is the resulting Graph Theory.

\[
f(a) + \varepsilon \quad \text{Stays Constant}
\]

\[
f(a) - \varepsilon \quad \text{Changes}
\]

If the graph icons are in the way of the upper right corner, add one axis to the right and the other to the top of the graph. Change the cropping to Moderately Wide.

- Keep \( \varepsilon \) constant at 0.1 and change \( \delta \) until the line in the plot creates a diagonal within the Viewport.

The value given to \( \delta \) to create a diagonal represents the maximum \( \delta \) can be to have an output within the limits defined by \( \varepsilon \). The following plot suggests an approximate maximum value of 0.107.

\[
\begin{align*}
\text{Plot using this equation: } f(a) + \varepsilon & \quad f(a) - \varepsilon \quad f(a) + \varepsilon - \varepsilon - \delta + \delta & \quad \text{Stays Constant} \\
\text{The value of } \delta \text{ which makes the line a diagonal within the graph viewport: } a - \delta & \quad a + \delta \quad \text{Changes}
\end{align*}
\]

To find the relationship between \( \delta \) and \( \varepsilon \), set up a Prop creating a direct relationship.

- Substitute \( \varepsilon \) and \( \delta \) into this new Prop.
- Isolate \( r \) (declare \( r \) a User Defined variable).
- Substitute the \( r = 1.07 \) equation back into the first Prop (see below) to give the relationship.

\[
\begin{align*}
\text{Substitute } \delta \text{ and } \varepsilon \text{ from above into this Prop.} \\
\text{Substitute this equation back into the first Prop.}
\end{align*}
\]
Differential Calculus

• Substituting $r$ back into the first Prop gives the relationship between $\delta$ and $\varepsilon$.

\[ \delta = 1.07 \varepsilon \quad \text{Substitute} \]

• Below is the whole Theory.

\[ \text{Declarations} \]
\[ f(a) = \sin(a) \]
\[ \varepsilon = 0.1 \]
\[ s = 0.107 \]
\[ a = \frac{\pi}{6} \]
\[ y = f(x) \]

\[ \delta = r \varepsilon \quad \text{Substitute} \]
\[ 0.107 = 0.1r \quad \text{Substitute} \]
\[ r = 1.07 \]
\[ \delta = 1.07 \varepsilon \quad \text{Substitute} \]

Teacher's Note

You can add line plots, defining the limits, to the Graph Theory. As different values are input, the lines act as the bounds, rather than the Viewport. The Theory below shows an example.
Slope of a Curve

The derivative of a function is inexorably linked to the concept of the slope of a curve at a given point. An efficient way to study this concept is to use Graph Theories. This section demonstrates how to zoom in on a curve to approximate slope; how to add a line plot to a Graph Theory to represent a secant to a given function; and how to make tangent lines using function notation. Finally, you are introduced to the Taylor Series manipulation by using the feature to generate the same tangent line.

Zooming in on Curves

A change in \( y \) (the outputs), divided by the associated change in \( x \) (the inputs), determines the slope of a straight line. A problem occurs, however, when you try this method with curves. For any change in \( x \), the associated change in \( y \) determines the average change, or the slope of the secant line, between the two points.

By taking smaller and smaller changes in \( x \), this value approaches the true slope of the curve. Zooming in on a curve is a graphical way you can display this concept. After you zoom in on a plot several times, the curve will look more and more like that of a straight line and you can calculate an approximation to the actual slope of the curve at a given point.

- Input the following function and zoom by using the Knife, using the Rocket (hold down the Option or Alt key while clicking on the Rocket), or opening the details and changing the Viewport. These details are shown below each of the following graphs. The chosen point is \( x = 1.2 \). The first graph shows the curve as \( MathView \) initially generates it. The second, and subsequent graphs, show various zooms.
Differential Calculus

Although the line does not intersect a gridline exactly, you can approximate the plot’s slope by using the $x$ values of 1.19995 and 1.20005 in the last graph. The change in the associated $y$ values divided by the differences in the $x$ values gives a slope of .30. This number is pretty close to the actual slope of .31302.

You can also use the Viewport to determine the slope. Zoom in to a view where the line makes a diagonal in the Viewport. Then use the Viewport boundary values to perform the calculations. This calculation leads to a slope of .3166...

Change the precision to 8 by choosing
Notebook ➤
Display Precision ➤
8 digits.

Secant Lines

In the last example, you determined the slope of the secant line by connecting two points near a target point. In the next example, you will add a secant line to the plot of a function using the difference quotient $[f(x + h) - f(x)]/h$. In addition, by using MathView’s animation feature, you will turn that secant line into a tangent line.

- In a New Notebook, input the function $y = x^4$. Generate a Linear plot and press $\text{from}$. This places you in a Prop between the function and its graph. Input the equation for the secant in Point-slope form using subscripted variables.

\[
\text{Difference Quotient } m
\]

\[
\square \text{secant} = \frac{(x_1 + h)^4 - x_1^4}{h} - 1(x - x_1) + y_1
\]

- Input a value of 2 for $x_1$ and define $y_1$ to be $x_1^4$. This input allows you to change $x_1$ without having to determine $y_1$ for any given point. Finally, create a Prop defining $h = 5$. Declare all new names User Defined when requested by MathView.
- Select the secant Prop and choose Graph ➤ Additional ➤ Add Line Plot. The notebook will now look like the following.
Slope of a Curve

In the next example, you will use function notation to plot a tangent line at a point \( a \) on the Sine curve. When you change the value of \( a \), the tangent will move to different points on the curve.

- In a New Notebook, or in a Case Theory within an existing notebook, input the sine function using Wildcard variables. Plot this function using a new Prop where \( y = f(x) \). Declare \( f \) as a function.
- After the plot generates, hit the Return key. Enter the equation for the tangent, using function notation. See the \( y' \) Prop below.
- Create two additional Props defining \( a = 1 \) and \( h = 0.001 \). Select the Prop defining the tangent line and Add Line Plot, making sure to choose the correct

Tangent Lines

You may want to try the method described here for the Secant Line example above.
Differential Calculus

x and y axis variables (x and y'). The Theory will look like the following, after declaring all variables User Defined.

By zooming out and animating \( \alpha \), watch the line traverse the sine wave like a skier going over the bumps on a ski slope.

Using the same function, the next example demonstrates MathView’s Taylor Series. The tangent line is, after all, just a Taylor polynomial of degree one.

- Input the sine function in a new Prop within a Case Theory, or in a New Notebook. Do not use Wildcard variables this time. Select the function and generate a Linear Graph Theory.

- Select the RHS (right hand side of the equation) and choose Manipulate » Other » Taylor Series. The following dialog box will open.

Since you want to have the ability to move the tangent line, choose an expansion variable.

- Toggle on the variable button by clicking on it, and choose \( a \) in the scrollable box on the right. Change the Highest order term to 1 and click OK, or press \( \text{[OK]} \). MathView generates a new equation with the RHS (right hand side of the equation) in the form of a Taylor series.

- Press \( \text{[OK]} \) again and input a Prop giving \( \alpha \) the value of 1.

Rename the equation at this time. This action allows you to plot the Taylor
equation in the same Graph Theory without conflicting with the other plot (the existing plot already uses $y$ as the dependent variable).

- Select the $y$ in the Taylor equation and type $y'$. MathView generates a new Assumption just below the Taylor equation. Select this new equation and choose Graph ▶ Additional ▶ Add Line Plot. A Graph Theory exactly like the one in the last example appears.

- Change the value of $a$ to move the line. You can also animate this graph by choosing $a$ as the animation variable.

The Taylor series does not look very much like a polynomial at this point because you have not substituted the expansion variable into the equation yet. To see the series in polynomial form, substitute $a=1$ into the equation, Expand, and then Calculate the RHS; or since you have given $a$ a value in the Theory, just select the RHS, Expand, and Calculate.
Derivatives of Functions with One Variable

You can find derivatives of functions with one variable using two different methods in MathView. The preferred method is to use the Partial Derivative Op. A second method is to use the PreDefined Differential Operator, \( d \). Before the discussion on these operators, you will explore the link between the Difference Quotient and the derivative, giving you another look at how you can use functions in MathView.

Solving the Difference Quotient

In the next example, you algebraically solve the difference quotient using the simple function \( f(x) = x^2 \). The solution, in turn, gives the derivative of the function.

- Input the function using Wildcard variables.
- In a second Prop, input the difference quotient using regular variables.
- Select the function and substitute it into the difference quotient Prop. After you declare the function \( f \), MathView performs the operation.
- Select the RHS of the resulting equation and Expand twice.
- Since you are interested in the limit of this function as \( h \to 0 \), create a Prop defining \( h = 0 \) and substitute \( h \) into the RHS of the last equation for the answer.

Using the Partial Derivative Op

For most of your work with derivatives, use the Partial Derivative Op. MathView often requires you to declare an Independence Declaration when performing partial differentiation. Therefore, as long as you do not declare an Independence Declaration, you can use the Op to take regular derivatives. See page 165 for instruction on Partial Derivatives.
You have several methods of entering the Partial Derivative Op. The first method is to click on the Palette image, which inserts the Op at your insertion point, or in a new Prop if you have no selection. Question mark place-holders await the input of the parameters.

- Click on the palette image of the Derivative Op.
- Type the expression delimited with a parenthesis and press \(\texttt{Tab} \) to input the independent variable. Once you have entered the expression, select and \texttt{Simplify} to obtain a symbolic answer. Below is an example.

\[
\frac{\partial}{\partial x}(x^4 + 3x^3 - 4x + 79) = 4x^3 + 9x^2 - 4
\]

The second method involves entering the expression, selecting it, and clicking on the Palette image of the Op. Tab to input the independent variable.

The third method involves typing the command line:

\[
\texttt{Diff}(x) \cdot (x^4 + 3x^3 - 4x + 79)
\]

A more dynamic way of working with derivatives is to create a function \(y\) and substitute it into the derivative Op.

- Input the function and the Derivative Op using \(y\) as the dependent variable and \(x\) as the independent variable.

\[
y = x^4 + 3x^3 - 4x + 79
\]

- Select the equation by clicking on its equal sign and, with the hand, move it to the Derivative Op. Let go.

You can now change the original function and \texttt{MathView} will automatically generate the derivative for the new function.
Differential Calculus

**Numeric Derivatives**

All you do to generate the numeric derivative of an expression at a point is to give the independent variable a value.

- To the example above, add a Prop giving \( x \) the value of 3. Select the derivative expression and perform a **Calculate**.

\[
\frac{d}{dx} (x^4 + 3x^3 - 4x + 78) = 185
\]

\( x = 3 \)

A problem may occur if you do not place the \( x = 3 \) Prop in its own Case Theory. Since you have given \( x \) a value, all subsequent derivatives will automatically result in a numerical answer. Using a Case Theory solves this problem.

- Create a Case Theory and enter \( x = 3 \). Substitute this equation into the Derivative Op located outside of the Case Theory. The answer displays inside the Case Theory and the value you gave to \( x \) will not affect any other derivatives.

**Using the Differential Operator \( d \)**

You can also use the PreDefined differential operator \( d \) to find derivatives.

- Using the same function as above, enter the derivative using the differential operator \( d \), rather than the Partial Derivative Op. \( / d \times y \)

- Substitute the function into the derivative for the answer. The resulting expression includes \( dx \) terms, which will cancel when you perform an **Expand** on the RHS.

**Rules of Differentiation**

You can explore the rules of differentiation by using substitution variables or constants, as the case requires, to represent the inner functions and powers that make up a function.
For example, to explore the Power Rule, input the following two Props and perform the substitution. Notice that the derivative is of the function $y$ with respect to $x$.

You explore the Negative Power Rule and Constant Power Rule in like fashion. Use a variable in place of the inner functions to demonstrate several other rules of differentiation.

Below is the Sum Rule. Enter the first five Props shown below and perform the first substitution. Turn off Auto Simplify to have MathView show all of its steps.

You must declare the index $n$ a constant.

Make sure you declare $u$ and $v$ as variables.
Differential Calculus

You can display the Product and Quotient rules in similar fashion. The screen-shot below only shows the manipulations on the substitution variables.

**Product Rule**

\[ y = uv \]

\[ \frac{d}{dx}y = \frac{d}{dx}(uv) \]

Substitute

\[ \frac{d}{dx}y = v \frac{d}{dx}u + u \frac{d}{dx}v \]

Simplify

**Quotient Rule**

\[ y = \frac{u}{v} \]

\[ \frac{d}{dx}y = \frac{d}{dx}\left(\frac{u}{v}\right) \]

Substitute

\[ \frac{d}{dx}y = \frac{v \frac{d}{dx}u - u \frac{d}{dx}v}{v^2} \]

Simplify

- Use the next two examples to demonstrate the chain rule. Remember to declare \( n \) as a constant.

**Chain Rule**

\[ y = u^n \]

\[ \frac{d}{dx}y = \frac{d}{dx}u^n \]

Substitute

\[ \frac{d}{dx}y = n u^{n-1} \frac{d}{dx}u \]

Simplify

\[ y = \sin(u) \]

\[ \frac{d}{dx}y = \frac{d}{dx}\sin(u) \]

Substitute

\[ \frac{d}{dx}y = \cos(u) \frac{d}{dx}u \]

Simplify

Turn off **Auto Simplify** for this manipulation. The example will then show the intermediate step.
Higher Order Derivatives

Not only are higher-order derivatives easy to input and solve, the dynamic aspect of MathView allows you to change initial functions and witness immediate changes to a Graph Theory containing their plots.

In the following example, you find the first and second derivatives of a function. You then plot all three in the same Graph Theory. By varying the initial function, you can watch all three plots change in the Graph Theory.

• Using the Partial Derivative Op, you enter the second derivative in the following manner. Click on the Palette image of the Op twice, type y, press \( \frac{\partial}{\partial x} \), type an x, press \( \frac{\partial}{\partial x} \) again, and type another x.

\[
\frac{\partial}{\partial x} \left( \frac{\partial}{\partial x} y \right)
\]

You can also enter a second derivative as an exponent.

• Enter a single Partial Derivative Op in a new Prop and select it without the y, by clicking once on its fraction bar.
• Click on the Superscript Palette icon or press \( \text{alt} - 6 \).
• Complete the input by typing the index number.

\[
\frac{\partial}{\partial x} y \\
\frac{\partial}{\partial x} y \\
\left( \frac{\partial}{\partial x} y \right)^2 \\
\left( \frac{\partial}{\partial x} y \right)^2
\]

To verify that this input is in fact taking the derivative of a derivative, select and \textbf{Expand}. Try using this technique with even higher order derivatives.

• Input the function and the first derivative.
• Follow by inputting the second derivative in the third Prop.
• Complete by selecting the function and \textbf{Substituting} it into each Derivative Op.

\[
y = x^3 - 2x^2 + 11x + 12
\]

\[
\frac{\partial}{\partial x} y \\
\left( \frac{\partial}{\partial x} y \right)^2
\]
You will have to **Expand** the RHS of the intermediate answer of the second substitution to complete the operation.

\[
\begin{align*}
\Delta y &= x^3 - 2x^2 - 11x + 12 \\
\frac{\partial}{\partial x} y &= 3x^2 - 4x - 11 \quad \text{Substitute} \\
\left(\frac{\partial}{\partial x} y\right)^2 &= \left(3x^2 - 4x - 11\right)^2 \quad \text{Substitute} \\
\Delta \left(\frac{\partial}{\partial x} y\right)^2 &= 3x - 4 \quad \text{Expand}
\end{align*}
\]

You plot these functions by selecting the original equation, generating a Linear Graph Theory, and adding two line plots. Define the first additional plot as the first derivative and the second as the second derivative.

- Select the original function and generate a Linear Graph Theory.
- Add two line plots and open the details.
- Select the \( y \) in the second line detail. Click on the Derivative Op on the Palette and type an \( x \). The Graph Theory will redraw with the derivative function, along with the original function.
- Select the \( y \) in the third line detail and click on the Derivative Op.
- Type an \( x \) and then select the whole derivative, including the \( y \), and click on the Derivative Op again.
- Complete the operation by typing another \( x \).

You can now change the original function and the affects of that change will ripple through the theory, redrawing all three plots.

Zoom out once.
Implicit Differentiation

In this section, you learn to use the **Apply** manipulation to help differentiate implicit functions. In addition, you are introduced to the **Implicit** Graph Theory and learn how to add a line plot to one of these plots.

- Enter an equation for a circle. Select the equation and choose **Manipulate** ▶ **Apply**. Click on the Derivative Op palette image and type an $x$. The apply will give you two ? placeholders awaiting an input. The Theory will look like the following.

  \[ x^2 + y^2 = 25 \]

  Select Eq and **Apply** $x$.

  \[ \frac{\partial}{\partial x}(x^2 + y^2) = \frac{\partial}{\partial x}25 \]

- Select the equation again and **Simplify**, to perform the differentiation.
- Select the Derivative Op and **Isolate** for the answer.

\[ \frac{\partial}{\partial x}y = \frac{x}{y} \]

**Implicit Graphs**

- You plot an implicit equation by selecting the equation (click once on its equal sign) and choosing the implicit graph menu item, **Graph ▶ Other ▶ f(x,y) = g(x,y) Implicit**. Choose $x$ as the $x$-axis and $y$ as the $y$-axis.
- You may have to zoom out once or twice to have the circle display in the Viewport. Use **True Proportions** for this plot.

Clicking the more resolution icon will make a smoother circle.
Implicit plots are merely normal Graph Theories that have zero-contour plots as their plot detail; therefore, you may add line plots.

The screen-shot below displays all of the steps in this example.

Use the point where \( x = 3 \).

- Select the first Prop from the previous example and press \( \text{prop} \). Enter \( x = 3 \). Substitute this equation into the original Prop and \textbf{Isolate} \( y \) (in the figure below, \#1 gives \#2).
- Substitute the \( x \) and \( y \) Props into the RHS of the derivative equation. This gives a slope of \(-3/4 \) (\#3).
- Input an equation for a line into its own Prop below the \( x = 3 \) Prop, with the point you determined above as its inputs (\#4).
- Isolate \( y \) in this equation. Add a line plot to the Graph Theory by choosing \textbf{Graph} \( \text{Add} \text{Line} \text{Plot} \). The screen-shot below displays the whole theory.

\[
\begin{align*}
x^2 + y^2 &= 25 \\
\frac{2}{dx}(x^2 + y^2) &= \frac{2}{dx}25 & \text{Apply} \\
2x + 2y \frac{dy}{dx} &= 0 & \text{Simplify} \\
\frac{dy}{dx} &= -\frac{x}{y} & \text{Isolate} & \#3 & \text{Both} x \text{and} y \text{substituted here.} \\
\frac{2}{dx}y &= \frac{-3}{y} & \text{Substitute} \\
y^2 + 9 &= 25 & \text{Substitute} \\
y &= 4 & \text{Isolate} & \#2 & \text{Gives the} y \text{value.} \\
x &= 3 & \text{Isolate} & \#1 & \text{Chosen} x \text{substituted into} \\
y - 4 &= -\frac{3}{4}(x - 3) & \text{Eq for line with} x \text{&} y \text{as point.} \\
y &= -\frac{3}{4}(x - 3) + 4 & \text{Isolate} \\
\end{align*}
\]

Notice that the \( y \) in the added line plot does not conflict with the \( y \) in the contour plot.
Derivatives of Functions with more than one Variable

In “Traces and Partial Derivative Functions” on page 136, you generated a graph of a function with more than one variable along with a plane intersecting that function. The plane made a curve of intersection with the three-dimensional plot called a trace. This trace represented the partial derivative with respect to the independent variable. In this section you will learn how to use MathView to algebraically find the derivatives of functions with more than one variable.

The point of tangency of a 3-D object is a plane. In the final example in this section you will learn how to generate this plane in a 3-D Graph Theory.

You use the Partial Derivative Op, along with an Independence Declaration, to perform partial differentiation in MathView.

Partial Derivatives

Use the following function for the next example.

\[ z = f(x, y) = -x^2 - y^2 \]

- Create a Case Theory by choosing Notebook ➤ Insert ➤ Case Theory.

To solve partial derivatives in MathView, you must declare your variables independent of each other. If you put an independence declaration at the root of the notebook (outside of all Case Theories), it will affect all subsequent manipulations, including those inside Case Theories. When placed inside its own Case Theory, the declaration will only apply to operations inside that Case Theory and any Case Theories inside of it. It will not affect manipulations outside of its own Case Theory.

- Input an Independence Declaration by choosing Notebook ➤ Insert ➤ Independence Decl.. Declare x and y independent by typing their names separated by a comma, at the location of the ?.

- Input the function and two Derivative Ops, the first with respect to x and the second with respect to y. Your notebook will look like the following.

\[ \frac{\partial z}{\partial x} \quad \text{and} \quad \frac{\partial z}{\partial y} \]
Differential Calculus

To find the numerical derivative at a point is a simple matter of giving \( x \) and \( y \) values and substituting them into the two new functions just generated.

- **Substitute** the function into the derivatives to obtain the answers.

\[
\frac{\partial}{\partial x} z = -2x \\
\frac{\partial}{\partial y} z = -2y
\]

The point of tangency of a 3-D object is a plane. The next example plots the graph of the function just used and adds a tangent plane. You can then dynamically move this plane to any point on the surface of that function.

- In a new Case Theory, input the function using Wildcard variables and enter a \( z = f(x, y) \) Prop.
- Substitute the function into the \( z \) Prop and take the Partial Derivatives. The Theory will look like the following. Do not forget the Independence Declaration, and make sure to declare \( f \) a function when requested.

\[
\frac{\partial}{\partial x} z = -x^2 - y^2 \\
\frac{\partial}{\partial y} z = -2x \\
\frac{\partial}{\partial y} z = -2y
\]

- Input the point of tangency at \((1,0)\) by entering two Props defining \( x \) and \( y \) (still inside the Case Theory).
- Input four Props: \( z_0 = z; x_0 = x; y_0 = y; \) and \( z_0 \) (by itself).
- Substitute the \( z \)-Prop (Conclusion), above, into the RHS of the \( z_0 = z \) Prop.

\[
z = -x^2 - y^2
\]

- Substitute the \( x = 1 \) and \( y = 0 \) Props into the resulting equation. This manipulation links the function to the plane.
Derivatives of Functions with more than one Variable

- Substitute \( x = 1 \) into the RHS of the \( x_0 = x \) Prop and \( y = 0 \) into the RHS of the \( y_0 = y \) Prop.
- Finally substitute the \( z_0 = -1 \) Conclusion into the \( z_0 \) Prop.

Below is the equation for a plane.

\[
\partial^2 z = \frac{\partial^2 f(x, y)}{\partial x^2} (x-x_0)^2 + \frac{\partial^2 f(x, y)}{\partial y^2} (y-y_0)^2 + z_0
\]

You do not use the equation above in this example, however, because the partials in the Theory are in terms of \( x_0 \) and \( y_0 \), which are constants at this time.

- You must manually input the following equation below the \( z_0 \) Prop. Declare \( z' \) as a User Defined variable when requested.

\[
z' = (-2x_0)(x-x_0) + (-2y_0)(y-y_0) + z_0
\]

- Substitute the values for \( x_0 \), \( y_0 \) and \( z_0 \) in to this Prop. The resulting equation becomes the equation for the tangent plane at the point \((1,0)\).

- Generate the Graph Theory by selecting the original function, the \( z = f(x, y) \) Prop, and choose Graph \( \triangleright z=f(x,y) \triangleright Color\ 3D \).
Differential Calculus

You use this method of adding the second plot because MathView needs two independent variables to add a Surface Plot, which this equation does not have. You can trick the program by adding a plot with the same definition as the first plot and then changing the detail.

Alternatively you can toggle on Additional ➤ with blank slots under the Graph menu. Then select the \( z' \) Prop and choose Add Surface Plot. This action adds a blank Surface Plot detail which you then fill in with the details shown to the right.

To change the location of the tangent plane, merely change the values of \( x \) and \( y \) and the Graph Theory will redraw with the plane at that new point.
Integral Calculus

Integration 170
Definite Integration 178
Integral Calculus

Integration

- Definite and indefinite Integral Op
- Constants of integration
- Integration tables
- Techniques of integration

MathView does not load large libraries of integral formulas in its basic notebook, although you can configure it that way. Each “New Notebook” has a small set, in the form of Transformation Rules, which should serve most of your needs. If you are an engineer or scientist who needs more power, it is a simple matter to add rules of your own, or to copy rules from the many “Distribution” notebooks which came with your program.

Not only does MathView have the capability of solving many integrals with a simple manipulation, it also allows you to systematically demonstrate how to derive these rules. In this section, you will learn how to enter, set up, and solve integrals using these methods.

Integral Input

You have three ways to input indefinite integrals.

- The first is to click on the palette image, which produces the integral sign, a ? where the integrand should be, the differential, and another ?. After clicking on the image, MathView highlights the integrand placeholder. Type the integrand and \( d \) to enter the variable of integration in the differential.

- The second method is the Command key equivalent. Type a dollar sign (\$). This method does not generate a differential operator (\( d ? \)), which is sometimes helpful when solving differential equations. Differential equations already have a differential in them. You will not duplicate the operator using this method.

- The third method to enter the indefinite integral is the Command-line method. You enter the integral above by typing \( \text{Integral(sin(x)*d*x)} \).

Although not very efficient for entering expressions, this method is important because the expression is in the form used to send an integral to a colleague in an e-mail message. You do not have to type it into your message, however, just Copy (regular copy, not copy as picture) any integral or, for that matter, any expression from your notebook and Paste into the message. Your colleague would then copy the integral from the message and paste directly to his or her notebook.
You input definite integrals in a similar manner. See the following.

- Click on the palette image to produce an integral with upper and lower limits. To complete the input: type the integrand, \[ \int \]; type the independent variable, \[ \text{d}x \]; type the lower bound, \[ 0 \]; type the upper bound.

- The second method is to use the Command key equivalent -j (Mac) or -j (Win). This action duplicates the palette input.

- You can input by Command-line, by typing the following

\[
\text{Integral}(\sin(x) \times \text{d}x) : (0) : (\pi)
\]

Constant of Integration

Turn on Auto Casing, under the Manipulate \( \Rightarrow \) Manipulation Prefs menu, to generate a constant of integration. The default label is the User Defined constant \( c \). MathView subscripts constants with a number which, by default, starts at 100 (so they are not as likely to duplicate one of your subscripted variables). Every time you perform an operation that generates a constant, the subscript of this new constant increases by one.

- Input the following integral, select, and Simplify.

\[
\int \sin(x) \, dx
\]

You can change the label and the starting number of the subscript by choosing Manipulate \( \Rightarrow \) Manipulation Prefs \( \Rightarrow \) Arbitrary Constants. The following dialog box opens, where you can choose a different label and a different starting number for the subscript.

You generate constants of integration for definite integrals by turning Auto Simplify off and Auto Casing on before a manipulation. This action also initiates the Fundamental Theorem of Calculus. See page 181.
Integral Calculus

Simple Integration

You have several ways to have MathView perform the integration once you have entered an integral. The first is to **Simplify**. The example above demonstrated this method. Remember, you must select the integral before you can manipulate it. Either select the leading Prop icon, which selects the whole proposition, or click on the integral sign, which selects the integral alone.

Select by clicking on the Prop icon.

\[ \int \sin(x) \, dx \]

Select by clicking on the integral sign.

\[ \int \sin(x) \, dx \]

There is an important difference here: clicking on the integral sign is a quick way of selecting just the integral expression rather than the whole expression or whole equation. This selection method comes in handy when you want to select only the integral out of a larger expression or equation.

In many cases, a **Simplify** manipulation will produce an answer, as in the example above. Times will occur, however, when the integral is more complicated, or in a form that you need to change first. Use an **Expand** in these cases. In some cases, **Collect** performs the integration. The best thing to do is to start with **Simplify**, and if it does not work, try the others.

- Enter the following integral and try a **Simplify** then try an **Expand**.

\[ \int (x^2 + x) x^2 \, dx \]

**Simplify** 

\[ \int (x^2 + x) x^2 \, dx \]

**Expand**

\[ \int (x^2 + x) x^2 \, dx = \frac{1}{5} x^5 + \frac{1}{4} x^4 + c \]

Integration Tables

The default Notebook, called **Untitled** (Mac) or **Untitled** (Win), contains a small set of integration rules, in the form of Transformation Rules. You invoke them by performing a **Simplify**. Several other notebooks, found on your distribution CD, contain large lists of rules. You can find the rules inside the Declarations comment area of these notebooks. You can observe different rules by double-clicking on the various balloon icons nested inside the Declaration Prop.

Not only will these notebooks allow you to solve many integrations by merely using a **Simplify** manipulation, you can also augment them. You can create your own rules to build specialized integration notebooks with your only limit being the memory available in your computer. A very large notebook will take longer to open and may take longer to solve a problem.

You may want to create special notebooks which better serve your needs by copying rules from one of the distributed notebooks into your notebook. To do this, click on the transformation icon just to the left of the desired rule, **Copy**, and then **Paste** into your notebook. You may, in some cases, duplicate rules and names when you paste them into your notebook. MathView will alert you to this fact the first time you invoke a duplicate name, at which time you can delete one of them.
Integration

MathView can immediately solve many integrations when you use notebooks filled with Transformation rules. A strength of the program, however, lies in the fact that you can solve these problems using a more manual approach.

Power Rule

Differentiation has its power rule and so does integration. You can demonstrate this rule by solving an integral of a polynomial with Auto Simplify turned off.

- Enter \( x^2 \), and select it.
- Click on the indefinite integral palette image and type an \( x \).
- Select the whole expression and Simplify with Auto Simplify turned off.

\[
\int x^2 \, dx \quad \text{Result} \quad \frac{x^{2+1}}{2+1} \quad \text{Simplify}
\]

- Take the derivative of the RHS to show that integration undoes the derivative. You can create a new Prop (below left) or Apply the derivative Op to both sides of the conclusion above (below right).

\[
\frac{d}{dx} \left( \frac{x^{2+1}}{2+1} \right) = \frac{d}{dx} x^2 \quad \text{Apply}
\]

Method of Substitution

The chain rule provides a systematic way of differentiating composite functions. The method of substitution, although not as systematic, does describe a way to reverse this process. The example below uses the following integral. After you input it, try to solve by performing a Simplify.

\[
\int (12x - 1) \cos(6x^2 - x) \, dx \quad \text{Simplify will not work.}
\]

To solve, look for an inner function that is the derivative of another one within the integrand. In this example, you can easily see that \( 12x - 1 \) is the derivative of \( 6x^2 - x \).

- In a Prop below the integral, input the substitution equation \( u = 6x^2 - x \).
- Below that, input the total derivative of \( u \). Be sure to press the space bar, or type an \( * \) between the \( d \) and the \( u \) to create the differential.

\[
\int (12x - 1) \cos(6x^2 - x) \, dx
du = (12x - 1) \, dx
\]

- You take the total derivative of the target function by selecting the \( u \) Prop and
substituting it into the \( du \) Prop.

- Since the RHS (right hand side of the equation) contains two occurrences of \( dx \), you must first Collect. After you execute the collect, Isolate \( dx \).

- Substitute the \( dx \) Prop and then the \( u \) Prop into the integral (in order). Simplify the result.

Auto Simplify should be off when you substitute the \( u \) Prop. You do the manipulation with Auto Simplify off to show the substitution. If you have Auto Simplify on, MathView will not display this intermediate result.

Integration by Parts

When you differentiate a product, the result is the following.

\[
\frac{d}{dx} (uv) = v \frac{du}{dx} + u \frac{dv}{dx}
\]
When you place the equation above in differential form and integrate it, the equation becomes the Integration by Parts formula.

\[ \int d(uv) = \int udv + \int v
du \]

Integration by Parts Formula

\[ uv = \int udv + \int v
du \]

\[ \int udv = uv - \int v
du \]

Integration by Parts works when one of the functions in the integrand is easy to integrate and the other is easy to differentiate. MathView has a manipulation that performs this technique automatically.

The trick is for you to input, or manipulate, the integrand so that the integrated function is next to the differential. You then select both this function and the differential and use MathView’s Integration by Parts manipulation. The following example demonstrates this technique.

- The integral below is not in a form where an Integration by Parts will produce a final solution. Select \( \ln(x)dx \) and choose Other ➤ Int. by Parts under the Manipulate menu.

\[ \int x^2\ln(x) dx \]

Selection

\[ \int x^2\ln(x) dx \]

\[ \int x^2\ln(x) dx = \left( x\ln(x) - x \right) x^2 - \frac{1}{2} \int \left( x\ln(x) - x \right) x dx \]

Integrate by Parts

This new expression is more complicated than the first. You must try a different way.

- Select \( x^2 \) and Commute to the other side of \( \ln(x) \). Now select \( x^2dx \) and perform Integration by Parts.

\[ \int x^2\ln(x) dx \]

Commute with Hand

\[ \int x^2\ln(x) dx = \int \ln(x)x^2 dx \]

Commute

\[ \int x^2\ln(x) dx = \int \ln(x)x^2 dx \]

Commute Selection

Choose Manipulate ➤ Other ➤ Int. by Parts

\[ \int x^2\ln(x) dx = \frac{1}{2}x^3\ln(x) - \frac{1}{2}x^3 \]

Integrate by Parts Result

Sometimes you will find that an Integration by Parts produces a new expression with an integral that you can reduce further by using another Integration by Parts or by doing a substitution.
You can use MathView to demonstrate the manual method of performing an Integration by Parts. Start by setting up your notebook in the following manner.

First, enter the integral you used in the last example with the integrand already commuted.

\[ \int \ln(x) x^2 \, dx \]

Below this Prop, define the differentiated function by setting it equal to the substitution variable \( u \). Below the \( u \)-Prop input a differential Prop and, below that, input an integral equation that will integrate the \( dv \) part of the Integration by Parts formula.

Set up a separate Prop defining the Integration by Parts formula and performing the appropriate substitutions.

\[ \int \ln(x) x^2 \, dx = u \, v - \int v \, du \]

Perform the first Substitution.

\[ \int \ln(x) x^2 \, dx \]

\( u = \ln(x) \)

\( du = \frac{1}{x} \, dx \)

\( dv = x^2 \, dx \)

\[ \int \ln(x) x^2 \, dx = \ln(x) x^2 - \int \frac{1}{x} x^2 \, dx \]

Result needs \( u \) & \( v \) Props

Substituted into RHS

\[ \int x^2 \ln(x) \, dx = \frac{1}{3} u \, x^3 - \left( \frac{v \, dx}{x} \right) \]

Final answer after you substitute in the \( u \) & \( v \) Props is

\[ \int x^2 \ln(x) \, dx = \frac{1}{3} x^3 \ln(x) - \frac{1}{9} x^3 \]
Method of Partial Fractions

The section on Rational Functions contains an example on partial fraction decomposition (page 109). You use this same method to help solve integrals with rational integrands.

When you try to simplify the following integral, MathView cannot solve it. If you try an Expand, the result may be more complicated than the original problem.

$$\int \frac{7x-1}{x^2 + x - 20} \, dx$$

**Simplify**

Expand produces the following:

$$\int \frac{7x-1}{x^2 + x - 20} \, dx = \left( \int \frac{1}{x^2 + x - 20} \, dx \right) + 7 \left( \int \frac{x}{x^2 + x - 20} \, dx \right)$$

You start by placing the integrand into a factored form. See “Partial Fractions” on page 111. Then you expand for the answer.

- Enter the following integral, select the denominator of the integrand, and Factor.
- Select the resulting integral and Expand for the answer.

- Select denominator and Factor.

$$\int \frac{7x-1}{x^2 + x - 20} \, dx = \int \frac{7x-1}{(x+5)(x-4)} \, dx$$

Select the RHS and Expand.

$$\int \frac{7x-1}{x^2 + x - 20} \, dx = \int \frac{7x-1}{x+5} \, dx$$

$$\int \frac{7x-1}{x^2 + x - 20} \, dx = 4 \ln(x+5) + 3 \ln(x-4)$$

Expand
Integral Calculus

Definite Integration

- Definite integral input
- Riemann Sums
- Fundamental Theorem of Calculus
- Techniques of integration
- Areas between curves
- Solids of revolution

Definite Integral Input
You click on the palette image to produce an integral with upper and lower limits. To complete the input, type the integrand, press \[ \int \], type in the independent variable, press \[ \int \], type in the lower bound, press \[ \int \], and type in the upper bound. See the figure on page 171.

A second method is to use the Command-key equivalent \( \text{Mac} \) or \( \text{Win} \), duplicating the palette input.

You can also use the Command-line method by typing the following to produce your integral. Type: \textbf{Integral} \{integrand\} \( \int \) \{lower bound\}: \{upper bound\}.

Riemann Sums
You solve Riemann Sums, in \textit{MathView}, by using the Summation Op. The easiest way to input the Op is to click on the palette image. The Command-key is \( \text{Mac}\). Below is the Command-line method.

To Input \[ \sum_{k=1}^{100} a_k x^k \] Type: \textbf{Summation}(\{lower\} \{upper\}) \{a_k\} \{x^k\}

The following example shows you how to set up a Lower Sum, an Upper Sum, and the Trapezoid Method to approximate a definite integral. The Lower and Upper Sums demonstrate two different methods you can use to solve these problems.

The integral the example approximates is \( \int_a^b f(x) \, dx \).

You define the Lower Sum as \textbf{Lower Area} = \sum_{k=0}^{n-1} f(a + k \cdot \Delta x) \Delta x.

- For this example, use the function \( f(x) = x^2 \). In a new notebook, enter the
Definite Integration

six Props below.

\[ \int_a^b f(x) \, dx = \frac{b^2}{2} \]

Declare \( f \) a User Defined Function.

\[ n = 100 \]
\[ a = 2 \]
\[ b = 4 \]
\[ \Delta x = \frac{b - a}{n} \]
\[ \sum_{k=0}^{n-1} f(a + k \Delta x) \Delta x \]

\( \Delta x \) is one symbol declared as a User Defined variable. Do not put a * or press \( \text{Space} \) between \( \Delta \) and \( x \).

You create the symbol \( \Delta x \) by choosing \( \Delta \) from the Palette and then by typing \( x \) without a space or an * between them.

- Declare \( \Delta x \) a User Defined variable.
- Declare \( f \) a function.
- Select the Summation expression and choose Calculate.

\[ \sum_{k=0}^{n-1} f(a + k \Delta x) \Delta x = 18.547 \quad \text{Calculate} \]

The advantage of doing the problem in terms of the function \( f \), is that you can change the function very easily to find the sum of other functions.

The Upper Sum is the same formula with \( k \) starting at 1 and \( n \) as the upper limit rather than \( n - 1 \).

- For the next example, which demonstrates a second method, find the upper sum of the same problem without function notation.

\[ y = x^2 \]
\[ n = 100 \]
\[ a = 2 \]
\[ b = 4 \]
\[ \Delta x = \frac{b - a}{n} \]
\[ \sum_{k=1}^{n} x \Delta x \]

- Select the Summation Op and Calculate.

\[ \sum_{k=1}^{n} y \Delta x = 18.787 \quad \text{Calculate} \]

The Trapezoid Method is simply the Upper and Lower Sums averaged.
Integral Calculus

• Set up your notebook as follows and **Calculate** for the answer.

  ![Image](image1)

  ```latex
  \begin{align*}
  &\text{Upper }= \sum_{k=0}^{n-1} f(a + k \Delta x) \Delta x \\
  &\text{Lower }= \sum_{k=1}^{n} f(a + k \Delta x) \Delta x \\
  &\text{Trap }= \frac{1}{2} \left[ \text{Upper} + \text{Lower} \right] \\
  &\Delta \text{Trap }= 18.867 \quad \text{Calculate}
  \end{align*}
  ```

**Definite Integrals**

Extending the concept leads to the definition of the definite integral as a limit of Riemann Sums.

$$\int_{a}^{b} f(x) \, dx = \lim_{n \to \infty} \sum_{k=1}^{n} f(x_k)\Delta x_k$$

You can change the parameters of this algorithm by choosing **Manipulate**

**Manipulation Preferences**

**Numeric Integration**

*MathView* uses a very powerful numerical algorithm to solve definite integrals, making the solution to the difficult problem below as easy as selecting the integral and performing a **Calculate**.

• Input the following definite integral by typing in the integrand, selecting it, clicking on the palette image of the Definite Integral Op, and tabbing to input the limits.

  ![Image](image2)

  ```latex
  \begin{align*}
  &\sin(x^2) \cos(x^2 + \epsilon) \\
  &\int_{\epsilon}^{3} (\sin[x^2] \cos[x^2 + \epsilon]) \, dx \quad \text{After clicking on} \quad \text{Integrate} \\
  &\int_{0}^{3} (\sin[x^2] \cos[x^2 + \epsilon]) \, dx \quad \text{After typing } x \quad \text{Set} \quad 0 \quad \text{and} \quad 3
  \end{align*}
  ```

• Select the expression by clicking on the Prop icon or by clicking on the integral sign. To get a numerical answer for this problem, you must choose **Calculate**. Simpler problems may only require an **Expand, Collect, or a Simplify**.

  ![Image](image3)

  ```latex
  \begin{align*}
  &\int_{0}^{3} (\sin[x^2] \cos[x^2 + \epsilon]) \, dx \\
  &\Delta \int_{0}^{3} (\sin[x^2] \cos[x^2 + \epsilon]) \, dx = 0.18282 \quad \text{Calculate}
  \end{align*}
  ```

Be warned that this integral is a particularly nasty one, which may take some time...
Definite Integration

for MathView to solve. A look at the graph of the function explains why.

\[ y = \sin(x^2) \cos(x^2 + e) \]

For simple functions, MathView will evaluate to an exact answer by using the Fundamental Theorem of Calculus Simplify or Expand are the manipulations you use.

The next example demonstrates one of MathView’s more useful features.

- For comparative purposes, use the same integral you used in the Riemann Sum example. The method of input is up to you.

\[ \int_{2}^{4} x^2 \, dx \]

- Select the integral and choose Simplify. You get an answer which is somewhat different than the one achieved with Calculate. Make sure you turn on Auto Simplify for the manipulation.

\[ \int_{2}^{4} x^2 \, dx \]

\[ \Delta \int_{2}^{4} x^2 \, dx = \frac{56}{3} \text{ Simplify} \]

Calculate while you still have the fraction selected.

\[ \Delta \int_{2}^{4} x^2 \, dx = 18.687 \text{ Calculate} \]

- To see what MathView is doing during this manipulation, delete the answer above, and perform the manipulation again. Turn Auto Simplify off.

\[ \int_{2}^{4} x^2 \, dx \quad \text{Simplify with Auto Simplify turned off.} \]

\[ \Delta \int_{2}^{4} x^2 \, dx = \frac{x-4}{2} \quad \text{Simplify} \]

MathView is using the Fundamental Theorem of Calculus to solve the problem. Simplify this intermediate answer two more times to obtain the final answer. This procedure steps you through the process. Notice that MathView uses a new operator here. It is called the Evaluate-At Op.

If MathView cannot evaluate the integral, then it gives you the Evaluate-At Op with an indefinite integral as its argument. The following example requires further
Integral Calculus

manipulation to solve.

\[ \int_{1}^{3} x \ln(x^2) \, dx \]

\[ \int_{1}^{3} x \ln(x^2) \, dx = [\frac{x^2}{2} \ln(x^2)]_{x=1}^{x=3} \]

\[ \text{Simplify} \]

\[ = \frac{9}{2} \ln(9) - \frac{1}{2} \]

\[ \text{Integrate by Parts} \]

\[ \text{Evaluate At Op, Simplify for the} \]
Definite Integration

answer, and Calculate to get a floating-point answer.

$$\Delta \int_{1}^{3} 2 \ln(x^2) \, dx = \frac{x^2}{4} \left[ \ln(x^2) - \frac{1}{2} x^2 \right]$$

Integrate by Parts

$$= \left( \frac{3}{2} \ln[3^2] - \frac{1}{2} 3^2 \right) - \left( \frac{1}{2} 2^2 \ln[2^2] - \frac{1}{2} 2^2 \right)$$

Simplify

$$= \frac{3}{2} \ln \Theta - 4$$

Simplify

$$= 5.6875$$

Calculate

Graphs of Areas Between Curves

You can shade areas between curves, which can be useful when studying inequalities and integration. Use the following two equations for the next example.

$$y = \sin(2x + \frac{1}{2} \pi) + 2$$

$$y' = 1$$

- The problem is to shade the area between $y$ and $y'$. Select the first equation, by clicking on the equal sign, and generate a Linear Graph Theory.
- Select the second equation and choose Add Line Plot under the Graph ➤ Additional menu.

Teacher's Note

The Evaluation-At Op is a valuable tool when teaching the Fundamental Theorem. Have the student evaluate an integral separately with Auto Casing on, and then Paste the result into the Op. Turn off Auto Simplify and Simplify will demonstrate the theorem.

$$\Delta \int \sin(x) \, dx$$

Simplify

After you have determined the integral, Copy the result and Paste it into the Evaluate-At Op. Simplify three times to obtain the answer using the Fundamental Theorem.

$$\begin{align*}
\Delta y &= \left[ \sin(x) + c \right]_0^\pi \\
\Delta x &= \int \cos(x) + c_{100} \, dx
\end{align*}$$

Simplify

$$= (-\cos(\pi) + c_{100}) - (-\cos(0) + c_{100})$$

Simplify

$$= -(-1) + 1$$

Simplify

$$= 2$$

Simplify
Integral Calculus

To add shading, you must add a Surface Plot to this Linear Graph Theory.

- A surface plot needs two independent variables. You get around this problem by adding a third equation, \( z = xy \). Select this new Prop and choose Add Surface Plot from the Graph ➤ Additional menu. A surface plot will show up inside the graph details and MathView will plot a nonsensical surface in the Graph Theory.

- Open the graph details and change the surface plot details to those below. When the plot initially draws, the shading may not completely fill the area. Remedy by clicking on the More Points icon along side the graph until the detail is satisfactory.

Use Transparent so the surface plot does not cover up the function lines in the graph.

Redefine the Surface Plot detail to the following:

**Solids of Revolution**

You can display solids in MathView by using three-dimensional Graph Theories. To generate 3-D plots in Graph Theories, MathView adds a third axis, the \( z \)-axis. Think of taking a regular two-dimensional plot and pushing it into the page or
computer screen, and adding a third axis where the $y$-axis was.

You can create a volume by rotating a surface in the $x$-$y$ plane around the $x$-axis (see above). When you take a slice parallel to the $y$-axis and perpendicular to the $x$-axis, you create a curve of intersection that is a circle.

To generate a Graph Theory that looks like the one above, you will revolve the points of the function around the $x$-axis, rather than rotating a surface. You must again trick $MathView$ into producing the correct plot.

Look at the circle that arises when you take a slice through the solid. Notice that for any value of $x$, you can obtain values for $y$ and $z$ using trigonometry. The following diagram shows the circle viewed along the $x$-axis. The origin of the circle is the $x$-axis and the radius is the value of the function itself. You can define any point on the circle by converting the polar coordinates, where the radius equals $y$, to rectangular coordinates. Since the radius is equal to $y$, you can define any point $P$ on the circle in the $y$-$z$ plane by replacing $y$ with $y \cos(a)$ and $z$ with $y \sin(a)$ in your line detail. To define the whole circle for each $x$ value, let the
angle $a$ go from $0$ to $2\pi$. Finally, define the domain of the plot (in the graphic below $x = 0\ldots10$).

$$P = [y \cos(a), y \sin(a)]$$

$y \cos(a), y \sin(a)$ $a = 0\ldots2\pi$ $x = 0\ldots10$

Surface at $(x, y, z)$ where $x = \text{west} \ldots \text{east}$ and $y = \text{south} \ldots \text{north}$:

- Opaque $\Rightarrow$ surface has mesh $\Rightarrow$ and is shaded using Custom $\Rightarrow$
- Coloring: $z = \text{bottom} \ldots \text{top}$ selects from the color scheme [Oregon $\downarrow$]

- Enter the following Props.
  
  - $y = \sin(2x + \frac{1}{2} \pi) + 2$
  - $y' = 1$
  - $z = xy$

- Generate the 3-D plot by selecting the $z$ Prop and choosing Color 3-D under the Graph $\Rightarrow$ $y = f(x,y)$.

- Open the details and change the surface detail to the following.

  - Surface at $(x, y, \cos(a), y \sin(a))$ where $a = 0\ldots2\pi$ and $x = 0\ldots10$
  - [Illuminated $\Rightarrow$] surface has mesh $\Rightarrow$ and is shaded using [Solid $\Rightarrow$]
  - Coloring: [White $\Rightarrow$] is the solid color

- After some Viewport manipulation, a plot similar to the one below will display.
Multiple Integrals

To solve multiple integrals, you must nest one integral entirely within the other. Each must have its differential inside it, but not inside any deeper integral. To demonstrate, use the following integral.

\[
\int_0^1 \left( \int_0^y \sin(x + y) \, dx \right) \, dy
\]

- Enter the above integral by typing
  \[\text{Integral}((\text{Integral}(\sin(x+y) \cdot dx):(0):(y)) \cdot dy):(0):(1)\]
- **Clarify** to remove the unnecessary parentheses.

\[
\int_0^1 \left( \int_0^y \sin(x + y) \, dx \right) \, dy
\]

Try to **Simplify**, and notice that *MathView* does not perform this integration symbolically.

\[
\Delta \int_0^1 \left( \int_0^y \sin(x + y) \, dx \right) \, dy = \int_0^1 \left( \int_0^y \sin(x + y) \, dx \right) \, dy
\]

The integrals with limits turn into integrals enclosed in **Evaluate-At** Ops, but *MathView* does not process the integrals themselves. *MathView* does not evaluate the inner integral because it contains the variable \(y\), with an uncertain relationship to the variable of integration, \(x\). As far as *MathView* knows, \(y\) could be equal to \(x\) or some function of \(x\), or vice versa. Without knowing this relationship, you will find it impossible to find an answer.

An important thing you must do when solving multiple integrals, and indeed anytime you are working in two dimensions, is to use an Independence Declaration.

- Choose **Independence Decl.** from the Insert submenu of the Notebook menu. Type \(x, y\) in the question mark.

\[
\int_0^1 \left( \int_0^y \sin(x + y) \, dx \right) \, dy
\]

- **Simplify** the integral again and **Calculate** the result to achieve a numerical answer.

\[
\Delta \int_0^1 \left( \int_0^y \sin(x + y) \, dx \right) \, dy = -\frac{1}{2} \sin(2) + \sin(1) \quad \text{Simplify}
\]

\[
\Delta \int_0^1 \left( \int_0^y \sin(x + y) \, dx \right) \, dy = 0.38682 \quad \text{Calculate}
\]

- You can obtain the same numerical answer, without the **Simplify** step, by selecting the integral (first Prop) and choosing **Calculate**.

\[
\int_0^1 \left( \int_0^y \sin(x + y) \, dx \right) \, dy
\]

\[
\Delta \int_0^1 \left( \int_0^y \sin(x + y) \, dx \right) \, dy = 0.38682 \quad \text{Calculate}
\]
Differential Equations

Testing Solutions 188
Simple Integration with Initial Value 190
Separation of Variables 192
First Order Linear Equations 194
Numerical Methods 197
Testing Solutions

Finding the derivative of a function was the subject of the chapter on differential calculus. See pages 156 and 165. When you reverse this process, you are solving a differential equation. This section introduces you to differential equations by showing how you can use Case Theories to test potential solutions.

When you substitute the first Prop below into the Derivative Op, you generate a new function along with a derivative. Not only have you found the derivative of the first function, you have created a differential equation.

\[ y = \sin(x) \]
\[ \frac{dy}{dx} = \cos(x) \]

You can find the solution to the differential equation above by reversing the process.

A solution to the differential equation is the function \( y = f(x) \) that, when substituted into the associated differential equation, reduces that equation to an identity. For example, you would reduce the differential equation above to an identity by substituting the original function (the solution) into it.

\[ y = \sin(x) \]
\[ \frac{dy}{dx} = \cos(x) \]
\[ \cos(x) = \cos(x) \]

Therefore, \( y = \sin(x) \) is a solution to the differential equation \( \frac{dy}{dx} = \cos(x) \).

Explicit Solution

A solution that you place in the form \( y = f(x) \) is called an explicit solution. The unknown (dependent) variable, \( y \), is a function of the known (independent) variable, \( x \). In the example above, \( y = \sin(x) \) is an explicit solution to the differential equation \( \frac{dy}{dx} = \cos(x) \).

Implicit Solution

When you cannot isolate the dependent variable, as you could with the equation above, the solution is called implicit. The solution is in the form \( f(x, y) = 0 \). You will find MathView very useful in determining whether a function is a solution to a given differential equation. Below is an example.

- Set up a MathView notebook with the differential equation in its own Prop, followed by two potential solutions in separate Case Theories. Use Notebook ➤ Insert ➤ Case Theory.
Select each potential solution and substitute into the differential equation with the Hand and Expand the result.

<table>
<thead>
<tr>
<th>Differential Equation</th>
<th>Potential Solution #1</th>
<th>Potential Solution #2</th>
</tr>
</thead>
<tbody>
<tr>
<td>((\frac{\partial}{\partial x})^2 y = -4y)</td>
<td>(y = 2\sin(x))</td>
<td>(y = \sin(2x))</td>
</tr>
</tbody>
</table>

MathView brings the differential equation into each Case Theory, allowing each solution to be tested separately.

<table>
<thead>
<tr>
<th>Differential Equation</th>
<th>Potential Solution #1</th>
<th>Potential Solution #2</th>
</tr>
</thead>
<tbody>
<tr>
<td>((\frac{\partial}{\partial x})^2 y = -4y)</td>
<td>(y = 2\sin(x))</td>
<td>(y = \sin(2x))</td>
</tr>
<tr>
<td>(2(\frac{\partial}{\partial x})^2 \sin(x) = -8\sin(x)) Substitute</td>
<td>(-2\sin(x) = -8\sin(x)) Expand</td>
<td>A Solution</td>
</tr>
<tr>
<td>(-4\sin(2x) = -4\sin(2x)) Expand</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To toggle on ReManipulate choose Always ReManipulate under the Manipulate menu.

You can use one Case Theory to test several potential solutions. Before you start, make sure Always ReManipulate is on.

- Using the first Case Theory above, change the potential solution \(2\sin(x)\) to the correct solution \(\sin(2x)\).

<table>
<thead>
<tr>
<th>Differential Equation</th>
<th>Potential Solution #1</th>
<th>Potential Solution #2</th>
</tr>
</thead>
<tbody>
<tr>
<td>((\frac{\partial}{\partial x})^2 y = -4y)</td>
<td>(y = \sin(?))</td>
<td>(y = \sin(2x))</td>
</tr>
<tr>
<td>(2(\frac{\partial}{\partial x})^2 \sin(x) = -8\sin(x)) Substitute</td>
<td>(-2\sin(x) = -8\sin(x)) Expand</td>
<td>Original Solution in the process of changing.</td>
</tr>
<tr>
<td>(-4\sin(2x) = -4\sin(2x)) Expand</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- Below is the result after you have altered the solution.

<table>
<thead>
<tr>
<th>Differential Equation</th>
<th>Potential Solution #1</th>
<th>Potential Solution #2</th>
</tr>
</thead>
<tbody>
<tr>
<td>((\frac{\partial}{\partial x})^2 y = -4y)</td>
<td>(y = \sin(2x))</td>
<td>(y = \sin(2x))</td>
</tr>
<tr>
<td>(2(\frac{\partial}{\partial x})^2 \sin(2x) = -8\sin(2x)) Substitute</td>
<td>(-4\sin(2x) = -4\sin(2x)) Expand</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Simple Integration with Initial Value

When you differentiate a function, the resulting conclusion has a new function along with a derivative in it. Reversing this procedure, by integrating the conclusion, produces the original equation along with a constant of integration. Therefore, every time you integrate, you are solving a differential equation. In this section, you use the Apply manipulation to help solve a simple differential equation.

You call the result you obtain in the following example the General Solution to the differential equation. If given an initial value for \( x \) and \( f(x) \), you can find a Particular Solution. Below is an example.

- Input the following differential equation.

\[
\frac{\partial}{\partial x} y = \cos (x)
\]

- Select the whole equation, by clicking on the equal sign once, then choose Apply.

\[
\frac{\partial}{\partial x} y = \cos (x)
\]

- Click on the Indefinite Integral Op on the palette and type the independent variable \( (x \) in this case). Select the equation and Simplify with Auto Casing turned on.

\[
\frac{\partial}{\partial x} y = \cos (x)
\]

\[
\int \left( \frac{\partial}{\partial x} y \right) \, dx = \int \cos (x) \, dx \quad \text{Apply}
\]

\[
y + c_{100} = \sin(x) + c_{101} \quad \text{Simplify}
\]

- Isolate \( y \) for the General Solution.

\[
y = \sin(x) + c_{101} - c_{100} \quad \text{Isolate}
\]

**Essential Constants**

You would normally combine the two constants of integration, in the example above, into one. This demonstrates the concept of essential constants. Because there are two integrations, two constants are generated. Since these two constants can be combined into one, without effecting the solution, one or the other is non-essential, and you can be eliminated.

- Select the two constants and type a \( c \) to replace both with a new, unlabeled \( c \). This action also generates a new Assumption.
Simple Integration with Initial Value

Given an Initial Value, IV, you can find the Particular Solution by substituting those values into the General Solution, solving for $c$, and substituting $c$ back into the General Solution.

- Use an initial value of $(2, 3)$, that is $f(2) = 3$.
- Select both the $x$ and $y$ equations and substitute into the first Prop.
- Isolate $c$.
- Select the resulting equation and Calculate.
- You arrive at the final solution (Particular Solution) by substituting the equation for $c$ into the original equation (General Solution) in the first Prop.

\[ y = \sin(x) + c \]
\[ 3 = \sin(2) + c \] Substitute
\[ c = -\sin(2) + 3 \] Isolate
\[ c = 2.0907 \] Calculate
\[ y = \sin(x) + 2.0907 \] Substitute

\[ x = 2 \]
\[ y = 3 \]

Below is a Graph Theory containing several solution curves, including the Particular Solution with the Initial Value $(2,3)$. 

![Graph Theory with solution curves and initial value](image-url)
Separation of Variables

You can algebraically manipulate an equation in the form of $\frac{dy}{dx} = \frac{g(x)}{h(y)}$ into the following form.

$$\frac{dy}{dx} = \frac{g(x)}{h(y)} \rightarrow h(y) \, dy = g(x) \, dx$$

Notice how all the $x$s are together on one side of the equation and all the $y$s are together on the other. Use the old algebraic method, cross multiplying, to put the equation into this form. In MathView, you manipulate with the Hand, use the rules of algebra, or re-input in the new form. In the first example, you will use the algebraic method.

You must enter the differential in the following form for the operation to work; the Partial Derivative Op will not work.

- Enter $(d*y)/(d*x) = (g(x))/(h(y))$ or $/d*x d*y$ Esc $= / g(x$ $h(y)$. 
- Select the equation and choose Apply (click on the palette image).
- Type $\cdot (h(y) \cdot d+x)/1$
- Select by clicking on the equal sign and Simplify.

Now that the expression is in differential form; you can integrate each side for the solution.

- Now try entering the following equation using your favorite method.

$$\frac{dy}{dx} = \frac{2x}{e^y}$$

- Using the same method you used above, place the differential equation into a separated form. Remember to separate the differential operators from their variables with a space, or a multiplication (both $d*x$ and $d \cdot x$ produces $dx$).
Separation of Variables

Now you can integrate. Since the differentials are already in the problem, you apply the Integral Op using the keyboard method (\(\text{Shift} - 4\)).

- Select the equation and choose **Apply**. Both sides highlight, ready for you to perform an operation on them. Rather than clicking on the Indefinite Integral Op on the Palette (which would add a second differential operator), enter the command key equivalent, \(\text{u}\).

- Select this new equation by clicking on the equal sign. Once selected, perform a **Simplify**. If **Auto Casing** is on, \(\text{MathView}\) generates two constants.

You can save a step by simplifying one side of the equation with **Auto Casing** turned on and the other side with it turned off. In either case, you can remove the subscript which remains after you have eliminated all non-essential constants.

- Select the number and delete it; or just select the whole constant, subscript and all, and type a new \(c\). A new Prop will be generated with the subscript gone.

The disadvantage of removing the subscript is that when \(\text{MathView}\) generates the new Assumption Prop, you lose the dynamic link. You will not be able to change the original problem and have it ReManipulate the solution. It may be better to wait until the very end to do this operation or just leave the subscript attached, if you plan on testing different initial values.

You solve for the dependent variable \(y\) by performing an **Isolate** or by applying the Natural Log to each side.

- Select the equation by clicking on the equal sign; **Apply** the \(\text{Ln}\) function by clicking on its Palette image; select the resulting equation and **Simplify**.
First Order Linear Equations

The general linear differential equation takes the following form.

\[ a_n(x) \frac{d^n y}{dx^n} + a_{n-1}(x) \frac{d^{n-1} y}{dx^{n-1}} + \cdots + a_1(x) \frac{dy}{dx} + a_0(x) y = g(x) \]

Note two items in this equation. First, the derivatives and the dependent variable \( y \) are of the first degree (to the first power). Second, the coefficients depend only on the independent variable \( x \), in this case. In the context of differential equations, a coefficient can be a constant or a function of the independent variable (the dependent variable \( y \) is not multiplied onto any derivative). In addition, although not apparent from the equation above, the dependent variable is not the argument of a transcendental function. The independent variable can be an argument, but the dependent variable cannot.

A first order linear differential equation takes the following form.

\[ a_1(x) \frac{\partial y}{\partial x} + a_0(x) y = g(x) \]

Note that both coefficients and the function \( g \) depend on the independent variable \( x \) alone and not \( y \). If you divide both sides by the coefficient of the derivative, \( a_1(x) \), you place the equation into standard form.

\[ \frac{a_1(x) \frac{\partial y}{\partial x}}{a_1(x)} + \frac{a_0(x) y}{a_1(x)} = \frac{g(x)}{a_1(x)} \]

The two new functions \( P \) and \( Q \), below, merely replace the two functions of \( x \) that you have created by the division. Since they are both functions of \( x \), you can replace them with new functions of \( x \), which may or may not represent a quotient in a problem.

\[ \frac{\partial y}{\partial x} + P(x)y = Q(x) \]

You solve differential equations in this form by using the following integrating factor.

\[ u = e^{\int P(x) \, dx} \]

You can find the solution by placing a linear equation in the standard form \( dy/dx + P(x)y = Q(x) \) and applying this integrating factor to both sides. Below is the standard formula.

\[ uy = \int uQ(x) \, dx + c \]
First Order Linear Equations

An example demonstrates how you use MathView to find these solutions.

• Solve the following equation.

\[ \frac{d}{dx} y + 2y = x \]

• Enter the integrating factor, defining \( u \) as a User Defined Variable. In a second Prop, enter the differential equation.

\[ u = e^{\int 2 \, dx} \]

\[ \frac{d}{dx} y + 2y = x \]

• **Simplify** the integrating factor with Auto Casing turned off.

\[ u = e^{\int 2 \, dx} \]

\[ u = e^{2x} \quad \text{Simplify} \]

• **Apply** the integrating factor to the differential equation (multiply it to both sides using a * and not \( \dot{\cdot} \)).

\[ u = e^{\int 2 \, dx} \]

\[ u = e^{2x} \quad \text{Simplify} \]

\[ \frac{d}{dx} y + 2y = x \]

\[ \left( \frac{d}{dx} y + 2y \right) u = x \quad \text{Apply} \]

• Substitute the integrating factor into the last conclusion with the Hand. **Expand** the resulting equation.

\[ u = e^{\int 2 \, dx} \]

\[ u = e^{2x} \quad \text{Simplify} \]

\[ \frac{d}{dx} y + 2y = x \]

\[ \left( \frac{d}{dx} y + 2y \right) u = x \quad \text{Apply} \]

\[ \left( \frac{d}{dx} y + 2y \right) e^{2x} = e^{2x} x \quad \text{Substitute} \]

\[ 2e^{2x} y + e^{2x} \frac{d}{dx} y = e^{2x} x \quad \text{Expand} \]

• While the last Prop is still selected, enclose it in a Case Theory by selecting Notebook → Insert → Case Theory. Insert an Independence Declaration declaring \( x \) and \( y \) independent of each other. See page 68. Move the
Differential Equations

You add an Independence Declaration inside a Case Theory now because it is necessary for the integration to follow, but would have given the wrong answer in the substitution in the Prop just before the Case Theory (dy/dx would have gone to zero).

\[
\begin{align*}
\square u &= e^2 \int dx \\
\triangle u &= e^{2x} \quad \text{Simplify} \\
\frac{\partial}{\partial x} y + 2y &= x \\
\triangle \left( \frac{\partial}{\partial x} y + 2y \right) u &= x u \quad \text{Apply} \\
\triangle \left( \frac{\partial}{\partial x} y + 2y \right) e^{2x} &= e^{2x} x \quad \text{Substitute} \\
\bigcirc \begin{array}{c}
\square \text{The variables } (x,y) \text{ are independent of each other} \checkmark \\
\end{array}
\end{align*}
\]

- \textbf{Apply} the Integral Op to the last equation and \textbf{Simplify} the LHS (you should have \textbf{Auto Casing} on at this point to generate the constant). \textbf{Simplify} the RHS with \textbf{Auto Casing} off.

\[
\begin{align*}
\square u &= e^2 \int dx \\
\triangle u &= e^{2x} \quad \text{Simplify} \\
\frac{\partial}{\partial x} y + 2y &= x \\
\triangle \left( \frac{\partial}{\partial x} y + 2y \right) u &= x u \quad \text{Apply} \\
\triangle \left( \frac{\partial}{\partial x} y + 2y \right) e^{2x} &= e^{2x} x \quad \text{Substitute} \\
\bigcirc \begin{array}{c}
\square \text{The variables } (x,y) \text{ are independent of each other} \checkmark \\
\end{array}
\end{align*}
\]

\textbf{MathView} is unable to solve the RHS with a simplify manipulation. You can solve by using Integration by Parts on the RHS after commuting the integrand with the Hand. Make sure you turn \textbf{Auto Casing} off at this time. \textbf{Isolate} \( y \) and \textbf{Expand} the RHS of the resulting equation for the solution. Below is the entire Theory.

\[
\begin{align*}
\square u &= e^2 \int dx \\
\triangle u &= e^{2x} \quad \text{Simplify} \\
\frac{\partial}{\partial x} y + 2y &= x \\
\triangle \left( \frac{\partial}{\partial x} y + 2y \right) u &= x u \quad \text{Apply} \\
\triangle \left( \frac{\partial}{\partial x} y + 2y \right) e^{2x} &= e^{2x} x \quad \text{Substitute} \\
\bigcirc \begin{array}{c}
\square \text{The variables } (x,y) \text{ are independent of each other} \checkmark \\
\end{array}
\end{align*}
\]

See page 174 for a review on Integration by Parts.
Numerical Methods

You can use MathView to solve differential equations using two numerical methods, Euler and Runge-Kutta. MathView stores the solutions you obtain using these methods in a table which you can then examine and plot just like other tables. This section introduces these features by showing you how to solve two simple first order equations.

**Euler’s Method**

Although it is not very accurate, Euler’s method is simple and understanding it is basic to the understanding of other more sophisticated methods. The next example uses MathView to compare Euler’s Method with an actual solution.

- Input the following differential equation.

\[ \frac{dy}{dx} = y \quad \text{or} \quad \frac{d^2y}{dx^2} = y \]

You can construct the derivative (on the left above), or you can use MathView’s Partial Derivative Op (right).

- Select the equation by clicking on the equal sign and choose Integrate Differential Equation... under Table in the Manipulate menu. Select Euler, rather than Runge-Kutta, by clicking on the latter and moving the mouse down to Euler’s Method.

- Input the information above and click OK. Set the Initial Value to 1. The table generates with 21 points according to Euler’s method.

- Select the table by clicking on its leading icon and plot the points by choosing Linear under the Graph menu. Below is the table and the resulting graph theory (zoomed out).
The equation \( y = Ce^x \) represents the solution curve, so duplicate the first line plot inside the graph details by selecting and performing a **Copy/Paste**. Replace the \( y \) in the line description with \( Ce^x \) and change the color of the line.

- You must give \( C \) a value before this plot will show. In a new Prop, input 1 as this value. **Clarify** and declare \( C \) a constant. The plot will generate in the Graph Theory.

- To better display the Euler line, generate a scatter plot of the points. Select the table again and choose **Add Scatter Plot** under the Graph ▶ Additional menu. **MathView** will automatically add the 21 scatter points over the Euler line. Displayed below is the resulting graph theory.

The Euler curve is a pretty good approximation close to the starting point, but contains more error the farther right you go. To analyze the error, the following Case Theory can help.

- Copy the original table and paste inside a separate Case Theory. Rename the table \( E \) (**User Defined Function**). Define \( C=1 \) and \( x=0.1 \).

- Set up two equations: the first, defining the actual solution \( y = Ce^x \); and the second, as the table \( E(x) \). Call this second equation \( y_{euler} \).

- Finally, create an error equation, defined as the difference, named \( Error \). After calculating, **Substitute** the two conclusions into the Error equation to determine the error. You can now change the value of \( x \) to see different errors.
You can further study the errors by generating another table.

- Select the Error equation and generate a table with the same data you used to generate the original Euler table. To generate the error graph, select the table and choose **Linear** under the **Graph** menu. Make \( x \) the x-axis and **Error** the y-axis.

**Runge-Kutta Method**

A much more accurate and more widely used method of approximation is the Runge-Kutta method. It uses a sampling of slopes through an interval and takes a weighted average to determine the right end point. This averaging gives a very accurate approximation.

- Input the following equations. The second equation is the exact solution.

\[
\frac{\partial}{\partial x} y = x + y \quad \therefore y = 2e^x - x - 1
\]

- Generate two tables from the same differential equation, one using Euler’s method and the other using the Runge-Kutta method. Make the domain 0 to 1 with 101 points. This will create an \( h \) of 0.01. Name the Euler table \( E \) and the
Differential Equations

Runge-Kutta table $R$ (User Defined Functions). Plot both approximations along with the solution curve in the same graph theory.

Adjust the graph bounds to show the curves at $x = 1$. The Runge-Kutta is so accurate that it appears to be on top of the actual solution curve. By zooming in on these two lines, you can generate a graph showing an error. This requires quite a few zooms. Alternatively, you can change the graph bounds to the following numbers to produce a graph showing the error.

You can further study the errors by adding the following Case Theories. Generate errors for both Euler and Runge-Kutta at $x = 0$, $x = 0.5$, and $x = 1$.

Solving Second and Higher Order Equations

You solve higher order equations by forming the system of associated first order equations, selecting all by Shift-clicking, and choosing Manipulate ▶ Table ▶ Integrate Differential Equation.... Enter the initial values and click OK. You can generate an interesting plot from second order equations by leaving the selection as it is and choosing Graph ▶ Other ▶ $x = f(t)$, $y = g(t)$ Parametric. For higher order equations, you use Graph ▶ Other ▶ $x = f(t)$, $y = g(t)$, $z = h(t)$ Space Curve to plot a 3-D parametric graph.
Appendix

Universal Keystrokes 202
Macintosh Shortcut Keystrokes 203
Windows Shortcut Keystrokes 204
Macintosh Menu Items and Palette Buttons 205
Windows Menu Items and Palette Buttons 209
MathView and the Internet 213
Divert Cascade 218
Break Cascade 223
Frequently Asked Questions 225
Appendix

**Universal Keystrokes**

Type apostrophe then the key listed on Macintosh or Windows.

<table>
<thead>
<tr>
<th>Key ⇒ modifier</th>
<th>α</th>
<th>Β</th>
<th>Χ</th>
<th>∆</th>
<th>Ε</th>
<th>Φ</th>
<th>Γ</th>
<th>Η</th>
<th>ϑ</th>
<th>Κ</th>
<th>Λ</th>
<th>Μ</th>
</tr>
</thead>
<tbody>
<tr>
<td>′</td>
<td>α</td>
<td>Β</td>
<td>Χ</td>
<td>∆</td>
<td>Ε</td>
<td>Φ</td>
<td>Γ</td>
<td>Η</td>
<td>ϑ</td>
<td>Κ</td>
<td>Λ</td>
<td>Μ</td>
</tr>
<tr>
<td>′esc &amp; ′</td>
<td>Ρ</td>
<td>&lt;</td>
<td>Δ</td>
<td>Φ</td>
<td>Γ</td>
<td>∀</td>
<td>∃</td>
<td>ϑ</td>
<td>〉</td>
<td>Λ</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Key ⇒ modifier</th>
<th>ν</th>
<th>°</th>
<th>π</th>
<th>θ</th>
<th>ρ</th>
<th>σ</th>
<th>τ</th>
<th>υ</th>
<th>ω</th>
<th>ξ</th>
<th>ψ</th>
<th>ζ</th>
</tr>
</thead>
<tbody>
<tr>
<td>′</td>
<td>ν</td>
<td>°</td>
<td>π</td>
<td>θ</td>
<td>ρ</td>
<td>σ</td>
<td>τ</td>
<td>υ</td>
<td>ω</td>
<td>ξ</td>
<td>ψ</td>
<td>ζ</td>
</tr>
<tr>
<td>′esc &amp; ′</td>
<td>π</td>
<td>Θ</td>
<td>Ρ</td>
<td>Σ</td>
<td>Γ</td>
<td>Ω</td>
<td>Ξ</td>
<td>Ψ</td>
<td>Ν</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Macintosh Shortcut Keystrokes

Type modifier(s) and key together.

<table>
<thead>
<tr>
<th>Key</th>
<th>Modifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>α</td>
<td>B</td>
</tr>
<tr>
<td>Β</td>
<td>Χ</td>
</tr>
<tr>
<td>Α</td>
<td>Δ</td>
</tr>
<tr>
<td>Ε</td>
<td>Φ</td>
</tr>
<tr>
<td>Γ</td>
<td>Η</td>
</tr>
<tr>
<td>Η</td>
<td>Ι</td>
</tr>
<tr>
<td>ι</td>
<td>Κ</td>
</tr>
<tr>
<td>Κ</td>
<td>Λ</td>
</tr>
<tr>
<td>Λ</td>
<td>M</td>
</tr>
<tr>
<td>ℝ</td>
<td>⟨</td>
</tr>
<tr>
<td>Δ</td>
<td>E</td>
</tr>
<tr>
<td>Ε</td>
<td>Φ</td>
</tr>
<tr>
<td>Γ</td>
<td>Ψ</td>
</tr>
<tr>
<td>∀</td>
<td>ι</td>
</tr>
<tr>
<td>ι</td>
<td>θ</td>
</tr>
<tr>
<td>θ</td>
<td>⟩</td>
</tr>
<tr>
<td>Λ</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Key</th>
<th>Modifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>η</td>
<td>ο</td>
</tr>
<tr>
<td>ο</td>
<td>π</td>
</tr>
<tr>
<td>π</td>
<td>θ</td>
</tr>
<tr>
<td>ρ</td>
<td>σ</td>
</tr>
<tr>
<td>σ</td>
<td>τ</td>
</tr>
<tr>
<td>τ</td>
<td>υ</td>
</tr>
<tr>
<td>υ</td>
<td>ψ</td>
</tr>
<tr>
<td>ψ</td>
<td>ο</td>
</tr>
<tr>
<td>ο</td>
<td>ξ</td>
</tr>
<tr>
<td>ξ</td>
<td>ψ</td>
</tr>
<tr>
<td>ψ</td>
<td>ξ</td>
</tr>
<tr>
<td>ξ</td>
<td>ζ</td>
</tr>
<tr>
<td>ζ</td>
<td></td>
</tr>
<tr>
<td>ν</td>
<td>Π</td>
</tr>
<tr>
<td>Π</td>
<td>Θ</td>
</tr>
<tr>
<td>Θ</td>
<td>Ρ</td>
</tr>
<tr>
<td>Ρ</td>
<td>Σ</td>
</tr>
<tr>
<td>Σ</td>
<td>γ</td>
</tr>
<tr>
<td>γ</td>
<td>ψ</td>
</tr>
<tr>
<td>ψ</td>
<td>Ω</td>
</tr>
<tr>
<td>Ω</td>
<td>Ξ</td>
</tr>
<tr>
<td>Ξ</td>
<td>Ψ</td>
</tr>
<tr>
<td>Ψ</td>
<td>Ν</td>
</tr>
</tbody>
</table>

203
### Windows Shortcut Keystrokes

Type modifier(s) and key together.

<table>
<thead>
<tr>
<th>Key ⇒ modifier</th>
<th>☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁</th>
</tr>
</thead>
<tbody>
<tr>
<td>☁ ☁</td>
<td>α B X Δ E Φ Γ H õ K Λ M</td>
</tr>
<tr>
<td>☁</td>
<td>R ⟨ Δ Φ Γ ∀ Ψ õ ⟩ Λ ℜ</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Key ⇒ modifier</th>
<th>☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁ ☁</th>
</tr>
</thead>
<tbody>
<tr>
<td>☁ ☁</td>
<td>ν π θ ρ σ τ ν ω ξ ψ ζ</td>
</tr>
<tr>
<td>☁</td>
<td>Π Θ Σ Ω Ξ Ψ ∀</td>
</tr>
</tbody>
</table>
The following tables list the keystrokes to use for menu items and palette buttons, and other editing functions for the Macintosh platform.

### Macintosh Menu Items and Palette Buttons

<table>
<thead>
<tr>
<th>Menu/Submenu</th>
<th>Menu Item</th>
<th>Palette Button</th>
<th>Keystroke(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>New Notebook</td>
<td>n/a</td>
<td>⌘ N</td>
</tr>
<tr>
<td>File</td>
<td>Open Notebook</td>
<td>n/a</td>
<td>⌘ O</td>
</tr>
<tr>
<td>File</td>
<td>Close Notebook</td>
<td>n/a</td>
<td>⌘ C</td>
</tr>
<tr>
<td>File</td>
<td>Save Notebook</td>
<td>n/a</td>
<td>⌘ S</td>
</tr>
<tr>
<td>File</td>
<td>Print Notebook</td>
<td>n/a</td>
<td>⌘ P</td>
</tr>
<tr>
<td>File</td>
<td>Quit</td>
<td>n/a</td>
<td>⌘ Q</td>
</tr>
<tr>
<td>Edit</td>
<td>Undo</td>
<td></td>
<td>⌘ Z</td>
</tr>
<tr>
<td>Edit</td>
<td>Cut</td>
<td></td>
<td>⌘ X</td>
</tr>
<tr>
<td>Edit</td>
<td>Copy</td>
<td></td>
<td>⌘ C</td>
</tr>
<tr>
<td>Edit</td>
<td>Copy as Picture</td>
<td>n/a</td>
<td>⌘ F</td>
</tr>
<tr>
<td>Edit</td>
<td>Paste</td>
<td></td>
<td>⌘ V</td>
</tr>
<tr>
<td>Edit</td>
<td>Clear</td>
<td></td>
<td>⌘ W</td>
</tr>
<tr>
<td>Edit</td>
<td>Select In</td>
<td></td>
<td>⌘ I</td>
</tr>
<tr>
<td>Edit</td>
<td>Select Out</td>
<td></td>
<td>⌘ Shift ⌘ I</td>
</tr>
<tr>
<td></td>
<td>n/a</td>
<td>n/a</td>
<td>⌘ Shift ⌘ I</td>
</tr>
<tr>
<td></td>
<td>n/a</td>
<td>n/a</td>
<td>⌘ Shift ⌘ I</td>
</tr>
<tr>
<td></td>
<td>n/a</td>
<td>n/a</td>
<td>⌘ Shift ⌘ I</td>
</tr>
<tr>
<td>Edit</td>
<td>Comment Font</td>
<td>n/a</td>
<td>⌘ Option ⌘ F</td>
</tr>
<tr>
<td>Edit ▶</td>
<td>Comment Style</td>
<td>Plain</td>
<td>⌘ P</td>
</tr>
<tr>
<td>Edit ▶</td>
<td>Comment Style</td>
<td>Bold</td>
<td>⌘ B</td>
</tr>
<tr>
<td>Edit ▶</td>
<td>Comment Style</td>
<td>Italic</td>
<td>⌘ I</td>
</tr>
<tr>
<td>Edit ▶</td>
<td>Comment Style</td>
<td>Underline</td>
<td>⌘ U</td>
</tr>
<tr>
<td>Notebook</td>
<td>Clarify</td>
<td>n/a</td>
<td>⌘ Option ⌘ C</td>
</tr>
<tr>
<td>Notebook ▶</td>
<td>Windows Palette</td>
<td></td>
<td>⌘ Option ⌘ W</td>
</tr>
<tr>
<td>Appendix</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Notebook</th>
<th>Expose</th>
<th>n/a</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notebook</td>
<td>Collapse</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Indent Left</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Indent Right</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Insert</td>
<td>Page Break</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Insert</td>
<td>Case Theory</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Insert</td>
<td>Transform Rule</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Make Working Stmt</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Stop Working Stmt</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Get Info</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Display Precision</td>
<td>2 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Display Precision</td>
<td>3 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Display Precision</td>
<td>4 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Display Precision</td>
<td>5 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Display Precision</td>
<td>6 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Display Precision</td>
<td>7 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Display Precision</td>
<td>8 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Display Precision</td>
<td>10 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ▶ Display Precision</td>
<td>15 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Notebook Font</td>
<td>n/a</td>
</tr>
<tr>
<td>Manipulate</td>
<td>Calculate</td>
<td></td>
</tr>
<tr>
<td>Manipulate</td>
<td>Simplify</td>
<td></td>
</tr>
<tr>
<td>Manipulate</td>
<td>Expand</td>
<td></td>
</tr>
<tr>
<td>Manipulate</td>
<td>Collect</td>
<td></td>
</tr>
<tr>
<td>Manipulate</td>
<td>Factor</td>
<td></td>
</tr>
<tr>
<td>Manipulate</td>
<td>Apply</td>
<td></td>
</tr>
<tr>
<td>Manipulate</td>
<td>Transform</td>
<td></td>
</tr>
<tr>
<td>Manipulate ▶ Other</td>
<td>Int. by Parts</td>
<td></td>
</tr>
<tr>
<td>Manipulate ▶ Table</td>
<td>Generate</td>
<td></td>
</tr>
<tr>
<td>Manipulate ▶ Table</td>
<td>Integrate Differential Equation</td>
<td>n/a</td>
</tr>
<tr>
<td>Manipulate</td>
<td>ReManipulate Now</td>
<td>n/a</td>
</tr>
</tbody>
</table>
### Macintosh Menu Items and Palette Buttons

<table>
<thead>
<tr>
<th>Manipulate ▶ Manipulation Prefs</th>
<th>Auto Simplify</th>
<th>( n/a )</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manipulate ▶ Manipulation Prefs</td>
<td>Auto Casing</td>
<td>( n/a )</td>
</tr>
<tr>
<td>Graph ▶ ( y = f(x) )</td>
<td>Linear</td>
<td>( \text{\textbf{\Sum}} )</td>
</tr>
<tr>
<td>Graph ▶ ( y = f(x) )</td>
<td>Complex 3D</td>
<td>( n/a )</td>
</tr>
<tr>
<td>Graph ▶ ( z = f(x, y) )</td>
<td>Contour 2D</td>
<td>( \text{\textbf{\Sum}} )</td>
</tr>
<tr>
<td>Graph ▶ ( z = f(x, y) )</td>
<td>Color 3D</td>
<td>( \text{\textbf{\Sum}} )</td>
</tr>
<tr>
<td>Graph ▶ ( z = f(x, y) )</td>
<td>Illum. 3D</td>
<td>( n/a )</td>
</tr>
<tr>
<td>Graph ▶ ( z = f(x, y) )</td>
<td>Spherical 3D</td>
<td>( n/a )</td>
</tr>
<tr>
<td>Graph ▶ ( z = f(x, y) )</td>
<td>Cylindrical 3D</td>
<td>( n/a )</td>
</tr>
<tr>
<td>Graph ▶ Other</td>
<td>Parametric</td>
<td>( \text{\textbf{\Sum}} )</td>
</tr>
<tr>
<td>Graph ▶ Other</td>
<td>Space Curve</td>
<td>( n/a )</td>
</tr>
<tr>
<td>Graph ▶ Other</td>
<td>Implicit</td>
<td>( n/a )</td>
</tr>
<tr>
<td>Graph ▶ Scatter</td>
<td>Linear</td>
<td>( \text{\textbf{\Sum}} )</td>
</tr>
<tr>
<td>Graph ▶ Additional</td>
<td>Add Line Plot</td>
<td>( n/a )</td>
</tr>
<tr>
<td>Graph ▶ Additional</td>
<td>Add Scatter Plot</td>
<td>( n/a )</td>
</tr>
<tr>
<td>Graph ▶ Animation</td>
<td>Start</td>
<td>( n/a )</td>
</tr>
</tbody>
</table>
## Constructs

<table>
<thead>
<tr>
<th>Construct</th>
<th>Palette Button</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>? [ ?</td>
<td><img src="image" alt="Palette Button" /></td>
<td>#</td>
</tr>
<tr>
<td>( \sum ? )</td>
<td><img src="image" alt="Palette Button" /></td>
<td>@</td>
</tr>
<tr>
<td>( ? )</td>
<td><img src="image" alt="Palette Button" /></td>
<td>$</td>
</tr>
<tr>
<td>( ? \ &amp; ? )</td>
<td><img src="image" alt="Palette Button" /></td>
<td>\text{Option 1} \text{ or } \text{Option 2}</td>
</tr>
<tr>
<td>? \neq ?</td>
<td><img src="image" alt="Palette Button" /></td>
<td>\text{Option 1}</td>
</tr>
<tr>
<td>? \leq ?</td>
<td><img src="image" alt="Palette Button" /></td>
<td>\text{Option 1}</td>
</tr>
<tr>
<td>? \geq ?</td>
<td><img src="image" alt="Palette Button" /></td>
<td>\text{Option 1}</td>
</tr>
<tr>
<td>( \sqrt{?} )</td>
<td><img src="image" alt="Palette Button" /></td>
<td>\text{Option 1} \text{ or } \text{Option 2}</td>
</tr>
</tbody>
</table>
The following tables list the keystrokes to use for menu items and palette buttons, and other editing functions for the Windows platform.

### Windows

#### Keystrokes

<table>
<thead>
<tr>
<th>Menu/Submenu</th>
<th>Menu Item</th>
<th>Palette Button</th>
<th>Keystroke(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>New Notebook</td>
<td>n/a</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>File</td>
<td>Open Notebook</td>
<td>n/a</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>File</td>
<td>Close Notebook</td>
<td>n/a</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>File</td>
<td>Save Notebook</td>
<td>n/a</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>File</td>
<td>Print Notebook</td>
<td>n/a</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>File</td>
<td>Exit</td>
<td>n/a</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Edit</td>
<td>Undo</td>
<td></td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Edit</td>
<td>Cut</td>
<td></td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Edit</td>
<td>Copy</td>
<td></td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Edit</td>
<td>Copy as Picture</td>
<td>n/a</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Edit</td>
<td>Paste</td>
<td></td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Edit</td>
<td>Clear</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit</td>
<td>Select In</td>
<td></td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Edit</td>
<td>Select Out</td>
<td></td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>n/a</td>
<td>n/a</td>
<td></td>
<td></td>
</tr>
<tr>
<td>n/a</td>
<td>n/a</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit</td>
<td>Comment Font</td>
<td>n/a</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Edit ▶ Comment Style</td>
<td>Plain</td>
<td>P</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Edit ▶ Comment Style</td>
<td>Bold</td>
<td>B</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Edit ▶ Comment Style</td>
<td>Italic</td>
<td>I</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Edit ▶ Comment Style</td>
<td>Underline</td>
<td>n/a</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Notebook</td>
<td>Clarify</td>
<td>n/a</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Notebook ▶ Windows Palette</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Appendix</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Notebook</th>
<th>Expose</th>
<th>n/a</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notebook</td>
<td>Collapse</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Indent Left</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Indent Right</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Insert</td>
<td>Page Break</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Insert</td>
<td>Case Theory</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Insert</td>
<td>Transform Rule</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Make Working Stmt</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Stop Working Stmt</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Get Info</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Display Precision</td>
<td>2 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Display Precision</td>
<td>3 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Display Precision</td>
<td>4 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Display Precision</td>
<td>5 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Display Precision</td>
<td>6 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Display Precision</td>
<td>7 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Display Precision</td>
<td>8 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Display Precision</td>
<td>10 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook ► Display Precision</td>
<td>15 digits</td>
<td>n/a</td>
</tr>
<tr>
<td>Notebook</td>
<td>Notebook Font</td>
<td>n/a</td>
</tr>
<tr>
<td>Manipulate</td>
<td>Calculate</td>
<td>f, g</td>
</tr>
<tr>
<td>Manipulate</td>
<td>Simplify</td>
<td>h</td>
</tr>
<tr>
<td>Manipulate</td>
<td>Expand</td>
<td>e</td>
</tr>
<tr>
<td>Manipulate</td>
<td>Collect</td>
<td>d</td>
</tr>
<tr>
<td>Manipulate</td>
<td>Factor</td>
<td>c</td>
</tr>
<tr>
<td>Manipulate</td>
<td>Apply</td>
<td>b</td>
</tr>
<tr>
<td>Manipulate</td>
<td>Transform</td>
<td>a</td>
</tr>
<tr>
<td>Manipulate ► Other</td>
<td>Int. by Parts</td>
<td>c</td>
</tr>
<tr>
<td>Manipulate ► Table</td>
<td>Generate</td>
<td>c</td>
</tr>
<tr>
<td>Manipulate ► Table</td>
<td>Integrate Differential Equation</td>
<td>n/a</td>
</tr>
<tr>
<td>Manipulate</td>
<td>ReManipulate Now</td>
<td>n/a</td>
</tr>
<tr>
<td>Manipulate ▸ Manipulation Prefs</td>
<td>Auto Simplify</td>
<td>n/a</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------</td>
<td>-----</td>
</tr>
<tr>
<td>Manipulate ▸ Manipulation Prefs</td>
<td>Auto Casing</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ y = f(x)</td>
<td>Linear</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ y = f(x)</td>
<td>Complex 3D</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ z = f(x, y)</td>
<td>Contour 2D</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ z = f(x, y)</td>
<td>Color 3D</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ z = f(x, y)</td>
<td>Illum. 3D</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ z = f(x, y)</td>
<td>Spherical 3D</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ z = f(x, y)</td>
<td>Cylindrical 3D</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ Other</td>
<td>Parametric</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ Other</td>
<td>Space Curve</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ Other</td>
<td>Implicit</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ Scatter</td>
<td>Linear</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ Additional</td>
<td>Add Line Plot</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ Additional</td>
<td>Add Scatter Plot</td>
<td>n/a</td>
</tr>
<tr>
<td>Graph ▸ Animation</td>
<td>Start</td>
<td>n/a</td>
</tr>
</tbody>
</table>
## Appendix

### Constructs

<table>
<thead>
<tr>
<th>Construct</th>
<th>Palette Button</th>
<th>Keystroke(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td><img src="image" alt="Palette Button" /></td>
<td>#</td>
</tr>
<tr>
<td>Σ</td>
<td><img src="image" alt="Palette Button" /></td>
<td>@</td>
</tr>
<tr>
<td>∫</td>
<td><img src="image" alt="Palette Button" /></td>
<td>$</td>
</tr>
<tr>
<td>∫ ?</td>
<td><img src="image" alt="Palette Button" /></td>
<td>or $</td>
</tr>
<tr>
<td>? ≠ ?</td>
<td><img src="image" alt="Palette Button" /></td>
<td>= or =</td>
</tr>
<tr>
<td>? ≤ ?</td>
<td><img src="image" alt="Palette Button" /></td>
<td>= or =</td>
</tr>
<tr>
<td>? ≥ ?</td>
<td><img src="image" alt="Palette Button" /></td>
<td>= or =</td>
</tr>
<tr>
<td>√ ?</td>
<td><img src="image" alt="Palette Button" /></td>
<td>or \</td>
</tr>
</tbody>
</table>
MathView and the Internet

Using your Internet web-browser you can view and manipulate, to a certain degree, actual MathView notebooks. Not only can you view these notebooks, you can create your own web-pages with embedded MathView notebooks, if you own the full version of the product. In this section you will learn how to create a simple example using MathView’s web-browser Plug-in. In addition, two Internet addresses are listed to guide you to current information about this exciting new technology.

There are two parts to MathView’s link to the Internet. First is the MathView Internet Plug-in, which allows you to view your own notebooks which you create for the Internet, as well as view other people’s web-pages. Second is the VRML image files which MathView can create for you to explore with third-party viewers.

Browsers and Plug-ins

To explore the world-wide web, you use a program called a browser. The following browsers are compatible with the MathView Plug-in, MathView Internet.

- Netscape Navigator version 2.0 or later
- Microsoft Internet Explorer version 3.0 (Win) or version 2.0 (Mac)
- Apple Cyberdog (included with the Macintosh CD)

These browsers all support plug-ins. Plug-ins are small programs that run inside your browser to display different kinds of data.

You may already be using one of these browsers. If not, you can install Internet Explorer (Windows) or Cyberdog (Macintosh) directly from the MathView CD. Or, if you prefer Netscape Navigator, you can download a copy from http://www.netscape.com/.

MathView Internet

The first thing you must do is obtain and load the MathView Plug-in on your computer. The installer is located on your MathView CD and is called MathView Internet Installer. You can also download this file by going directly to Waterloo Maple’s web site, http://www.mathview.com/. Once there, you will be guided to the correct file and directions for its use depending upon the platform you are using.

The Plug-in was developed for use with the plug-in savvy browsers mentioned previously. Once you have the plug-in up and running on your computer, you do not need the MathView program to view MathView notebooks on the Internet. If you use another browser that does not use the plug-in technology, you must have the actual MathView program configured as a “helper” application.

Before you try making your own web-page, you may find it useful to look at several pages already on the Cybermath web-site (http://www.cybermath.com/). Try viewing the source for some of the pages to see how they are written.

Notice that once you are at the site of one of the examples, you can view and manipulate, to a certain degree, the actual equations and graphs. These manipulations are limited, however, to changing equations and controlling the
Appendix

Viewport of graphs. For example, you find out through experimentation that you can change an existing assumption causing pre-existing conclusions and graphs to remanipulate and redraw.

You cannot enter new equations, comments, transformations rules, or other Props. You cannot create new graphs, nor can you augment existing graphs. You can control graphs by rotating and spinning them, if 3-D; panning them, if 2-D; and you can control the Viewport by using the graph icons attached to the graph. You can start and stop animations, and you can change the range, increment, and number of frames to animate. Conclusions and graphs must already be in the notebook and their exact behavior depends on the way these hotwired components were originally authored. There is, however, no limit to the complexity of the notebook. Finally, you can save the notebook to your computer where you can open it with MathView. Once opened, you can edit and manipulate the equations and graphs as if you authored them yourself.

Now that you have a feel for the Plug-in, the next example will walk you through the authoring of your own MathView enriched web-page.

Personal Web Pages

The following example assumes you have a basic understanding of the Internet. If you have no experience creating your own web-pages, you should obtain one of the excellent books available on the subject. Alternatively, many Internet service providers offer information and instruction on how to author web pages through their home pages.

To create your own personal web-page you should first contact a local internet provider to sign up for this service, if you do not have access through your system. If you do not have a personal page, but want to see how MathView's plug-in works, do not worry; you do not have to be signed up to experiment. All you do is create an HTML document and load it into your web-browser as a file. It will look just as if you were linked to the Internet directly, except other people will not be able to see your pages.

You will use the polynomial example found on page 107 for this example.

- Recreate the polynomial example in a new notebook. The example is reprinted below.

You should use a common font, like the Courier font used above. Other good fonts to use are Helvetica and Times Roman. Most web users have one of these fonts on their computers.
MathView and the Internet

- **Save** the `MathView` file as NetExpl.thp

   This step is important. You must add the extension `.thp` to the name of any `MathView` notebook you want to embed into your web-page. The name you give before the .thp is up to you but should not include any spaces.

- Use a web authoring program if you have one, or use an editor that can save as a text file, and copy, exactly, the file below.

- **Save** the document, at the same file level as the .thp document, with the name NetExpl.html (or netexpl.htm under Windows 3.1).

   It is important that you name the file with the .html (or .htm) extension and that it is located at the same file level as the .thp file.

- Go to the `MathView` document and choose **Edit ▶ Copy HTML Tag**.

   This action copies the information your web-browser needs to embed the notebook.

- **Paste** this information into your HTML document at the location shown above. If you are using a web-editing program to create the document, consult the editor’s documentation to learn how to insert a tag. The document will now look like the following.

- **Save** the file.

   You are ready to view your notebook in your web-browser.

- Open your web-browser and choose **File ▶ Open File**.

- Locate the HTML file on your disk and open it.

   Your web-browser will load the `MathView` Plug-in and open the file. Your browser

---

You do not have to select anything prior to copying the HTML tag. Just be inside your notebook — `MathView` knows what to copy.

If you already have Netscape open while you load the helper applications, you must first close the program down and re-open to activate the plug-in.
window will look like the following, with your notebook embedded within.

To test the interactivity of your page, change one or more of the values assigned to the coefficients and adjust the viewport using the graph icons. If you have a personal web-site, you may place the files on your server and anyone, as long as they have the MathView plug-in on their computer and an Internet account, will be able to view and manipulate the page in the same fashion you have just done.

Keep in mind that you must have your web master or service provider configure your site according to Waterloo Maple’s requirements. Over the web, MathView plug-in files are identified by the mime type “plugin/x-theorist”. Your web-server administrator must add the following information to the server configuration according to the instructions provided by the web-server manufacturer. You can find these configuration details at http://www.mathview.com/.

VRML

You can also embed and view VRML (Virtual Reality Modeling Language) 3-D images you create in MathView.

The files you need on your computer to view VRML documents are found on your MathView CD. You can also download them from several web sites. Below is a description of the downloading procedure for the Macintosh.

- Connect to Waterloo Maple’s web-site and download a VRML viewer install-file appropriate for your platform (Macintosh, Windows 3.1, Windows 95 or Windows NT). Expand the downloaded file by double-clicking on its icon.
- Install the VRML viewer according to the instructions which accompany it.
- In your web-browser under Options, choose General Preferences... and click on the “Helpers” tab.

VRML

The Windows installer will place all of the files in the appropriate locations on your disk.

If using a Macintosh, you must be running System 7.5.3 or newer for most VRML viewers to work properly.
• Locate the MIME type “x-world/x-vrml” and set the options as appropriate for your VRML viewer.
• Quit your web-browser and restart it to activate the plug-in.

Before you create your own VRML image, you may wish to go to the web site listed below these instructions and view some sample VRML images.

• Create your own image by generating a 3-D graph in MathView. Make the Graph Theory as large as you can on your monitor, choosing the colors and Viewport to your liking.
• When you have completed the graph choose Graph ➤ Generate VRML File... to save the MathView file. Name the file with the extension .wrl.
• Open your web-browser and choose File ➤ Open file.... Navigate to the .wrl file you just created in MathView and click OK. The browser will load your file and open your VRML Viewer.
• Manipulate the image. If you need help, click on the question mark at the bottom of the screen.

There are some differences between 3-D images you create in MathView and those translated into VRML documents. There will be no axes, gridlines, scatterplot markers, or contours. In addition, there will be no mesh lines for surfaces and illumination is not the same as in MathView. It does, however, take into account the optical pop-up on the first surface.

To place a VRML image into your own web-page requires you to place a “hypertext reference” in your HTML document. Unlike MathView notebooks and 2-D/3-D images that you embed into your HTML document and view using the MathView Internet plug-in, you can view VRML files using numerous 3-D viewers. This fact requires a more universal method of linking your HTML document to the VRML file.

The following is an example of a hypertext tag that you have in your HTML document. The tag below links the page to a VRML file called Seashell.wrl, located at the same file level as the main HTML document. When someone clicks on the name Yellow Seashell, the web-browser opens the file “Seashell.wrl” using their VRML viewer.

    <A HREF= "Seashell.wrl" > Yellow Seashell </A>

To help you understand these new MathView capabilities, and to keep current with the technology, make the following bookmarks in your browser. These sites will be your source for current information and instruction on this exciting addition to MathView.

• http://www.mathview.com/
• http://www.cybermath.com/
Appendix

Divert Cascade

On occasion you may take an action which causes an error message similar to the following.

*Cannot ReManipulate this Conclusion: There is an error in one of the equations it depends upon. You may be able to redo that step and connect the result to this result with Divert Cascade.*

or

*Cannot ReManipulate this Conclusion: The expression no longer matches the pattern in the Transformation rule. You may be able to redo that step and connect the result to this result with Divert Cascade.*

The first message indicates a break in the chain of manipulations in a Theory. It sometimes is created when an assumption which was used for a substitution is inadvertently deleted. Rather than delete the whole Theory and start over, *MathView* has the **Divert Cascade** manipulation to help you. The following simple example demonstrates how you use this feature.

- Enter the following two Props.
  
  \[
  \begin{align*}
  y &= \sin(x) \\
  x &= \frac{1}{2}
  \end{align*}
  \]

- **Substitute** the \( x \) Prop into the \( y \) Prop and **Calculate** the RHS.
  
  \[
  \begin{align*}
  y &= \sin(x) \\
  \triangle y &= \sin\left(\frac{1}{2}\right) \quad \text{Substitute} \\
  \triangle y &= 0.47943 \quad \text{Calculate} \\
  x &= \frac{1}{2}
  \end{align*}
  \]

- Delete the \( x = \frac{1}{2} \) Prop.

  \[
  \begin{align*}
  y &= \sin(x) \\
  \triangle y &= \sin\left(\frac{1}{2}\right) \quad \text{Conclusion Prop turns into an Assumption Prop.} \\
  \triangle y &= 0.47943 \quad \text{Calculate}
  \end{align*}
  \]

You have created a situation where the Theory has no equation to base the manipulation on, so the first conclusion in the cascade turns into an assumption.

- Create a new Prop re-defining the substitution assumption. Change the value of \( x \) so you will be able to distinguish the **Divert Cascade** manipulation from the original substitution. This example uses \( x = \frac{3}{2} \).
- **Substitute** this new assumption into the first Prop. This action redoes the original substitution, generating a new conclusion below the old ones.

  \[
  \Delta y = \sin\left(\frac{\pi}{2}\right) = 0.47943 \\
  x = \frac{3}{2}
  \]

- Hold the Shift key down and select the Conclusion Prop with the first occurrence of the error message, or in the case of no error message, the Conclusion Prop that changed to an Assumption Prop. This action selects both the new conclusion and the cascade of manipulations which was broken when you deleted the \(x = 1/2\) Prop.

  \[
  \Delta y = \sin\left(\frac{3}{2}\right) \\
  \Delta y = 0.47943 \\
  x = \frac{3}{2}
  \]

- Choose **Manipulation ▶ Divert Cascade**.

  \[
  \Delta y = \sin\left(\frac{\pi}{2}\right) \\
  \Delta y = 0.99749 \\
  x = \frac{3}{2}
  \]

MathView has established a link between the new assumption, \(x = 3/2\), and the old cascade. The old Prop remains as a reference for you. You can now delete it.

  \[
  \Delta y = \sin\left(\frac{\pi}{2}\right) \\
  \Delta y = 0.99749 \\
  x = \frac{3}{2}
  \]

The second error message, shown at the beginning of this section, may have been generated under the following circumstance. You may have made a substitution in the original manipulation and then performed a transformation on the conclusion.
Appendix

You then changed the original substitution equation creating a situation where the original transformation would not work with the new substitution. A simple explanation would be that the new expression, which you created by the new substitution, did not have a matching transformation rule. Without a rule, all subsequent manipulations had no bases.

To fix these types of errors requires you to find a new transformation that works for the expression, just prior to the Prop where the error occurred. Once you have done this, you select (with a Shift-click) both the new conclusion and the Prop first containing the error message. Then you choose Divert Cascade. An example demonstrates.

- Enter the following Prop, select the equation, and Apply.

\[
\begin{align*}
\Box \sin(2x) &= \tan(x) \\
\triangle \sin(2x) &= \tan(x)
\end{align*}
\]

- Transform the equation by choosing Manipulate ▶ Transform. Choose the middle choice for the transform.

\[
\begin{align*}
\Box \sin(2x) &= \tan(x) \\
\triangle \sin(2x) &= \tan(x) \\
\triangle 2\cos(x)\sin(x) &= \frac{\sin(x)}{\cos(x)} \quad \text{Apply} \\
\triangle 2\cos^2(x)\sin(x) &= \sin(x) \quad \text{Transform Transform}
\end{align*}
\]

- Manipulate the equation by first moving the \(\cos(x)\) on the RHS over to the LHS and then moving the \(\sin(x)\) on the LHS over to the RHS.

\[
\begin{align*}
\Box \sin(2x) &= \tan(x) \\
\triangle \sin(2x) &= \tan(x) \quad \text{Apply} \\
\triangle 2\cos(x)\sin(x) &= \sin(x) \quad \text{Transform Transform} \\
\triangle 2\cos^2(x)\sin(x) &= \sin(x) \quad \text{Move Over} \\
\triangle 2\cos^2(x) &= 1 \quad \text{Move Over}
\end{align*}
\]

- Solve the equation by isolating \(x\).

\[
\begin{align*}
\Box \sin(2x) &= \tan(x) \\
\triangle \sin(2x) &= \tan(x) \quad \text{Apply} \\
\triangle 2\cos(x)\sin(x) &= \sin(x) \quad \text{Transform Transform} \\
\triangle 2\cos^2(x)\sin(x) &= \sin(x) \quad \text{Move Over} \\
\triangle 2\cos^2(x) &= 1 \quad \text{Move Over} \\
\triangle x &= \frac{1}{4}\pi \quad \text{Isolate}
\end{align*}
\]

- Change the original assumption by turning the equation into a hyperbolic equation. Click to the right of the \(n\) in both expressions and type an \(h\).
Divert Cascade

The errors occur because the Transformation Rule that you applied to the original equation does not apply to the new equation.

- Select the original equation, Apply, and perform another transformation, choosing the non-exponential transforms. There will be two transformations. The new conclusion will appear at the bottom of the bad cascade.

- Select the last Prop generated (click on the Prop icon) and Shift-click the first bad Prop in the original cascade.

The notebook you are using does not have the Transformation Rule tanh(x) ▷ sinh(x)/cosh(x); create it prior to doing this example. See page 64 for instruction.
Appendix

You may be asked to PreDefine one or more functions during the Divert Cascade manipulation.

- Choose **Manipulate ➤ Divert Cascade**.

\[
\begin{align*}
\text{Apply} & \quad \sinh(2x) = \tanh(x) \\
\triangle \quad \sinh(2x) = \tanh(x) & \\
\text{Transform Transform Apply} & \quad 2\cosh(x)\sinh(x) = \frac{\sinh(x)}{\cosh(x)} \\
\triangle 2(\cosh(x))^2\sinh(x) = \sinh(x) & \\
\text{Move Over} & \quad 2(\cosh(x))^2 = 1 \\
\triangle x = -\frac{1}{4} \pi i & \\
\text{Isolate} & \\
\text{Apply} & \quad \sinh(2x) = \tanh(x)
\end{align*}
\]

*MathView* corrects the error and ReManipulates the cascade. You may remove the last conclusion, as it is not necessary now.
Break Cascade

With the advent of version 2.5, two menu choices were added to MathView to help you in your manipulations, Break Cascade Above and Break Cascade Below. Both commands allow you to break a cascade of conclusions into two separate cascades, without losing dependencies. The best way to learn this feature is by trying out an example.

The following example analyzes the error between an actual equation and the Taylor approximation to that equation using Break Cascade Above.

- Enter \( y = \sin(x) \) select the RHS and choose Manipulate \( \Rightarrow \) Other \( \Rightarrow \) Taylor Series.
- When the dialog box opens choose the variable \( a \) as the expansion point and enter 4 as the highest order term. MathView will default to a polynomial in the variable \( x \).

A large equation results.

- Enter a new Prop defining the expansion point of \( a=3 \) and substitute it into the Taylor equation (first conclusion) and Calculate and then Expand the RHS.

Because of the size of the equations, the screen shot has cut off the far right of the Conclusions.

- Right under the last conclusion, enter the equation \( y' = \sin(x) \)
- Enter a new Prop under the a Prop giving a value to \( x \) and substitute into both the Taylor and the sine equations. Select the RHS of both and Calculate.

Because of the size of the equations, the screen shot has cut off the far right of the Conclusions.

\[ y = \sin(x) \]
\[ y' = \sin(x) \]
\[ y' = \sin(x) \]
\[ y' = \sin(x) \]
\[ y' = \sin(x) \]
Appendix

Now, say you want to study the error between the Taylor equation and the sine function at the expansion point 3, but do not want the intermediate Taylor manipulations to show as part of the analysis.

Select the Taylor Conclusion and select Manipulation ▶ Break Cascade Above.

The link between the Taylor equation and the Prop is broken because the substitution of the a Prop occurred above the Break Cascade.

You may want to graph both the sine function and the Taylor approximation in the same Graph Theory.

Notice that the Prop chosen to Break the Cascade is where you substituted x.

Notice how the Taylor Conclusion turns into an Assumption. Your notebook would look the same if you would have selected the Conclusion and did a Copy/Paste; however, Break Cascade Above preserves the link with the x = 1 substitution while the Copy / Paste does not. Now you can change the value of x and the final values will still change.

- Move the two subject cascades below the x Prop, collapse the first Prop, and change the value of x to 6. In the screen shot below, an Error equation is added to the notebook. Set it up as shown below, substitute the values for y and y' into the RHS, and Calculate.

Break Cascade Below does the same thing as Break Cascade Above except that the cascade is broken below the selected Prop.
Frequently Asked Questions

*MathView* has been on the market in various forms for over six years. The manuals and learning guides of earlier versions tried their best to answer all of the questions users had about the program. There are times, however, when manuals fail to do an adequate job of explaining various features. The following list of frequently asked questions comes from the technical support staff at Waterloo Maple. They represent the questions most frequently asked of the staff.

After each question is a short answer followed by page references to areas in the guide where the subject is discussed further. The questions are not in order of frequency.

1) **How can I print a notebook without having the icons displayed?**
   Choose *Never* or *Unless Printing* under the *Notebook ▶ Preferences ▶ Show Icons* menu. See page 30.

2) **How can I save new declarations in a MathView worksheet?**
   Create the name declaration and choose *Save* under the *File* menu. Saving the notebook saves any new declaration you have created since the last save. See page 62.

3) **How can I paste MathView equations into a word processor?**
   To paste a *MathView* equation to a word processing document in “real” math notation (page 2), select the equation and choose *Copy as Picture* under the *Edit* menu. Go to your word processor and Paste. See page 36.

4) **How can I change the sign of an expression in my notebook?**
   Select the term (or expression) and type a negative sign or click on the negation palette icon. See page 44.

5) **How can I change the alignment, color, or font of a comment?**
   You control individual characteristics by selecting the text and choosing the appropriate command under the *Edit* menu, or by selecting the characteristic under the Comment palette pop-up menu. To change the style of all comments, choose *Comment font...* under the *Edit* menu. See pages 14, 35, and 36.

6) **How can I add a line or surface plot to an existing graph?**
   Select the graph and choose *Add Line Plot* or *Add Surface Plot* under the *Graph ▶ Additional* menu. See pages 76 and 80.

7) **How do I switch between the two palettes?**
   Click on the large *x* when on the Variables palette to switch to the Function palette. Click on the large *f(x)* when on the Function palette to switch to the Variable palette. See page 15.

8) **How can I obtain both roots of a quadratic equation?**
   Select all occurrences of the independent variable and *Isolate* with *Auto Casing* on. See page 68 and Quadratic Functions starting on page 104.

9) **How can I change the color or location of the axes in a graph?**
   Click on the details icon to the right of the graph and then open the Declarations Prop by double-clicking on the balloon icon that is within the
graph details area. Change the individual items in the axes details. You can change the default axes color by choosing **Graph Preferences** under the **Graph** menu. See Graph Labels starting on page 73.

**10) How do I do an animation in MathView?**
Select an animation variable and choose **Animation ➤ Start** under the **Graph** menu. See Animating a Graph on page 80.

**11) How do I create my own “default” notebooks?**
You change the default notebook by configuring your opened notebook the way you want and saving using **Save As** with the name **New Notebook** (Mac) or **newnote.the** (Win) to the directory where the MathView program is located. The next time you open MathView by double-clicking on its program icon, by double-clicking on the document icon called **New Notebook** (Mac) or **newnote.the** (Win), or by selecting New Notebook from the File menu, the newly configured notebook will open as the default. To create special “Custom” notebooks, you create a notebook configured the way you want and **Save As** with a name of your choice. The next time you open this notebook by double-clicking on its icon or by opening it from within MathView, it will open with this custom configuration. See page 28.

**12) How do I send a notebook to a friend using a different platform?**
If you use a Macintosh, initialize a disk in DOS format (a feature available with System 7), name the notebook in DOS format: use an eight character name and the three character extension “.the”. Copy the notebook to the newly initialized disk. Your friend will copy the file to his or her Windows machine and open it by double-clicking or by opening within MathView by choosing **Open** from the **File** menu.
If you use a Windows machine, copy the notebook to a DOS formatted disk and give it to your friend. To open a Windows notebook from within MathView, choose **Open** from the **File** menu and select the notebook. MathView will open the file. Use **Save as...** from the **File** menu to save in Macintosh format. System 7 reads DOS formatted disks. Your friend will insert the disk into his/her Macintosh and copy the notebook to the hard drive.

**13) How do I send a notebook to a friend via e-mail?**
**Partial Notebooks:** You can send propositions or nested propositions, by selecting the Prop and choosing **Copy** from the **Edit** menu (not **Copy as Picture**). Paste the material into the body of the e-mail message. The expression will appear in a special format. For example, the Assumption Prop \( y = \sin(x) \) will look like the following: \(~A(y=\sin(x))\sim p0 0 ~d\). Your friend copies this funny-looking text from the e-mail message and pastes it directly into his or her notebook.
**Complete Notebooks:** You can send an entire MathView notebook. First, save the notebook by choosing **Save** from the **File** menu. MathView notebooks are stored in text format that can easily be moved from computer to computer. Send the resulting file as an attachment to an e-mail message if your e-mail system supports this option. If your e-mail system or the receiving e-mail system does not accept attachments, open the MathView notebook in a text editor, then copy and paste the entire contents of the notebook into the body of the e-mail message. The receiver can save the
e-mail message as a text file and delete any e-mail headers using a text editor. He or she can then open the text file by choosing **Open** from the **File** menu.

14) **How do relational operators work in MathView?**

*MathView* does not support relational manipulation. In other words, you cannot enter a relation and **Isolate** a variable or generate a linear plot, as in graphing an inequality. If you enter a relation, select, and **Calculate**, *MathView* will return a 1 if the relation is true, or a 0 if it is false. You may use relations to generate piecewise functions and graphs (page 133). Below is an example.

\[
\begin{align*}
\text{if } (x) &= \begin{cases} 
\text{x} & (x < 0) \\
\text{x}^2 & (x \geq 0) 
\end{cases} \\
y &= f(x)
\end{align*}
\]

Below is an example.
Index
Symbols
! 37
- 38, 43
$ 25
() 39
* 13
*# 91
*@ 92
+ 37
, 86, 93
/ 37
? 16, 65
^ 24
_ 94
() 39

Numerics
2-D plots 70
3-D plots 135

A
absolute value example 133
Add contour plot 135
Add line plot 22, 76, 129, 225
Add scatter plot 198
Add surface plot 80, 136, 225
adjoint Op 94
Always Redraw 50, 72
Always ReManipulate 50
Animation
  3-D 82
    animation parameter 81
    examples 139, 140, 141
    in a cycle 82
    one-way 82
    saving 141
    speed 82
    stopping 81
anomalies 11
appendices
  Break Cascade 223
  Divert Cascade 218
  frequently asked questions 225
  internet 213
  keystrokes 201
application memory for Macintosh 6
Apply 25, 54, 221
Arbitrary Constants 171
arbitrary names dialog 171
areas between curves 182
Assumption 17, 31, 45

asymptotes 110
Auto Casing 25, 68
Auto Collapsars 29
Auto ReManipulate 50
Auto Simplify 50
AutoSave 29

B
balloon icon 20
blank slots 83, 136, 168, 183
brackets 39
Break Cascade above 223

C
Calculate 47
calculus 23
cancelling process 54
cascade 34, 45
  Break above 223
  Break below 224
  Divert Cascade 218
Case Theories 19, 24, 67–69
  auto casing 68
Clarify 21
Class 62
closing
  Macintosh document 6
  Windows document 10
Collect 51
Command key 12, 201, 202
Command Manipulations 45–56
comment 20, 35
  color 35
  font 35, 225
  proposition 31
  rulers 35
  style 35
common logarithms 117
Commute 58
completing the square 104
complex number conjugate 95
composite functions 131
Conclusions 17, 45
conditional Op 133
conjugate transpose 95
costant of integration 171
constants 62
e 118
  essential 190
i 62

230
pi 171

copy
   as HTML tag 215
   as picture 36, 225
   command line format 36
   multiple selections 41

cross product 91
cycloid 139
cylindrical coordinates 124

D
data analysis 126
daughter propositions 33
declarations 28
   independence 165, 186
Declare Name dialog 100
Definite Integral Op 180
definite integrals 180
Definite Integration 178–182
   numeric integration settings 180
degrees to radians 121
Delete key 32
delta-epsilon 147
derivative Op 24
Derivatives 156–162
   differential Op 158
   higher order 161
   implicit 163
   inputting 156
   more than one variable 165
   numeric 158
   rules of differentiation 158
desktop 14
details icon 21
determinants 91
difference quotient 156
differential 192
Differential Calculus 145–168
Differential Equations 187–200
   differential 25, 192
   essential constants 190
   Euler’s method 197
   explicit solution 188
   first order formula 195
   first order linear 194
   implicit solution 188
   numerical methods 197–200
   Runge-Kutta method 199
   separation of variables 192
   simple integration 190
   testing solutions 188
display precision 116
distribution notebooks 29
Divert Cascade 218
D-Linear Operator 62
dot product 92
E
e 118
Editing Prefs
   Enter key 19
   Fortranish 38
   Palette Autotoggle 38
   Ripple Changes Immediately 50
e-mail
   sending an expression 170
   sharing notebooks 226
Enter key 13, 19, 31, 35
together with equations 38–43
error message
   animation 81
   Divert Cascade 218
Escape key 39
essential constants 190
Euler’s method 197
Evaluate-At 37
together with examples 13
Expand 51
exponential solution 188
exponents 113
   negative integer 115
   positive integer 113
   properties of 113
   rational number 115
Exponents & Logarithms 113–115
F
Factor 53
finding graph roots 19, 105
first order linear equations 194
Fonts
   in comments 35
   in notebook 36
   used in Guide 11
Fortranish 38, 39
Fourier transform 87
Frequently Asked Questions 225
FromPolar(x) 123
Function Palette 15
Functions
   FromCylindrical 124
   FromPolar 123
   FromSpherical 124
ToCylindrical 124
ToPolar 123
ToSpherical 124
functions 62, 98–141
algebra 130
completing the square 104
composite 98
exponential 118
factoring 104
linear 102
logarithmic 118, 119
of two variables 134–??
partial derivative 136
piecewise 133
polynomial 107
PreDefined 100
PreDefined trigonometric 121
quadratic 104
quadratic formula 105
rational 109
round 100
slope 103
trigonometric 121
User Defined 98

Fundamental Theorem of Calculus 181

G
Graph Theories 21, 70–82
3-D graph details 79
3-D knife 79
3-D orientation guide 78
add blank slots 83
add contour plot 135
add grid lines 83
add implicit plot 143
add line plot 22
add surface plot 80, 183
adding axes 83, 149
adding lines to a plot 76
Always Redraw 72
animation 80, 226
animation parameter 81
areas between curves 182
axes 225
axis props 74
changing dependencies 70
cropping 72
defining points 103
details icon 21, 72
finding roots 19, 105
graphing derivatives 162
illuminated 3-D 77, 135
implicit plots 163
knife 71
labels 73
less accuracy button 73, 78
line detail 22, 75
linear 19, 70
log-log 127
more accuracy button 73, 78
parametric 120, 138
plotting external data 80
proportions 72
Redraw Now 72
remove grid lines 135
removing details 75
resolution 73
roots 105
scatter 126
selecting 106
solids of revolution 183
space curves 140
super knife 77
tangent plane 167
three-dimensional 77
two-dimensional 70
variable Viewport 148
Viewport 19
Viewport controls 71
with blank slots 168, 183
Greek palette 179
Guess Working Statements 48

H
hand manipulations 12, 57–61
help 11
higher order derivatives 161
HTML 215

I
i 62
icons
   assumptions 17
   conclusions 17
   palette 15
   side column 12
identities 122
identity matrix 94
implicit differentiation 163
implicit plots 163
implicit solution 188
increasing memory for Macintosh 6
independence declaration 68, 165, 186
indexing a matrix 94
initial value 190
in-line propositions 33
Installing MathView
  Macintosh 4–7
  Windows 8–10
Integrate Differential Equation 197
integration 170–185
  constant of integration 171
  entering definite integrals 178
  fundamental theorem 181
  inputting definite integrals 171
  inputting indefinite integrals 170
  integrand 170
  integration by parts 56, 174
  integration by parts formula 175
  integration tables 172
  method of substitution 173
  multiple integrals 186
  partial fractions 177
  power rule 173
  Riemann sums 178
  selecting integrals 172
intercepts 105
Internet 213
  HTML 215
  MathView web sites 217
  .thp files 215
  VRML 216
  web-browser plug-in 213
  .wrl files 217
inverse Fourier transform 87
Isolate 45, 58
K
key
  delete 32
  enter 19, 31, 35
  escape 39
  return 19, 31, 32
  shift 23, 32, 41, 60
  space 13, 37
  tab 41, 88
keyboard
  actions 13
  entry 38
  Fortranish 38
  maps 201
keystrkes
  Macintosh 203, 205
  Macintosh and Windows 202
  Windows 204, 209
knife 19, 71
L
LHS/RHS 13
limits 146
  by algebraic manipulation 146
  delta-epsilon 147
  using tables 147
line detail 22
linear functions 102
linearization 154
Lock Proposition 108
logarithmic function 119
logarithms 113
  base b 117
  common 117
  natural 117
  properties of 117
log-log plot 127
M
manipulation in place 46
Manipulation Prefs
  Auto Casing 25, 68
  Auto Collapsar 29
  Auto Simplify 50
manipulations 12
  Apply 25, 54
  Break Cascade above 224
  Break Cascade below 224
  Calculate & Uncalculate 47
  Collect 51
  Commute 58
  Commute 58
  Divert Cascade 219
  Expand & MiniExpand 51
  Factor 53
  hand 12, 33, 57
  in place 46
  Isolate 17, 45, 58
  Move Over 58
  portion of expression 47
  Ripple Changes Immediately 50
  Simplify 49
  solve to right side 46
  Substitute 59
  Transform 55
mathematical operators 37
MathView Internet 213
Matrices 88–94
  adjoint Op 94
  conjugate transpose 95
  determinants 91
  indexing 94, 124
  insert row/column indices 94
inverse 89
larger linear systems 93
matrix identity 94
matrix inverse 89
matrix transpose 94
numeric multiplication 89
simple linear systems 92
symbolic operations 89
MiniExpand 51
M-Linear Operator 62, 126
modifying equations 43
Move Over 58
moving a proposition 33
multiple integrals 186
multiple selections 41
multiplication Op 13
using space bar 32, 37, 38, 107

N
Name 62
constant 62
declarations 62
D-linear operator 62
function 62
M-linear operator 62
PreDefined 63
User Defined 62
variable 62
natural exponential function 118
natural logarithms 117
negative integer exponents 115
new notebooks
  New Notebook (Mac) 29
  Newnote.the (Win) 29
Notebook Preferences
  Show Icons 30
Notebook Prefs
  Comment Rulers 35
  Show Steps 17, 45
notebooks
  Auto Collapsars 29
  AutoSave 29
custom 29, 226
default 28
distribution 29
font 36
new 28
New Notebook (Mac) 226
Newnote.the (Win) 226
printing 29
Revert to Saved 29
saving 29
sharing 226
structure 32
Notebooks Disk 6
notebooks font 20
notes 13
numeric derivatives 158
Numerical 197
Numerical Analysis 197–200

O
opening new notebook
  Macintosh 15
  Windows 28
Operator 37
  a+b 37
  a=b 16
  adjoint 94
column 93
  conditional 133
cross product 91
definite integral 180
derivative 24, 156, 157
differential 158
division 37
D-Linear 62
dot product 92
evaluate-at 37, 181
exponential 113
factorial 37
index 94
integral 25
integration 170, 178
logarithm base b 117
logarithms 117
matrix 93
M-Linear 126
multiplication 32
negation 43
parenthesis 39
partial derivative 156
Pi product 37
relational 37, 227
row 93
selection tools 41
square root 55
subtraction 43
summation 37, 41, 178

P
palette
  autotoggle 38
entry 38
Function 15
hiding 40
switching between 225
Variable 15
palette icons
a+b pop-up 54
absolute value 133
apply 25
balloon comment 20
calculate 47
collect 51
conditional Op 133
copy 17
definite integral 178
derivative 24edit 17
evaluate-at 37
factor 18
graphs 70
Greek letters 179
indefinite integral 170
Int. by Parts 175
isolate 45
matrix 88
partial derivative Op 157
paste 17
piecewise functions 133
selection tools 41
simplify 49
square root 62
subscript 117
substitute 23
summation Op 178
superscript 16, 113
table 21
transform 55
undo 106
parametric plots 120, 138
Parametrized Curves & Polar Coordinates 138–141
Parenthesis 39
partial derivatives 136
partial fractions 111
personal web pages 214
Personalizing
Macintosh 5
Windows 9
pi 171
piecewise functions 133
plotting external data 80
Plug-in 213
polar coordinates 123, 138
polar plots 140
polynomial functions 107
positive integer exponents 113
PreDefined
functions 100
names 63
trigonometric functions 121
Preferences
Editing 19, 38, 40
Manipulation 12, 25
Notebook 17, 24, 30
printing 30
printing
Case Theories 30
header 30
notebooks 29
preferences 30
without icons 30
process, cancel 54
properties of exponents 113
properties of logarithms 117
proposition
Prop as abbreviation 16
propositions 31
Q
Quadratic 105
Quadratic Functions 104–106
R
radians 121
RAM required
Macintosh 4
Windows 8
Rational Functions 109–112
finding asymptotes 110
partial fractions 111
rational number exponents 115
real mathematical notation 2
rectangular coordinates 123
Redraw Now 72
relational Ops 227
Return key 13, 19, 31, 32
RHS/LHS 13
Riemann sums 178
Ripple Changes Immediately 50
Rocket ship 19, 71
roots 105, 225
Row/Column Number 94
ruler 20
rules of differentiation 158
Runge-Kutta method 199

S
saving an animation 141
Scatter Plots & Data Analysis 126–129
scientific notation 116
screen shots 11
secant lines 152
Select 16
Selection Tools 41
   Select First 42
   Select In 41
   Select Next 42
   Select Out 42
   Select Prop 42
selections
   multiple 41
   Shift-clicking 41
Separation of Variables 192
Shift key 23, 32, 41, 60
Show Icons 30, 225
Show Steps 17, 45
simple linear systems 92
Simplify 49
Slope 151–155
   secant lines 152
   tangent lines 153
   using Taylor series 154
slope 103
solids of revolution 183
solve to the right side 46
solving equations graphically 142–143
solving simultaneous equations 92, 142
space curves 140
Space key 13, 37
spherical coordinates 124
starting application
   Macintosh 6
   Windows 10
Statement 31, 45
   transformation rule 64
   working 48
stop process 54

subscript 117
Substitute 23, 59
   with variable on RHS 61
summation Op 41
Super Knife 77
System font
   Macintosh 4
   Windows 8
System Requirements
   Macintosh 4
   Windows 8

T
Tab key 41, 88
Tables 21, 84–87
   complex 85
   details 22, 85
   differential equation 87
   examples 119, 147
   exporting data 87
   Fourier transform 87
   importing data 86
   integrate differential equation 197
   other types 87
   snapshot 84
   types 84
tangent lines 153
tangent plane 167
Taylor polynomials 108
Taylor series 56, 154, 223
Teacher’s Note 13
   Fundamental Theorem of Calculus 182
   integration by parts 176
   limits 150
   order of operations 40
   partial fractions 112
   Taylor polynomials 108
Theory 12, 31
.thp files 215
three-dimensional graphs 77
ToPolar(x) 123
traces 136
Transformation Rules 62, 64
   examples 123, 220
   transform 55
Trigonometric Functions 121–125
trigonometric identities 122
two-dimensional graphs 70

U
UnCalculate 47, 49, 106
Undo 19, 106
User Defined function 21
examples of 98, 122
User Defined Names 62

V
Variable Palette 15
variables 62
subscripted 103
wildcard 64, 166
Viewport 19
VRML 216

W
Wildcard Variables 64, 98, 130, 166
with blank slots 83, 136, 168, 183
Working Statement 48
Guess Working Statements 48
.wrl files 217

Z
zoom in 71
knife 19
rocket ship 21, 71
super knife 77
zoom out 71
rocket ship 19, 71