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What’s New in 3.6?
New features have dribbled into LiveMath
over the past decade(s). With this new
LiveMath 3.6, we here highlight some of
the new features to look out for in this
minor update version.

.6

19.1 LiveMath Plug-In is Retired
With some regrets, LiveMath Plug-In has been retired.
The overall problem with plug-ins is the new (and it is about time!)
focus on browser security. Plug-ins, by their very nature, are programs
in their own right that could be doing some very nasty things to your
computer once installed, as can happen when installing any program.
The browsers have really clamped down on security, as you can see
from the near weekly updates of Flash and Java, and their frequent
disabling by Apple and Microsoft.
The “Netscape Plug-in API” has never been updated since 1998. It
is horrible. The LiveMath Plug-In was continually in a “let’s try this
example over here” to try to get it to work, and it never really did very
well. With every new browser release of Firefox, Chrome, and Safari,
the LiveMath Plug-In would break. We just couldn’t keep up with the
maintenance required.
On the Windows side there are 2 plugins, of course: the Active-X
control for Internet Explorer, now Edge on Windows 10, and the
Netscape-based plugin for all of the other browsers (that support
plugins).
On the Mac side, the browsers all made their move to 64-bit-based
binaries, and LiveMath is still built upon the older 32-bit technologies
(QuickDraw). So that just in and of itself sunk the Mac side.
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The commerical side of LiveMath Plug-In never materialized, either.
We made a lot of “textbook websites” for various publishers over
the initial years of LiveMath Plug-In, but that development did not
continue. We had “Viewer-type” restrictions in LiveMath Plug-In
which allowed you to interact with preset equations and computations
and graphs to achieve the “LiveExample” goal. Yet, aside from us and
a few academics, few used the LiveMath Plug-In.
So, for a web presence for LiveMath, we will return to links from
webpages into LiveMath Maker. You can “teach” the web browser
to launch LiveMath when you try to open a “.the” file - and you may
reteach the browsers to do the same for the formerly Plug-In files with
“.thp” file extensions.

19.2 Larger Palette
Screencast Video

http://www.LiveMath.com/v/1902

Way back in the year 2000, the LiveMath palette seemed enormous
with a width of 500 pixels. “It’s too big” many screamed! The deluxe
screensize of the day was a whopping 640x480 pixels.
Fast-forward to 2017 and screens are commonly 1500-2000 pixels
wide and beyond; the smaller icons just don’t fit the bill.
Some like the smaller button size, as they may only use the palette
once in a while. But others, especially on Windows 10 and its crazy
way it deals with screen resolution (dpi), a larger palette option is
required.
While a stretchable palette is not possible given the older technology
on both the Mac and Windows sides, we did a simple double enlargement to the new Large Palette options, with the width of the palette
now at 1000 pixels:
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Small Full Palette: 500 pixels wide

Large Full Palette: 1000 pixels wide
The Large palettes also use a new version of the artwork: vector-based
artwork that was commissioned for LiveMath 4.0, but I stole it over
for this intermediate LiveMath 3.6 release, mainly because the older
artwork was not in vector format, so it could not be enlarged.
Both the Full and Skinny palette options remain, so now there are 4
palette options:
		
		
		
		

(Small) Full Palette
(Small) Skinny Palette
Large Full Palette
Large Skinny Palette

The small palette is (primarily) made of buttons that are 24x24 pixels.
The new larger palette is (primarily) made of buttons that are 48x48
pixels.
Remember you may hold the mouse over a button, and then hold down
the Mac: B or Win: C keys to have a text help bubble appear
that describes the button.
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19.3 New Menus
Screencast Video

http://www.LiveMath.com/v/1903

A new feature of LiveMath 3.6 is a redesigned menu structure.
The new menus are yet another feature stolen from the LiveMath 4.0
development, as I just got sick of using the old LiveMath 3.5 menus.
On the Mac side, we have new graphical feature: menus commands
that correspond to palette buttons have those palette buttons in the
menu. Maybe these menu icons will get into the Windows version in a
future update, but for now this is a Mac-only version.
Let’s take a look at the new menus.
File Menu

The File Menu is nearly unchanged, with the exception of
Show Page Breaks, which is explained in §19.8.
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Page 604

In addition to the menu icons, the Edit menu has been cleaned up. Of
significance are the new features:
•

Copy for PrintMath
You may select an object in LiveMath, use Copy for
PrintMath, and then go over to PrintMath and paste
- if the object is something that PrintMath can handle
(and work with), like integrals and math expressions, it
will take the paste and you can edit. If you try this with
a graph or something similar, then of course PrintMath
does not know how to deal with this.

•

Export Formats
This new feature is discussed at length in §19.4 below.

•

Comment Back Color
Each comment may have a background color. Due
to limitations of original design (going back to
Expressionist 30 years ago), we cannot back color individual subobjects (words or math expressions inside of
comments).

A nice comment
A nicer comment with a bright background
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•

Propositions Tree
This was moved from the old Notebook menu over to
here. Seems more natural here. This menu allows you
to move propositions to different parts of the notebook
tree. Usually you indent via dragging objects in the
notebook tree.
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Notebook Menu

The old Formatting menu has been removed, and the two main items
in that former menu, Set Font Math and Comment Prefs, are now
on the main level of the menu. Otherwise this menu has not changed.
Insert Menu
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This menu is entirely new. The goal of this menu is to address the
age-old question, “but how do I get that in there?” Many of these
items are available in the Palette, some were inserted via special (and
not well documented) keystrokes. Over the years in working with
novice LiveMath users, it became clear that a central menu location
was required that held all of the possible inputs into LiveMath.

Likely you will not use this Insert menu as the primary insertion
method, but rather you will continue to use the Palette and/or
keystrokes. But when you get to the need to insert something, and
you forget where in the Palette it is located, or you are working with a
novice user, or forget which keystroke does the insert, this Insert menu
will be very helpful. The keystrokes are shown in the menu when there
are keystrokes for a specific command.
The Insert ▶ Statement submenu has the two most common
entry options: New Math Assumption and New Text Comment.
It is unlikely you would use these menu options to get either new
objects into a notebook, but for novices just starting out who often get
confused about the different between a Math Assumption and a Text
Comment, well, there they are. With the keystroke reminders as well.

▶ Basic Operations submenu is rather obvious not needing
explanation:
Insert
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▶ Graph Primitives submenu is a menu version of the
Graphics Primitives collapsar inside of every New Notebook, for the
purpose of getting a blank graphics primitive into the notebook, for
those (like me) that like to build up your graphs manually, without all
of the entry processes of the Graph menu.
Insert

If the current selection is inside of a Graph Theory (2D or 3D), then
any of these menu options will insert a new graphics primitive into that
theory (even another graph, so beeeeeeee careful!).
If the current selection is outside of a Graph Theory, these menus will
insert the chosen graphics primitive, but outside of a graph theory, the
SurfaceAt primitive will not do much (anything).
Surface at ? where ? and ?; April Lighting
Solid

White

coloring;

surface has mesh

and is shaded using

is the solid color.

No graph theory
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The slots for any of these graphics primitives are blank, so you have to
do all of the work to bring life to them inside of a graph theory:
LiveMath Graph Alert: Graph in
process of changing. Maybe you are
not finished typing? Please finish
typing/entering, then CLICK on this
Graph to REDRAW. For now,
LiveMath cannot draw this graph: A
range specification must be of the
?
form:
variable = a...b.

− 3 ... 3 = west...east Stretch to Fit
− 3 ... 3 = south...north cropped
Moderately

− 3 ... 3 = bottom...top

as seen through a

lens

Normal

Graph Building Blocks

Surface at ? where ? and ?; April Lighting
surface has mesh
Solid

White

and is shaded using

coloring;

is the solid color.

Manually entering the (correctly formatted) data, you can then customize your surface:
0.6
0.4
0.2
0
0.6 0.4 0.6
-0.6x-0.4-0.6
-0.2
-0.4
y -0.200.20.40.2
-0.2
-0.4

z

-0.6

− 0.75 ... 0.75 = west...east Stretch to Fit
− 0.75 ... 0.75 = south...north cropped
Moderately

− 0.75 ... 0.75

= bottom...top

as seen through a Normal

lens

Graph Building Blocks
3

2

Surface at s t , t − s , s t where
t = − 1 ... 1 and s = − 1 ... 1;
surface has mesh
April Lighting
and is shaded using Solid

White

is the solid color.

coloring;
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The Insert ▶ Lower Greek and Insert ▶ Upper Greek are
self-explanatory, with the Mac: W or Win: a keystrokes.
The easiest keystrokes for greeks are the apostrophe-based keystrokes:
Z
‘ a = α
Likewise Insert ▶ Symbol is self-explanatory, giving the miscellaneous symbols available in LiveMath.

The Insert ▶ Wildcards gives a visual description of the different
types of wildcard variables. These are for advanced users of LiveMath
who are doing Transform rule programming. But, of course, wildcard
variables are used for defining simple functions, too. The keystrokes
?X are not shown, as these are too specialized to get into the
menus as we would want to show them. (Mac does not consider ?a as
a keystroke, although it is to LiveMath).
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The next insert menus:
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are all self-explanatory.
The last submenu, Insert ▶ Comment Extras, are inserts that only
work in the comments:

These are constructions that only work inside of the Text Comments,
and are borrowed from PrintMath. The Block is the most useful in
the text comments for building up a complicated object (that may or
may not have any mathematical meaning, but certainly does not have
support inside of LiveMath for calculation purposes)
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?
?
2
3

4

In general, the other mathematical object inserts work for both math
computational areas, or in text comments, inserting the different
objects appropriately:

?
?

? d?
?

?

?

Compute Menu
The Compute menu has been reorganized, with the goal of greater
simplicity. It is a big menu, and I almost split it into 2 menus, but
there didn’t seem to be a natural separation point to do that. So, 1 big
menu it is.
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The Solve Numerically options is a menu command that is still under
development, and will appear in a future minor release.
The Macros areas are the computations that are “multi-step”, as
described in §19.11.
Graph Menu
The Graph Menu is largely unchanged in LM 3.6, although there is one
addition in the Graph ▶ Graph 3D menu with graphing a Parametric
Surface via the menu command on a selected 3-vector with 2 independent variables, 1 dependent variable (Matrix variable):
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This will trigger a variable match-up dialog:

and voilà:
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10
5
0
-10
xy 0 1010
-10
-5

z

-10

− 18 ... 18 = west...east Stretch to Fit
− 18 ... 18 = south...north cropped Wide
− 12 ... 12 = bottom...top as seen through a
Slight Telephoto

lens

Graph Building Blocks

Surface at T where s = west ... east and
t = south ... north ; April Lighting
surface has mesh
Solid

White

coloring;

and is shaded using

is the solid color.

Examples and Help Menus
These menus have not changed, although some references to LiveMath
Plug-In, which is now retired, have been removed.

19.4 Copy/Save as PDF & PostScript
Screencast Video
http://www.LiveMath.com/v/1904
Nearly 6 years ago, during a “hack attack”, I wrote a little converter
to take our wonderful PostScript output of all things in LiveMath
(and PrintMath), and convert it to PDF using a nice little Apple API
function I found. (It is the same function that Preview uses when you
double-click on a PostScript .ps file, converting it to PDF, which is the
Mac’s “natural” graphics format since OSX).
This little feature lay dormant in the source codes until now. Better
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You may now highlight objects in a LiveMath notebook, and select:

and you get into the Clipboard the beautiful PostScript-quality PDF
output for pasting into other programs like Microsoft Word, or Adobe
InDesign, which is the layout program this The LiveMath Book is written in. So you can see the quality of this output method in this book.
Note the keystroke: WUc It comes in very handy.
You may also Save selections out to PDF files, or copy/save the raw
PostScript (PS) data.
The Copy As PDF options are only available on the Mac side. I have
to write the cross-platform PDF writer, which is under development,
and will appear on the Windows and Linux versions in a future minor
release.

19.5 Copy/Save from PrintMath
Screencast Video
http://www.LiveMath.com/v/1905
If you have more complicated math expressions you wish to have in
Text Comments, you may use PrintMath to create these expressions,
and copy/paste them into LiveMath Text Comments.
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And then copy/paste into LiveMath:
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You might want to get wild and create PDFs to copy/paste into
LiveMath. That won’t work with the current older-technology version
of LiveMath on Mac (or Windows for that matter). On the Mac, you
will need to use Preview to copy/paste your PDF to first, which will
convert the PDF to an older PICT-image. On Windows you will do
essentially the same, but using Paint.

19.6 Drag & Drop Add To Graph
Screencast Video
http://www.LiveMath.com/v/1906
Drag & Drop Equations Onto Graph Theories
When you have a graph object, like this:
z =xy

5

-2

x-2 y

0

0

z

2

2

-5
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you may wish to add another graphical object to this 3D graph: let’s
say another surface plot. The (new to LM 3.6) method is to simply
drag your new equation onto the 3D graph:

And the result (after approving the variable-to-space coordinates
dialog)
z =xy

5

-2

0
x-2 y 0 2
z

2

-5

z 1 = x 2+ y 2

Let’s look inside of the Graph Details box to see what that Drag &
Drop action did for us:
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z =xy

5

-2

x-2 y

0

0

z

2

2

-5

− 3 ... 3 = west...east Stretch to Fit
− 3 ... 3 = south...north cropped
Moderately

− 9 ... 9 = bottom...top
Normal

lens

as seen through a

Graph Building Blocks

Surface at x , y , z where
x = west ... east and
y = south ... north ; April Lighting
surface has mesh
Solid

White

coloring;

and is shaded using

is the solid color.

Surface at x , y , z

1

where

x = west ... east and
y = south ... north ; Illuminated
surface has mesh
Solid

White

coloring;

and is shaded using

is the solid color.

z 1 = x 2+ y 2

We can see that a second SurfaceAt graphic primitive was placed
inside of this 3D graph object, with the z 1 dependent variable in the
z-coordinate slot. You could now fine tune this new SurfaceAt object
to a different color scheme, or different mesh setting, etc.
Drag & Drop Comments Onto Graph Theories
The Drag & Drop feature attempts to figure out what you want to
do with the drag, and tries to be as forgiving as it can be for novice
mistakes.
If you drag a Text Comment into Graph object, a copy of the Text
Comment will be used to create a TagAt graphic primitive inside of
the Graph object:
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The drag results in:
z =xy

5

-2
-2

Saddle Surface

0

xy 0
z

22

-5

Saddle Surface

The drop point inside the graph is used to place the Comment, so if
you drop the comment on the bottom left of the graph window, the
TagAt is placed there (approximately, of course, in the 3D graph
window case). You may, of course, adjust the new TagAt graphic
primitive to customize it as you like. You may also have a text comment with images inside of it - those, too, will get inserted into the
TagAt text comment:
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z =xy

5
0

-2
xy 0
LiveMath
-2 rocks!
z

Saddle Surface

22

-5

Saddle Surface

LiveMath rocks!

Anything you can put inside of a Text Comment: text, typeset expressions, images - all of these can go inside of a live Graph object.
Remember that the text comment is copied into the Graph object at the
time you make the Drag & Drop action. If you change the Text Comment later, the copy inside of the Graph object does not change with it.
Drag & Drop Functions Onto Graph Theories
LiveMath is notoriously persnickity about how you graph a function
f(x) or f(x,y). Technically you should set up a function defined with a
wildcard variable, and then create a dependent variable relation with
the function, like this:
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f x = x sin x
y =f x
1.5
1

y

0.5
-2

x

0

2

With Drag & Drop, we loosened the rules a little bit. So you could
define a function g(x) and drag & drop that onto the 2D Graph object,
and LiveMath will create the dependent variable relation for you:

Results in:

f x = x sin x
y =f x
1.5
1

y

0.5
-2

x

0

2

Stretch to Fit
− 3 ... 3 = left...right
0 ... 1.8 = bottom...top cropping Moderately

Graph Building Blocks

Curve at x , y where x = left ... right with a
line, colored Black
.
normal
Curve at x , g x where x = left ... right
with a heavy
line, colored Red
.

g x = x − tan x
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Notice that LiveMath put the function actually in the y-coordinate spot
in the CurveAt graphic primitive. You may be wondering: how did
LiveMath do that function call without wildcard variables?
Ahhhh. LiveMath cheated for you a little. Notice there is a little
collapsar below the g(x) definition. Let’s have a look:
f x = x sin x
y =f x
1.5
1

y

0.5
-2

x

− 3 ... 3 = left...right

0

2

Stretch to Fit

0 ... 1.8 = bottom...top cropping Moderately
Graph Building Blocks

Curve at x , y where x = left ... right with a
line, colored Black
.
normal
Curve at x , g x where x = left ... right
with a heavy
line, colored Red
.

g x = x − tan x
g x = − tan x + x
x =x

Substitute

LiveMath did the standard trick of substituting

x =x
into the regular variable definition of g(x) to create the wildcard
defintion of g(x), and made a Hot Dot on that substitution Conclusion
statement to make it the Working Definition of g(x).
We do this trick manually all the time. The Drag & Drop mechanism
does it for you, trying to save yourself from yourself.
Drag & Drop Parametrics Onto Graph Theories
If you try to drag a 2-vector like this:
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You won’t get very far. LiveMath will just go thud. But put a nice
dependent Matrix in a relation with that 2-vector, and you’ll be good to
graph with Drag & Drop:
f x = x sin x
y =f x
1.5
1

y

0.5
-2

x

0

2

Stretch to Fit
− 3 ... 3 = left...right
0 ... 1.8 = bottom...top cropping Moderately

Graph Building Blocks

Curve at x , y where x = left ... right with a
line, colored Black
.
normal
Curve at x , g x where x = left ... right
with a heavy
line, colored Red
.
Curve at T where t = − 3 ... 3 with a dotted
line, colored Blue

T = t 2, t 3
g x = x − tan x
g x = − tan x + x
x =x

.

Substitute

There are limitations for what LiveMath will try to compensate for.
If that T vector has what looks to be 2 independent variables, then
LiveMath will interpret that as a vector field plot request:
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1.5
1

y

0.5

x

-2

0

2

Stretch to Fit
− 3 ... 3 = left...right
0 ... 1.8 = bottom...top cropping Moderately

Graph Building Blocks

Curve at x , y where x = left ... right with a
line, colored Black
.
normal
Curve at x , g x where x = left ... right
with a heavy
line, colored Red
.
Vector field filled normally
Medium

from t , s size

pointing towards T where

t = left ... right s = bottom ... top with

One variable-length arm

colored Black

.

and an arrowhead

T = t 2, s t

Drag & Drop With Dependent Variables Onto Graph Theories
Usually LiveMath is very unforgiving with multiple dependent
variables that are the same symbol - you can only Hot Dot one of the
equations at a time - that is a fundamental construction (and power) of
LiveMath:
Same Dependent
Variable Symbols: y

y = x sin x
y = − x 2+1

But when you Drag & Drop an equation that may have a dependent
variable conflict with a previously graphed equation, LiveMath will
compensate with the some trickery to try to save yourself from yourself: subscripts are introduced, and the subscripted equation is hidden
under a collapsar of the original equation:
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Drag & Drop
New Equations
with subscripts
and substitution
automatically
inserted
under collapsar

y = − x 2+1
y1 = y

y 1 = − x 2+1
y =f x

Substitute

1.5
1

y

0.5

x

-2

− 3 ... 3 = left...right

0

2

Stretch to Fit

0 ... 1.8 = bottom...top cropping Moderately
Graph Building Blocks

Curve at x , y where x = left ... right with a
line, colored Black
.
normal
Curve at x , y
normal

1

where x = left ... right with a

line, colored Orange

.

The reason: this is what you would do yourself, manually, to get past
the multiple dependent variable problem. But for many of us, we just
like to see graphing equations with a pure “y” dependent variable,
without always having to go to subscripts or different letters.
Drag & Drop Points and Matrices Onto Graph Theories
You may also drag points and/or matrices to a graph window:

Drag & Drop
of a matrix of points:
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Drag & Drop

Make sure you have the dimensions correct! Otherwise, LiveMath is
not going to fix things up for you!
Drag & Drop One Graph Theory Onto Another Graph Theory
Sometimes you are building up a graph, and you want to get all of the
(major) graphics primitives copied over to a new graph. You may
do this easily by Drag & Drop one Graph Theory onto another Graph
Theory.
All of the major Graphics Primitives will be copied over to the new
graph.
2
0

x

-2

y0

2

-2

Stretch to Fit
− 3 ... 3 = left...right
− 3 ... 3 = bottom...top cropping Moderately

Graph Building Blocks

Curve at x , x sin x

2

where

x = left ... right with a normal
Red

.

line, colored

Scatter plot of − 1.75, 0 where ? using 10 point
colored Blue
.
spots
Curve at x , − 1 cos x
2

2

where

x = left ... right with a extra heavy
line, colored Dark Green

.
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If you drag a 2D Graph onto a 3D graph, the 2D graph objects objects
are copied over to the x-y plane (or the equivalent in that graph
theory).

If you drag a 3D Graph onto a 2D Graph, all of the 3D graphics primitives are squished to the x-y plane (simple coordinate projection).
The minor graphics primitives are not copied over with this operation:
Grid, Axis, nor any of the Name Declarations nor functional definitions. This would cause havoc is everything were copied over. The
goal of this operation is to quickly combine simple graphs together, not
address every pathological example of specialized LiveMath programming.
Drag & Drop Catalog
Here is a complete listing of all Drag & Drop Add Graph actions
All Graphs
Drag Object

Point/Matrix

Example

X = 1, 2
Text!

Text Comment

-2

0

xy0

Scatter
Tag

2

Graph Theory

Result

2

-2

Major Primitives
Adjusted for
Dimension

2D Graphs
Drag Object
Function

f : R1 → R1

Example

Result

f x = x2

CurveAt
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f x , y = x 2y 3

Contours

f : R2 → R2

f x , y = x y 2, x 2

VectorField

Equation 2 Variables

y = x2

CurveAt

Equation 3 Variables

z = x 2+ y 2

Contours

Equation 2-Vector

T = t 2, t 3

Parametric Curve

Equation 3-Vector

T = t , t 2, t 3

Equation 2-Vector

F = s t, t2

Parametric Curve
Projected to x-y plane

Equation 3-Vector

F = s t , s 2, t 2

Contours of
Parametric Surface

Example

Result

f : R2 → R1
Function

VectorField

3D Graphs
Drag Object
Function

f x = x2

CurveAt
in x-y plane

f x , y = x 2y 3

SurfaceAt

f x, y = y, x y, x

Parametric Surface

f x , y = x y 2, x 2

VectorField
in x-y plane

f : R3 → R3

f x , y , z = y 2, z 3, x

VectorField

Equation 2 Variables

y = x2

Equation 3 Variables

z = x 2+ y 2

CurveAt
in x-y plane

f : R1 → R1
Function

f : R2 → R1
Function

f : R2 → R3
Function

f : R2 → R2
Function

SurfaceAt

© 1999-2017 MathMonkeys, LLC. © 1999-2017 Robert R. Curtis

Page 630

The LiveMath Book

Equation 2-Vector

T = t 2, t 3

Equation 3-Vector

T = t , t 2, t 3

Equation 2-Vector

F = s t, t2

Equation 3-Vector

F = s t , s 2, t 2

Parametric Curve
in x-y plane
Parametric Curve
VectorField
in x-y plane
Parametric Surface

19.7 Marks
Screencast Video
http://www.LiveMath.com/v/1907
This little feature has been in place for many years, but hidden and
undocumented.
If you type into a math assumption: xVEC
You will magically get this:

x

The suffix VEC on the end of any Name Declaration gets magically
transformed into a Vector mark.
Historically LiveMath “names” in Name Declarations (variables,
functions, et al.) are strings of plain characters. In order to preserve
backwards compatibily with earlier minor releases of LiveMath 3.5, I
adopted this suffix VEC trick to get marks onto the variable or function names; if an older version of LiveMath opened a notebook with a
x that earlier version would simply see a xVEC as a variable name - a
bit odd, but it would not crash nor cause a variable conflict.
You may put a VEC suffix on any Name in LiveMath, so here are some
other examples:
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abcVEC
LiveMathIsCoolVEC

abc

Page 631

LiveMathIsCool

The following suffices will give the corresponding marks:
xDOT
xDDT

x

x

xDDD

x

xTIL

x

xVEC

x

xDVE

x

xBAR
xHAT

x
x

xARC

x

xBVE

x

xDBA

x

You may also make Marks using the menu command in the Insert
menu:
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The No Mark menu item in this submenu will undo a mark.
Warning: when you select and “x” and convert it into a xVEC = x
using the menu command, you are converting EVERY x in the current
notebook into an xVEC = x . You are actually changing the Name
Declaration that defines the name “x” into “xVEC = x ”. So be
careful! If you change such a variable globally, and you didn’t really
want to, just go find the Name Declaration and overtype over the
xVEC = x just x - this will convert it back.
You may also do marks in Text Comments areas as well.

19.8 Print Page Preview and Improved Pagebreak Printing
Screencast Video
http://www.LiveMath.com/v/1908
Suppose you have a big LiveMath notebook, and you want to print it
out (or output to PDF via the Print function, on the Mac with Save As
PDF, and on Windows with PrimoPDF or some other tool).
You may wish to fine-tune Page Break locations and other adjustments
so that the final output is more appeasing.
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To turn on Show Pagebreaks, select the menu item in the File menu:

Next, hold down the W on Mac or a on Windows, and you
will see the page delimiters show up:
Actual Page Break

Width of
Current
Page

Would-be
Page Break

The red line shows where the page break would be, but in this example,
the graph theory is in the way, so the page break needs to come before
the graph theory.
All of the calculations of page breaks are dependent upon the chosen
printer and Page Setup dimensions. In the example above, the Page
Setup shows this:
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If we change the Scale to 65% instead, we will see the change in the
Page Breaks:
Scale Change: 100%

65%
Page
Break
Change
Width
Change

I have this two part approach to showing these page delimiters because
the calculations of these page cut-offs is very hard on the system:
there are a lot of calculations going on, and you don’t want that heavy
burden of calculations happening all the time - especially while you
might be doing some drag calculations or something. This is a limitation of the older QuickDraw/Mac and GDI/Windows technologies.
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19.9 Inequality Solving
Screencast Video
http://www.LiveMath.com/v/1909

A feature that was snuck in a few years ago as I wrote a Precalculus
e-text was support for solving inequalities. As a first example, start
with:

−5x +3 > 7
With AutoSimplify OFF, you may complete this series of computations:

−5x +3 > 7
− 5 x > 7 − 3 Move Over
Isolate
x < 15 − 7 − 3
x < − 45 Simplify
You can do computations involving cases, similar to solving polynomial equations:
x 2−2x +6 > 9
x 2 − 2 x + 6 − 9 > 0 Move Over
x 2 − 2 x − 3 > 0 Simplify
x − 3 x + 1 > 0 Factor
x +1 > 0
x > 0 − 1 Isolate
x > − 1 Simplify
Isolate
x −3 > 0 1
x +1
x − 3 > 0 Simplify
x > 0 + 3 Isolate
x > 3 Simplify

x +1 < 0
x < 0 − 1 Isolate
x < − 1 Simplify
Isolate
x −3 < 0 1
x +1
x − 3 < 0 Simplify
x < 0 + 3 Isolate
x < 3 Simplify
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Note that each Case Theory here has the assumption conditions at the
top line, so the solutions are read off as:
		
		

x > –1 and x > 3
x < –1 and x < 3

x>3
x < –1

We can see this solution also with one of the (graphing) Macros, in
menu Compute ▶ Macros: Graphing ▶ Graph 1D Inequality

-6

x0

-4

-2

0

2

4

6

You may also try inequalities with functions as well:
sin θ <

1
2

θ < 2 π n 2 + 16 π Isolate
θ < − 11
π Substitute
6
θ < − 5.7596 Calculate
θ < 16 π Substitute
θ < 0.5236 Calculate
θ < 13
π Substitute
6
θ < 6.8068 Calculate
n 2 = −1
n2 =0
n2 =1

-6

θ 0 -4

-2

0

2

θ > 2 π n 1 + 56 π Isolate
θ > − 76 π Substitute
θ > − 3.6652 Calculate
θ > 56 π Substitute
θ > 2.618 Calculate
θ > 17
π Substitute
6
θ > 8.9012 Calculate
n 1 = −1
n1 =0
n1 =1

4

6

There are some other graphical solution Macros in the Compute ▶
Macros menu.
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19.10 Contour Plot Changes
Screencast Video
http://www.LiveMath.com/v/1910
Sometime since the last major update, a few small changes were
inserted into the Contour Plot primitive:
Contours at

matching

? where ? and ?; normally

spaced contours of

resolution, shown in normal

? computed with

line style, colored Red

with labels

Often Contour Plots need a higher amount of resolution (more points)
to make their graphs smoother. But if you have other graphic primitives in the same Graph Theory, you don’t necessarily want those other
primitives to have their resolution cranked up. So Contour Plots may
have matching resolutions to the Graph Theory, or you may change
that popup menu to a different, independent setting.
It used to be that Contour Plots had only a single line style - now
Contour Plots may have many different line styles, with Extra Heavy
the most useful, especially in a complicated Graph Theory.
It used to be that Contour Plots had only a fixed color: Black. Now
Contour Plots may have multiple colors like any other CurveAt plot.
Here is what Contour Plots could look like previously:
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2

-2

x

0

y0

2

-2

Stretch to Fit
− 3 ... 3 = left...right
− 3 ... 3 = bottom...top cropping Moderately

Graph Building Blocks

Contours at x , y where x = left ... right and
y = bottom ... top ; at zero only
2

3

2

spaced contours of y − x + x computed with
resolution, shown in normal
matching
line style, colored Black

with labels

And now with these new customizations:
2

-2

x

0

y0

2

-2

Stretch to Fit
− 3 ... 3 = left...right
− 3 ... 3 = bottom...top cropping Moderately

Graph Building Blocks
Contours at x , y where x = left ... right and
y = bottom ... top ; at zero only
2

3

2

spaced contours of y − x + x computed with
resolution, shown in extra heavy
highest
line style, colored Red

with labels

19.11 Macros
Screencast Video
http://www.LiveMath.com/v/1911
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The Macros area of the Compute Menu were designed to be semiautomated constructions in LiveMath that you could do manually, but it
would be a lot of work to do, and why not have a nice one-shot way of
doing these constructions.
An excellent example is the Macro for Completing the Square, a
standard algebraic computation in high school algebra. For years,
high school math teachers and students would write to me to ask,
“Can LiveMath Complete The Square?” The philosophy of LiveMath
dictates that the answer should be, “Yes, of course, but you need to do
it yourself!”

But it seemed that we needed to step back from that philosophy a
little bit, and help out with some calculations like this, rather than
just telling wayward students (and teachers) “yes, but do it yourself”.
These kinds of requests collected together to create the Macros menu
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area and functionality.

A typical problem in high school algebra of Completing the Square
might start with this equation:

y = x 2+3x
Selecting this equation and then the menu Compute ▶
Macros: Algebraic ▶ Completing the Square gives us:

y = x 2+3x
2
2
y −0 + 3 1 1 = x 2+3x + 3 1 1
21
21
2
9
9
Simplify
Simplify
y + 4 = x +3x + 4
y + 94 = x + 32

2

y = x + 32 2 − 94

Complete Square

Factor

Move Over

As you can see, all of the functionality shown in this computation
exists in LiveMath already, so it is not like there is a new “function”
called “Completing the Square” where the beginning equation is
simply transformed to the final answer. The idea of Macros was to
show students (and others) the steps involved in doing this algebraic
computation in LiveMath, that they could do on their own manually,
or use the Macro to get a little help from LiveMath on the steps to
complete.
Let’s look at each of the Macros menus a bit more in detail.
Macros: Arithmetic
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The Rounding macros are rather obvious in their goal. In the style
of Macros, these options actually try to teach you how you would set
up these functions in LiveMath manually: a new function is defined,
named “round”, that uses one of the predefined functions already built
into LiveMath.
A Function

named round behaves as Round to nearest integer

13.5
round 13.5
round 13.5 = 14

.

Calculate

The Factor Pairs menu was an interesting request from a teacher years
ago: to show all factorizations of a number, in factor pairs.

25 49
25 49 = 1225 Simplify
25 49 = 1225 1 Factor Pair
25 49 = 245 5 Factor Pair
25 49 = 175 7 Factor Pair
25 49 = 49 25 Factor Pair
25 49 = 35 35 Factor Pair
The Reduce Root helps a beginning in LiveMath deal with root simplication. If you try to Simplify this square root:

175
Nothing will happen. Simplify will not first factor the interior of
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the square root: you should do that manually yourself, being a good
mathematician. But in case you just learning how LiveMath works,
this Reduce Root macro will help you, and show you the process you
should follow:

175
175 = 52 7
175 = 5 7

Factor Root Base
Expand

Rationalize Denominator is another computational process that users
of LiveMath should do on their own, but the Macro helps you a little
bit to get there:

17
11
17 = 17 11
11 11
11
17 = 17 11
11
11

Multiply By One
Expand Expand

The Real and Imaginary Parts macros are similar to the Rounding macros: in LiveMath you should define a function and apply that function
to the object, using the built-in functions for Real and Imaginary parts.
Here the “Re” function is created and defined:
A Function

named Re behaves as Real part

19 − 7 i
Re 19 − 7 i
Re 19 − 7 i = 19

.

Calculate

The Complex Conjugate computation should be something that
LiveMath users do manually, but the Macro helps you this conclusion a
little bit:
A Function

named Conjugate behaves as Complex Conjugate
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13 − 4 i
Conjugate 13 − 4 i
Conjugate 13 − 4 i = 13 + 4 i
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Calculate

Macros: Solving

19.12 Miscellaneous
Screencast Video
http://www.LiveMath.com/v/1912

Arrows for scrolling up and down the notebook.
- Scroll arrows at bottom right of window for fine-tuned scrolling. No,
we can’t do gestures using older QuickDraw technology.
- f’ made nicer: extra space for prime on f’, but not for other letters.
Just a cheap hack for dealing with f ligature.
- Big Palettes: twice a big as small palette, with new artwork (stolen
from LM4)
- Printing: case theories will now print nicely, more compact, more
intelligent split up of pages.
- Printing to PS/PDF: now working correctly, using Postscript to create
the PDF and Preview
- New Menu Layout
- Insert Menu
- Name Declaration (variable, function) marks. For backward compatability, xVEC gives a x with a vector hat on top. The
insert->marks menu now changes that 3 letter magic suffix. when you
use this you are actually re-defining the variable, so be careful!
You can type these in manually as well. Give all 11 magic 3-letter
suffices.
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- Expanded math (from PrintMath) in comments
- Multiselect: Option key down, single-click on name/variable will
highlight all instances of this variable in the current object
- Drag Equation to Add to Graph:
- Drag comment to graph: make Tag out of it. Gets placed where you
dropped it.
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